summaryrefslogtreecommitdiff
path: root/sci-mathematics/fricas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 13:07:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 13:07:07 +0000
commiteb72a69c0109ff53b8c18b2f6c3b160489376e2e (patch)
tree6b1a11b63d1fa5f16537a183ee1800b8f0682d1b /sci-mathematics/fricas
parentafa7f3d7b9d6af29760049c9711a24821c77c8ec (diff)
gentoo auto-resync : 11:01:2024 - 13:07:07
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/Manifest2
-rw-r--r--sci-mathematics/fricas/fricas-1.3.10.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/fricas/Manifest b/sci-mathematics/fricas/Manifest
index 1426de0c38cc..627d2feb9eb0 100644
--- a/sci-mathematics/fricas/Manifest
+++ b/sci-mathematics/fricas/Manifest
@@ -1,4 +1,6 @@
AUX fricas-sbcl-2.3.9.patch 2339 BLAKE2B 484f46de176e5148d7a628551f70fe786f62716c30b20ec2db744e554fb06ceda8a9bc89e8ade987a34f9b92856492590497634886d46ab2917bb4b81a1905c1 SHA512 d16dc7bb46006bd50cf12b7758f58d22902a853a20b8febac2d96f151fe841181831f05a12f5fe88eb213ae9d71d8fe560ba078f214a7bfa961f7aa60ff74dcf
+DIST fricas-1.3.10-full.tar.bz2 10971513 BLAKE2B 0ea96cf1076dcd23f53ebdcd3ebf5c6e605915ce332093b83d62a5ed482d32f14833857e270865a4031d7bfc033d961c69007e936260e7d85e632b091d969e0d SHA512 de23c34a1e47b0a4ab2f85e1154e6fa5b0905427718e8c0ad4fe298bf6ebbb1abcc02426e528b7b34d15aebfc2ca1b06f73e39a24ec741d2d5c70f9b48b02665
DIST fricas-1.3.9-full.tar.bz2 10949173 BLAKE2B c535d2a384fa55db53b6901d3ba5d1cc8eca35ccf67a2664f934da427a808b5adc7a5522b935f5dcff89795c0ca5816818d9cf37399b6f9bdc63cfe4d622a7c3 SHA512 9cfcb8bad52550a46216509154d5c06dac23625bc14d504a1febbea7ff771fd3172f91c2824df51375b8d85adc19959a5cbbfa2b77a0095ca37e8a4d4b8cc405
+EBUILD fricas-1.3.10.ebuild 1923 BLAKE2B d94021c512cf71a9c7023a952852d956cb7f0f8fce7c396298ab84cde9dd2d8cdc0b89c4b90138953d629ee1bbe71d3d443ebe0a7285a0f7ea2533d11ac74f51 SHA512 d9f192dda0eb0a41587d88de1710c663ad723ce7cf49c7119f99e3f71efdff195a0224d3d09dcb05211abc9db928b6cef0324ba83188c502982de9ec250f0a45
EBUILD fricas-1.3.9-r3.ebuild 1988 BLAKE2B 0ca715f2fe05aaff11a0c5ac9958ff3b6fed7185e026fc80f0c8a69d94fad2121cabbbb89691da24bf35f19e3276943c82fd5ccb99d59ea6aea4d5f1a7833afe SHA512 0a4062314e24840031dab9278bf4f5422abe99309bdb7972b4bb6985174d88b1f5d364774dde0ca20afc61fa3241d9d220c52b733c879533c0bbd78659c68b63
MISC metadata.xml 1115 BLAKE2B dc1fcf98b2fb9df013ab256c4f81952ac5808f2761ae66479106482260b5328d337755fcb5208fa67ff7448c368d5db32a0c6c12537eaaa64d22a16cf32962ee SHA512 686316e67d08d27e48be2e544657c27ca20b8303b097b2154d18a2873ce39fe27c33be61a1922a3e61f89fadc9f4f6d204c9f591e670bcbf46ff2c71200f6660
diff --git a/sci-mathematics/fricas/fricas-1.3.10.ebuild b/sci-mathematics/fricas/fricas-1.3.10.ebuild
new file mode 100644
index 000000000000..96a81b24c204
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.3.10.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit elisp-common
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="https://fricas.sourceforge.net/
+ https://github.com/fricas/fricas
+ https://fricas.github.io/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-full.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+sbcl cmucl gcl ecl clisp clozurecl X emacs gmp"
+REQUIRED_USE="^^ ( sbcl cmucl gcl ecl clisp clozurecl )
+ gmp? ( ^^ ( sbcl clozurecl ) )"
+RDEPEND="sbcl? ( dev-lisp/sbcl:= )
+ cmucl? ( dev-lisp/cmucl:= )
+ gcl? ( dev-lisp/gcl:= )
+ ecl? ( dev-lisp/ecl:= )
+ clisp? ( dev-lisp/clisp:= )
+ clozurecl? ( dev-lisp/clozurecl:= )
+ X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ gmp? ( dev-libs/gmp:= )"
+DEPEND="${RDEPEND}"
+
+# necessary for clisp and gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP GMP
+ use sbcl && LISP="sbcl --dynamic-space-size 4096"
+ use cmucl && LISP=lisp
+ use gcl && LISP=gcl
+ use ecl && LISP=ecl
+ use clisp && LISP=clisp
+ use clozurecl && LISP=ccl
+
+ if use sbcl || use clozurecl
+ then GMP=$(use_with gmp)
+ else GMP=''
+ fi
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp="${LISP}" $(use_with X x) ${GMP}
+}
+
+src_test() {
+ emake -j1 all-input
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc README.rst FAQ
+
+ if use emacs; then
+ sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
+ -i "${D}"/usr/bin/efricas \
+ || die "sed efricas failed"
+ elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
+ elisp-make-site-file 64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}