summaryrefslogtreecommitdiff
path: root/sci-mathematics/flint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-mathematics/flint
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-mathematics/flint')
-rw-r--r--sci-mathematics/flint/Manifest2
-rw-r--r--sci-mathematics/flint/flint-2.8.5.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/sci-mathematics/flint/Manifest b/sci-mathematics/flint/Manifest
index bdab40575f4b..44aeeeddbf67 100644
--- a/sci-mathematics/flint/Manifest
+++ b/sci-mathematics/flint/Manifest
@@ -1,6 +1,8 @@
AUX flint-2.7.1-fix-cmake-findgmp.patch 5721 BLAKE2B db31d9e88304ec26a3fdd4ba9d53dd97044487413567e172235260fc238e6a4ad89225788726bdff94f36b699acda45c86025c23be04b895c1857d836a321113 SHA512 a364c4606fb9321443991d1356f9fb7b2c7fb946ad46760e6e1b1172acc1399f19fabd1eec4dbf8e75e1e61be5d8bfa88ac056ccff47d60f4d50fdff6e31193b
DIST flint-2.7.1.tar.gz 4945081 BLAKE2B 9dcc4b0062be08778cd8ada1794a73237ea091a7bff4a4673aa59eac9b414ed90e0291b9547bdf72aa30e48da11f98ff983267ea2e3dd1d75fcec00b24c86ca9 SHA512 abea97228e91089d82a9a44714e719064bef261c45f5f5b24700955bb841cc98a8182e04e6054fcbcaa3bd92f2f95a82bd5d168ec2171af6a58d4f71eb0a479a
DIST flint-2.8.4.tar.gz 5212964 BLAKE2B ddd3b9dca76ddac2070d3e12dfc4c5ea1a3b505c7bf28e41489798798d65ed2a5db12e01059816d42e5d1209166d17ee6035dcf0a94d991f78df59c6ad06b271 SHA512 1f66574a5f2f27e1f3cd0a334712c0e64f4a4b8dd57179a71f9adba4c4faff23ba8da3993f51c4f44f52a588d0d1678b1e1a272e8fe3367f2abc88e9d86ad804
+DIST flint-2.8.5.tar.gz 5212805 BLAKE2B 8922a2925b68d93fd35aa5b78eb0b8cbc6aa609498b8846ce4ff036c2fece3932a0eabb0f04a5c152147d8df3eccd6570832f55dafe4f7a35de135246454a83d SHA512 849fb61612f3becfde0d8afc019a9312a7ea07d3000a6bc558eb82babecd737e3af894d3084e4a57d52f7db0403d7298cbfa277b08e2b1f5497897637ed4825f
EBUILD flint-2.7.1-r1.ebuild 1372 BLAKE2B 4026ba6637f534d522ad3b7390ec491e764e440a913094fc98d9765b8cd3f89a0388099a56eb9805a2c588efc870d8cb7139b1d4daf8223314aed166b46b3162 SHA512 4f5cdebc04ff9888f5a235f4409b0428ba8ce4c18548c709cc0abf296254e6724f18d081f248f32c447c253af5dd7a71935bbd202e5789dd2b79981dd691a33e
EBUILD flint-2.8.4.ebuild 1527 BLAKE2B c74158618cb85471fda7e7a26b438f0d68ade93f0633ed34c65424488bb1b14b13dd7639ea599531099d87fb631474c26103d0c3e87233a589bb432c4c504399 SHA512 453b1404a1a99c8681d061b5373f50fb469122e45a1dd5c91be264f7714c8aeb5ffdca9c0d5e88d9c0c884c953b08ac094c680c012187f1bdece23f890514c87
+EBUILD flint-2.8.5.ebuild 1646 BLAKE2B 5b3d7c1b59f785be7edc541b780ed8993a1b06746f0b3b779173586bad765a396739087375cc4ce3df712afd8c94b2e5d86c4b32650c5ceead998a3817a7e186 SHA512 aa1e0e6ca27a895d8d5cba76fed384c2914cd5c2ef4d89120c728dfcfb6a7f50dc7a93685fcf442983bce25143fdc3cab346ece094cb37927abf0a0dcbf99356
MISC metadata.xml 640 BLAKE2B b95d6f493564025e43604bffa340fffd88fcedf29c282fcc3c18e08ac089cdf1e10837787af664dd250a77a62237bf3665ff0a3045ca52680dd67aa0b39eeba7 SHA512 a9a64076e7f0df29e6a05a9d349c530a4ee4285b6a444425681eddf6ae1e8b41f610fda0bd7cc86b5177b36f34bc3072b67c7edac2cc8c0709a032b000576a14
diff --git a/sci-mathematics/flint/flint-2.8.5.ebuild b/sci-mathematics/flint/flint-2.8.5.ebuild
new file mode 100644
index 000000000000..ade006fabbd2
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.8.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ninja doesn't like "-lcblas" so using make.
+CMAKE_MAKEFILE_GENERATOR="emake"
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+
+# flintlib.org tarballs have been broken in the past, Bill Hart suggests
+# we get them from Github (which he has control over).
+SRC_URI="https://github.com/wbhart/flint2/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+
+# Based off the soname, e.g. /usr/lib64/libflint.so -> libflint.so.15
+SLOT="0/16"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+IUSE="doc ntl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? (
+ dev-python/sphinx
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-tex/latexmk
+ )
+ ${PYTHON_DEPS}"
+DEPEND="dev-libs/gmp:=
+ dev-libs/mpfr:=
+ ntl? ( dev-libs/ntl:= )
+ virtual/cblas"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/flint2-${PV}"
+
+src_prepare() {
+ # https://github.com/wbhart/flint2/issues/1140
+ rm test/t-sdiv_qrnnd.c || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_NTL="$(usex ntl)"
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_DOCS="$(usex doc)"
+ -DCBLAS_INCLUDE_DIRS="${EPREFIX}/usr/include"
+ -DCBLAS_LIBRARIES="-lcblas"
+ )
+
+ cmake_src_configure
+
+ if use doc ; then
+ HTML_DOCS="${BUILD_DIR}/html/*"
+ DOCS=(
+ "${S}"/README
+ "${S}"/AUTHORS
+ "${S}"/NEWS
+ "${BUILD_DIR}"/latex/Flint.pdf
+ )
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc ; then
+ cmake_build html
+ cmake_build pdf
+ fi
+}