summaryrefslogtreecommitdiff
path: root/sci-mathematics/flint/flint-2.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-mathematics/flint/flint-2.6.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-mathematics/flint/flint-2.6.3.ebuild')
-rw-r--r--sci-mathematics/flint/flint-2.6.3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-mathematics/flint/flint-2.6.3.ebuild b/sci-mathematics/flint/flint-2.6.3.ebuild
new file mode 100644
index 000000000000..d6ba11ee4b12
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.6.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+SRC_URI="http://www.flintlib.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/14"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc ntl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? (
+ dev-python/sphinx
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+ ${PYTHON_DEPS}"
+DEPEND="dev-libs/gmp:=
+ dev-libs/mpfr:=
+ ntl? ( dev-libs/ntl:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.0-multilib-strict.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_NTL="$(usex ntl)"
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_DOCS="$(usex doc)"
+ )
+
+ cmake-utils_src_configure
+
+ if use doc ; then
+ HTML_DOCS="${BUILD_DIR}/html/*"
+ DOCS=(
+ "${S}"/README
+ "${S}"/AUTHORS
+ "${S}"/NEWS
+ "${BUILD_DIR}"/latex/Flint.pdf
+ )
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cmake-utils_src_make html
+ cmake-utils_src_make pdf
+ fi
+}