summaryrefslogtreecommitdiff
path: root/sci-mathematics/easycrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-mathematics/easycrypt
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-mathematics/easycrypt')
-rw-r--r--sci-mathematics/easycrypt/Manifest2
-rw-r--r--sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index 83a04e2b33be..5236f5665c12 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1,3 +1,5 @@
DIST easycrypt-1.0_pre20211210.tar.gz 1185137 BLAKE2B 3557a8b0423109a3b3e6e02f6d1ad88f07847d105015546c90b5a46cf514f1311390d3a6f6476c042420b91a62ad095919f7ab616adee2778165d9d081070730 SHA512 0043eac02e916dc46ed1cb4f278f148f915d09f336e904b1a711c18d62cda177e434fc13682ec095a085e458ba90ca8dd02968206af60f0b80a378f16b205553
+DIST easycrypt-1.0_pre20220303.tar.gz 1193244 BLAKE2B f4d4b0661b7c58d9dd2c344efac45aa4257b46122cef81f98ced05792c1e4dd49d332421f09d0b11a28893096042a98a7415d06e1624aaa59cea0c71f17f4bb8 SHA512 bd9f1638631c9539aea3ee369705fbaafa06d575db395b3d170642af2450b7df735a18fe8f6aa6e8904eae62bdcd30743ab734f7c17c583ece7c146fee1bcf77
EBUILD easycrypt-1.0_pre20211210-r2.ebuild 997 BLAKE2B 478ad9edc20d1da5f92c52fecf0d642591d926accc3040eb0eec9406fe99db24455b525d4334d5859bcc20e0cc472cb49ff005dc042151ba403cc0fc765f94a9 SHA512 ab80d2e314d2bde1877967bbec78c9226750fa5d8b80bddd5cdb2beeea26b478f5b4274ac10e4d3fba3d3c5e49a7762b061e1b4f433d51008dd4a60aa6a3f468
+EBUILD easycrypt-1.0_pre20220303.ebuild 997 BLAKE2B 323b45bd51376db37ac84b6205fc5d82647019a2a8473c34fe2d3fe53fe72b4d2e5a01aa13f862088b240328ae13d5aeb8d75b194cd84a73dd13ab76c2803e37 SHA512 ad99ec439aa7e855fb602d6ddcfde4a7bd829b28950c7489b9a50166fa862db1784d592e6bcdc6b863243a528de179a07ef65a3c3a2990d9eaf9a9e27770751b
MISC metadata.xml 799 BLAKE2B 967a758171a2fe87b648a29bf2663beaae7834119e55a7619c98518c96cfe459e59fe5dc72a9faea071c0b488dc8144f1c0e43677ac63646f1ba12cf831f4a88 SHA512 411ff1acad400c3e70e546fd59b20db13b0f1db121aca9f1af23da708cd82340114bc966f64cfb5a35e84967c1131c660ab260f867639932c67edf47c859c4ca
diff --git a/sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild b/sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild
new file mode 100644
index 000000000000..84353ee281ec
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=c98b014c131b6c0b147b852902953dd6c5771603
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${H}"
+fi
+
+LICENSE="CeCILL-B CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.4:=
+ dev-ml/batteries:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}