summaryrefslogtreecommitdiff
path: root/sci-mathematics/dunshire
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
commitd8a7472fc6314625f7d16e0427004eb448412908 (patch)
tree0dba2e223a5a5e200a4b84a4a5e3ff690e5059e7 /sci-mathematics/dunshire
parent8e49340ce0aaf205556648d8fa27dd30e8cf4435 (diff)
gentoo auto-resync : 09:09:2024 - 12:30:03
Diffstat (limited to 'sci-mathematics/dunshire')
-rw-r--r--sci-mathematics/dunshire/Manifest2
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild20
2 files changed, 14 insertions, 8 deletions
diff --git a/sci-mathematics/dunshire/Manifest b/sci-mathematics/dunshire/Manifest
index 9e62571841e5..65ae812ea476 100644
--- a/sci-mathematics/dunshire/Manifest
+++ b/sci-mathematics/dunshire/Manifest
@@ -1,3 +1,3 @@
DIST dunshire-0.1.3.tar.gz 52450 BLAKE2B 047f732daa7f2a53b8d24ea0aafdad3234aa5ee151a66f776ba22746d58b4b91a5047ba615978d4017e56345ac608fd1f537adef06f38b5a429276e284a88d02 SHA512 227d142347ad7b7eb5b283aaa94f457b20b686f40aa86b2a74057eed00d3d90e87fb4a0f32071db3bd73412489794a0b398a557f8194931a6e7d51ff442aa2b0
-EBUILD dunshire-0.1.3-r1.ebuild 851 BLAKE2B 15c1f147cb48bb4d9f8e09e2adf048c0db373f33f7df40596c22ab8a90418b0874daa9fde7931000e68c7e1953306deeb8e55b99a8973f29439fdf6314bf73e0 SHA512 fa54d4226d1f8078eee90b371611821eb02aca8cfa183c41871a36aac10d62eaf1b86bd4c25b8b963f63b48eda5a0dd6d41b169c5e3e7b9f54dc1fbd54303bbc
+EBUILD dunshire-0.1.3-r1.ebuild 719 BLAKE2B 679250a87250bc36635f7df83d877af9d5726bed7b310fcc40aaf4e08ba236f5d76bb04451da248aaef1c79472e13d381a8c392e75a3a04dee254b2c6d69edcb SHA512 e85fb5dcd889e617269d54629a46c7f814e4c2e42c1986828a0a0af4cd520031159ba77c176589df30879b63aa9f83185e24c1ecfd9b40a4d6d1a8c67edce81c
MISC metadata.xml 329 BLAKE2B e9cf64a4fd7f360e350a97ca0a9efe8e64ce485f2b025e456271c8e3d8bbf3f6950750a157eaa66e0639a800285351f84abd07789697acfbaf5422b9cb725ec6 SHA512 f8f757c9f662dfba3c0717720a7d2fe6e2c2bea517d6811cf9785d39cef92714c0ddddf3c56eecb6be37fc97fcd6ebdeba0412108b41ffc0c9cdde34c3e8a74a
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
index c98c5b6bf51d..348bf1942132 100644
--- a/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
+++ b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
@@ -5,26 +5,32 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
DESCRIPTION="Python library to solve linear games over symmetric cones"
HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/cvxopt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
-RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
DOCS=( doc/README.rst )
distutils_enable_sphinx doc/source
-# There are no additional dependencies even though we're not really
-# using setup.py to run the test suite any more. The __main__.py
-# runner has its own exit code handling.
-distutils_enable_tests setup.py
-
python_test() {
PYTHONPATH="." "${EPYTHON}" test/__main__.py --verbose || die
}