summaryrefslogtreecommitdiff
path: root/sci-mathematics/dunshire
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /sci-mathematics/dunshire
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'sci-mathematics/dunshire')
-rw-r--r--sci-mathematics/dunshire/Manifest2
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1-r1.ebuild (renamed from sci-mathematics/dunshire/dunshire-0.1.1.ebuild)17
2 files changed, 13 insertions, 6 deletions
diff --git a/sci-mathematics/dunshire/Manifest b/sci-mathematics/dunshire/Manifest
index 1558f3847adb..d52424969367 100644
--- a/sci-mathematics/dunshire/Manifest
+++ b/sci-mathematics/dunshire/Manifest
@@ -1,3 +1,3 @@
DIST dunshire-0.1.1.tar.gz 300878 BLAKE2B b0ed57e535313fbc653fdc7c8fd32fb98382db71dfe419e315f4b82fc4630e47757d74b9105e846b2eefaa7dcd93b12886eee341b11d0e8b562a52e480478e9a SHA512 5cdf8125d7fc1f76a483009392360e9e9088f9b58ca3f123d14e366421e831e4e7c8e17d367ba0430fb3cd61873cae7a004c903ff5417bfc9adecb7831681081
-EBUILD dunshire-0.1.1.ebuild 716 BLAKE2B 3299010971dd19a8e2fc82718629296221c73277b0c54a54ff9f96dd821e008e6e099e03731cf23e3e7338db506bf7ff7907871454e94c59c1f62dd4e5714169 SHA512 8c8605f04a6f5024844fd4f522c0ce9cb706768dd04ad58cdb95a0b1664fc2aedb308c7bd6f14ba581f5f42beb537dc69e928103cceeb1a15df98bc4b00b10ed
+EBUILD dunshire-0.1.1-r1.ebuild 973 BLAKE2B 8481023de71fb16fa09cd88aeb25de4f065a7e6f63c33c9850bfa8c038c84c51d826b6b372da0044d9e2ba70c09ac2a83fe9cac7c277e70e369f6721cad93067 SHA512 2a42b93acfe5d2c857de4a233cf516b3c4643c3b1bea920feddbefe31adf3268eb1454622cef7ea98b80807954b470a4fd0bea37c48d9b06fa397082612b1692
MISC metadata.xml 328 BLAKE2B 16beb1fab1e231e2bb2c8088729c9ab6fa1d4ab06f12f1da462fdeb18738d5fed80b28456df94b2af14f97855042d356b7f69ef956524c456bae62e12b4ba499 SHA512 1ae4898a1247c78ba707aa6e38819cbc5277e46fd32d3ca1172c70c18f42247624755262e3886a2deee76d2a39a3a54750edbc2d77a339543741c2488b095e45
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1-r1.ebuild
index 82de99fb080f..2824f031c377 100644
--- a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
+++ b/sci-mathematics/dunshire/dunshire-0.1.1-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit distutils-r1
DESCRIPTION="Python library to solve linear games over symmetric cones"
-HOMEPAGE="http://michael.orlitzky.com/code/dunshire"
+HOMEPAGE="http://michael.orlitzky.com/code/dunshire/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="AGPL-3+"
@@ -18,8 +18,15 @@ IUSE="doc test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Tests run on the build host? Bug #693916. There's one doctest that
+# uses a numpy matrix, sorry. That will be fixed in the next release.
+# Otherwise numpy is not needed; the required interfaces are provided
+# through cvxopt.
+BDEPEND="test? (
+ ${RDEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+)"
python_install_all() {
use doc && local HTML_DOCS=( doc/build/html/. )