summaryrefslogtreecommitdiff
path: root/sci-mathematics/dsfmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /sci-mathematics/dsfmt
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'sci-mathematics/dsfmt')
-rw-r--r--sci-mathematics/dsfmt/Manifest3
-rw-r--r--sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild9
-rw-r--r--sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch12
3 files changed, 22 insertions, 2 deletions
diff --git a/sci-mathematics/dsfmt/Manifest b/sci-mathematics/dsfmt/Manifest
index f4ed40b09dd2..a7c489145c1f 100644
--- a/sci-mathematics/dsfmt/Manifest
+++ b/sci-mathematics/dsfmt/Manifest
@@ -1,3 +1,4 @@
+AUX dsfmt-2.2.4-cc.patch 371 BLAKE2B 145ed23ce532abd33b8b9f76bd2f0a8afce2f62cd7e03fe6f8a15f49f276504793fe3f32f18793776be2b854b75eb9ddb0a0a41a8bd72e4e5160a5a1468b220b SHA512 45c518b57fe2a2ff536732971437c6f8452c0265ad00d2509cc14d08d816fa57e2023ad8cf1768d346c1bd25d36e9337dc2e7dcf9e7d894e01308d4ac657676f
DIST dsfmt-2.2.4.tar.gz 4984255 BLAKE2B 6119445d93cb45faab28dfb52a18c07cd5703b243b3cddde35fff7a5e948fa8788dfe8428ae8e0a52604f91ac07fe7b3bb0f6c438ef93b5257b42baee9dfdec5 SHA512 fe84e986cbf198172340adfac0436b08f087643eca3f1ceccacde146cbfd8c41e3eb0dfbb062f7ca5f462db13c386abd7c269bc0cbefc9a0ecf97a8a8870a2e4
-EBUILD dsfmt-2.2.4.ebuild 827 BLAKE2B 77b57fff30b2f5683925b10f9c28459e35529be12cdd450ab0cb3ea84e568ae2d41364e18193a035b31f48f77363aaa6eae57ed4bb8b6c1faada28808430dd37 SHA512 e5b0cd957e026cbd37ecdb168f73a86da3c6929b2a83f8fff5ca28630af9c6e224ce9a630d940c1c80a2096aed112c84e60f7d122a402eba0975a84759f2a2ac
+EBUILD dsfmt-2.2.4.ebuild 904 BLAKE2B 24433f240445a880d36f3101414fa6c22945b577cb29e9ee597e2c1874e752e81b56d23013fd8a0dccfb68626fb1982cc8718487ce40a2b8ea83c9c488228506 SHA512 307ddddb83223d84e8f7a9124aeecd01fff71339cd9fe8f927137f4b4effa91abe45f1c3d325e12777b42c779e44d8b2e8132b3c8b7cf0253bc3e4101e0857d9
MISC metadata.xml 1022 BLAKE2B 71c2367894eb7cd7864291434125ea73c91367a859b741ed8631f769dd8b6c45b31e62034ea3db2034502742c61f41bf9624baf40282cbf236f639a8ea6c3625 SHA512 409417f357f2e3d8f80c4a1fdf692b0926806d5cc47a3a1ad0dc29658852b61ca4bbd6a72d1b50215fe3be999db5c0283ebf70c70352ad3abef234fd07ec56a1
diff --git a/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
index 5de399e78f8a..fb35881b936e 100644
--- a/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
+++ b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
@@ -11,15 +11,22 @@ MYP=${MYPN}-${PV}
DESCRIPTION="Double precision SIMD-oriented Fast Mersenne Twister library"
HOMEPAGE="http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT"
SRC_URI="https://github.com/MersenneTwister-Lab/dSFMT/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MYP}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-S="${WORKDIR}/${MYP}"
+PATCHES=(
+ "${FILESDIR}"/${P}-cc.patch
+)
soname="lib${MYPN}.so"
+src_configure() {
+ tc-export CC
+}
+
src_compile() {
emake CCFLAGS="${CFLAGS}"
$(tc-getCC) -fPIC -shared -DDSFMT_SHLIB -DDSFMT_DO_NOT_USE_OLD_NAMES ${LDFLAGS} ${CFLAGS} -Wl,-soname=${soname} -o ${soname} ${MYPN}.c || die
diff --git a/sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch b/sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch
new file mode 100644
index 000000000000..fda30002ad7d
--- /dev/null
+++ b/sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch
@@ -0,0 +1,12 @@
+# https://bugs.gentoo.org/780936
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,7 @@ OPTI = -O3 -finline-functions -fomit-frame-pointer -DNDEBUG \
+ #STD = -std=c89 -pedantic
+ #STD = -std=c99 -pedantic
+ STD = -std=c99
+-CC = gcc
++CC ?= gcc
+ CCFLAGS = $(OPTI) $(WARN) $(STD)
+ ALTIFLAGS = -mabi=altivec -maltivec -DHAVE_ALTIVEC
+ OSXALTIFLAGS = -faltivec -maltivec -DHAVE_ALTIVEC