summaryrefslogtreecommitdiff
path: root/sci-mathematics/dataplot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-mathematics/dataplot
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-mathematics/dataplot')
-rw-r--r--sci-mathematics/dataplot/Manifest2
-rw-r--r--sci-mathematics/dataplot/dataplot-20131220.ebuild25
2 files changed, 20 insertions, 7 deletions
diff --git a/sci-mathematics/dataplot/Manifest b/sci-mathematics/dataplot/Manifest
index 4b89516a9e8b..2f0f00ca43e7 100644
--- a/sci-mathematics/dataplot/Manifest
+++ b/sci-mathematics/dataplot/Manifest
@@ -4,5 +4,5 @@ AUX configure.ac.20131220 2282 BLAKE2B 1ee098443f8aaba696b93948d62b6ed31fae8d14e
AUX dataplot-20090821-opengl.patch 1678 BLAKE2B 9b45ca716ba2ad053eac04942ee174a9ac6a5e6f6d451eedee03e18e6ebc0b13de866827a16eb9dce7de00881b1d7e53e61c99e8630c25c8eb0005696f9b8cf1 SHA512 cff8c08458c6d7ae57faa9e32ccf42b42adb9797b6b514aa597c34d5067935fefb5d1da9abf14ea2a74c17d3862d6b844f2e244895fb167fbce0b7b352f5dc07
DIST dplib.2009_07_15.tar.gz 7507367 BLAKE2B 5eec49feb1e90d479547955e5717e8e49eed18f78bae5942881511becf517986c8ba8e2f7513000c52fbb1686cc31fadf38ac61fb1f0822283f6b4fa9dd6431b SHA512 5e4e6c866a5690c3f67b322d53b6bf1bec33c488a99c95f360ce74785a57286541945fdcab5cbbacb04039046f5ba94aeaf8112b80aa34ed2c2cf04abc6f7d40
DIST dpsrc_2013_12_20.tar.gz 6761551 BLAKE2B 029d278ebc025d0e902b2b37743f0ad53c567463d7929d69c7c1fe291b9355c29766035b9747f184ca28035eac2954ad391a7039da7151e7a5391ba123c6ac3f SHA512 a62df14f3ec59ccae4ead52b34adfc6e881ade1397e5a31b8a73c9740e7a2245317fef4f9756224c8d2fb57799c2247b15f6c4d65777de6302553fd138bb4083
-EBUILD dataplot-20131220.ebuild 2020 BLAKE2B 8f124e353fda5b06a4b019198ec359994ba76251bd855ea545df8e4cc4c58a2a8de5561a6f73e378b5dfc3ff9139a88e8d30ebbfb38142c77b3aebf8d2b4f617 SHA512 070dac0662c6bd1a6c985d983c48c9bf730b4de20162c466c8719129c6348263a3bee0b754827816f6b5131288ae5aa21395b6fee1177ddb0f1e6cdcf44a8e06
+EBUILD dataplot-20131220.ebuild 2198 BLAKE2B 8fe1b659e1ffc212c78dea11658987556cd9a65824154205513111251beca56bf97854d8451f99899576c95c5fb9ac07ef85fae9a8cd73437fe649f4383bd72d SHA512 a7a1d49b106bdfd0279642e0e54c3da7ab9a834ec260421df93fcc8a5c056fec62de1eb6badb7e4c7ad3fd267a0f32144ed45299e55bf8d3849181da3031085e
MISC metadata.xml 729 BLAKE2B acf75410378db42d3283a67d95504885f28b80c206ca171645f296f0a77d03a3ab559bb31e37fd543c4c38a3b7ff9051f79a2b7fe09a3d495d214d271f2c98b4 SHA512 9e3ff791dba6c01cf997c725c10b4dc614c2785faba67504b68d9295eed65110be5cde92588ba9a3d89842a62709ac4ff69fda03f87e8929b21e5ec1335beb19
diff --git a/sci-mathematics/dataplot/dataplot-20131220.ebuild b/sci-mathematics/dataplot/dataplot-20131220.ebuild
index 11d223e7d7fd..ea559f7ade99 100644
--- a/sci-mathematics/dataplot/dataplot-20131220.ebuild
+++ b/sci-mathematics/dataplot/dataplot-20131220.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils fortran-2 toolchain-funcs autotools
+inherit autotools fortran-2 flag-o-matic toolchain-funcs
# YEAR MONTH DAY
MY_PV=${PV:0:4}_${PV:4:2}_${PV:6:2}
@@ -17,6 +17,7 @@ HOMEPAGE="https://www.itl.nist.gov/div898/software/dataplot/"
SRC_URI="
ftp://ftp.nist.gov/pub/dataplot/unix/${MY_P}.tar.gz
ftp://ftp.nist.gov/pub/dataplot/unix/${MY_P_AUX}.tar.gz"
+S="${WORKDIR}/${MY_P}"
SLOT="0"
LICENSE="public-domain"
@@ -34,7 +35,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
X? ( x11-misc/xdg-utils )"
-S="${WORKDIR}/${MY_P}"
S_AUX="${WORKDIR}/${MY_P_AUX}"
PATCHES=( "${FILESDIR}"/${PN}-20090821-opengl.patch )
@@ -43,9 +43,11 @@ src_unpack() {
# unpacking and renaming because
# upstream does not use directories
mkdir "${S_AUX}" || die
+
pushd "${S_AUX}" > /dev/null || die
unpack ${MY_P_AUX}.tar.gz
popd > /dev/null || die
+
mkdir ${MY_P} || die
cd "${S}" || die
unpack ${MY_P}.tar.gz
@@ -53,11 +55,21 @@ src_unpack() {
src_prepare() {
default
+
+ # bug #707176
+ append-cflags -fcommon
+ # bug #722208
+ append-fflags $(test-flags-FC -fallow-invalid-boz)
+ # another Fortran issue
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
cp "${FILESDIR}"/Makefile.am.${PV} Makefile.am || die
cp "${FILESDIR}"/configure.ac.${PV} configure.ac || die
+
sed -e "s:IHOST1='SUN':IHOST1='@HOST@:" \
-e "s:/usr/local/lib:@datadir@:g" \
dp1_linux.f > dp1_linux.f.in || die
+
sed -e "s/(MAXOBV=.*)/(MAXOBV=@MAXOBV@)/" \
-e "s:/usr/local/lib:@datadir@:g" \
DPCOPA.INC > DPCOPA.INC.in || die
@@ -76,9 +88,10 @@ src_install() {
default
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${S_AUX}"/data/*
+ docinto examples
+ dodoc -r "${S_AUX}"/data/*
fi
+
insinto /usr/share/dataplot
doins "${S_AUX}"/dp{mes,sys,log}f.tex
doenvd "${FILESDIR}"/90${PN}