summaryrefslogtreecommitdiff
path: root/sci-mathematics/cvc4/cvc4-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:09:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:09:35 +0100
commit963e79dcc85b2d1ff6167b5558b885d19cb0a6ad (patch)
treefc27f7984ca9e329255af0408d2a14313b1b6468 /sci-mathematics/cvc4/cvc4-1.6.ebuild
parent6260b15e6431fe568f4e548f696e150d467cd7f2 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'sci-mathematics/cvc4/cvc4-1.6.ebuild')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.6.ebuild b/sci-mathematics/cvc4/cvc4-1.6.ebuild
new file mode 100644
index 000000000000..1500f9d338da
--- /dev/null
+++ b/sci-mathematics/cvc4/cvc4-1.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="automatic theorem prover for satisfiability modulo theories (SMT) problems"
+HOMEPAGE="http://cvc4.cs.stanford.edu/web/"
+SRC_URI="http://cvc4.cs.stanford.edu/downloads/builds/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cln"
+
+RDEPEND="dev-libs/antlr-c
+ dev-libs/boost
+ cln? ( sci-libs/cln )
+ !cln? ( dev-libs/gmp:= )"
+DEPEND="${RDEPEND}"
+
+src_configure () {
+ econf --enable-gpl \
+ $(use_with cln)
+}