summaryrefslogtreecommitdiff
path: root/sci-mathematics/cudd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 01:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 01:47:04 +0000
commit8bb75334c4b9f91e9f95784e986ed31b4bc11f92 (patch)
tree8abc434e6b84ebe89eee2e7ae9687354cdf8d2c8 /sci-mathematics/cudd
parentf74222a7b6daa24caf124c66a7ce05c7ea773b08 (diff)
gentoo auto-resync : 19:12:2022 - 01:47:04
Diffstat (limited to 'sci-mathematics/cudd')
-rw-r--r--sci-mathematics/cudd/Manifest3
-rw-r--r--sci-mathematics/cudd/cudd-3.0.0.ebuild27
-rw-r--r--sci-mathematics/cudd/metadata.xml14
3 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/cudd/Manifest b/sci-mathematics/cudd/Manifest
new file mode 100644
index 000000000000..bc4e55b487ca
--- /dev/null
+++ b/sci-mathematics/cudd/Manifest
@@ -0,0 +1,3 @@
+DIST cudd-3.0.0.tar.gz 1175302 BLAKE2B 9948495b4426e5931daafe0f48a1e1886bbadd6adbd5191b41aa7876522da7d29e84585a555184d5cf661a93e0d974b2caea79e135e7633eef1b7fdf173fdd1c SHA512 c0cb5fbdc4bb1793712e42c2e1377c3b1ae36f22ffc82bb3dd93a8a51f58bfe192fed9a37239a4c471326ef00a8f5e2f7fc801a2a6841be3db5a7e159e866f21
+EBUILD cudd-3.0.0.ebuild 525 BLAKE2B 5ec2884638fd5c83067e5506603804dc46365b331beec169ccea84786d4a73062eb0e849a222f7fad8efdf384f44aee3add056093eb41bf7a4f3a0c053563af4 SHA512 7530b2aa8a32bb8925632b39884ac895c66fd1eebf9b3f77763d7cab4dec1f626107296018b5d7a62739a9f41bcc8bd1af0a2f9dde41df2347a0bd6ecbb080e9
+MISC metadata.xml 529 BLAKE2B 579460e5cc8af597d1540cb12a6107dceb3b3635f2f2e13769851b46f59f13da63fae41f1d6dfae7e2940c292b70bdd3a9200c85939f554cef9f95d09e8cb10c SHA512 4408ca822d4b781b98c7906f98cc2afebde15057d82ee6d9b2efa1101bb4cb5f14be74303d34fd85193220a07282a46734125e81cdd90813c47174997d81c42a
diff --git a/sci-mathematics/cudd/cudd-3.0.0.ebuild b/sci-mathematics/cudd/cudd-3.0.0.ebuild
new file mode 100644
index 000000000000..23d19b084202
--- /dev/null
+++ b/sci-mathematics/cudd/cudd-3.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Colorado University binary Decision Diagram library"
+HOMEPAGE="https://davidkebo.com/cudd/"
+SRC_URI="https://davidkebo.com/source/cudd_versions/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ local myconf=(
+ --enable-dddmp
+ --enable-obj
+ --enable-shared
+ )
+ econf ${myconf[@]}
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -type f -delete || die
+}
diff --git a/sci-mathematics/cudd/metadata.xml b/sci-mathematics/cudd/metadata.xml
new file mode 100644
index 000000000000..63814133765d
--- /dev/null
+++ b/sci-mathematics/cudd/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ CUDD stands for Colorado University Decision Diagram. It is a package for
+ the manipulation of Binary Decision Diagrams (BDDs), Algebraic Decision
+ Diagrams (ADDs) and Zero-suppressed Binary Decision Diagrams (ZDDs).
+ </longdescription>
+</pkgmetadata>