summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
commit6fe5af3f06c92a6b1a6b21ff5e1bc9d107490971 (patch)
tree872ff7ba355a0b1735779b329c6a6b8b8f728a88 /sci-mathematics/cryptominisat
parente564f1661521043bc9e03e613c3cd8c79d5d7713 (diff)
gentoo auto-resync : 25:06:2023 - 19:30:41
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/Manifest2
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index 1c891c16441c..f87dee0e54b7 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1,4 +1,6 @@
AUX cryptominisat-5.11.4-gcc-13.patch 216 BLAKE2B eac9f21b7e1e4049c27fdf4dcb19ec7aa1a7c0da5839cbb4bb54c20a00c41be0a101f280ba1a881d2529e7c36fe27abb94ea3b4e600d8212ec011abcbcd2fee6 SHA512 b13ea41b6a3a22ed6a171689a40ca4f9bae242f6013d334952776ff66517916960df4a962b55a5e1deab61de8e8a3c973d3c02c2b5e53aac1405a101c5b9e71b
+DIST cryptominisat-5.11.11.tar.gz 1012869 BLAKE2B 768ae936380c05f3129ac642fe8e7c3581824f8be8e02c7d6709fbb8ca1e43eae04ba6d16d441063ed4cbe597a64ee357fa8b45e3f740a6cf11c00f9225b6b5d SHA512 21827627a1765b760df4635f3606ba83c76bac52217120a0b4c97bcb05526fe6cf7325dff04385525f763f20a0371586dc929eb3c57023b3367a8af9ea8e947a
DIST cryptominisat-5.11.4.tar.gz 1044845 BLAKE2B b6df4e61c5f37d24a61a5c782f08f223c413e19fc2b1625718f7d19d4df8f4d955a92ae447f6c98889927ddc7407b4790092086996a0a32879c7dcb614ca1024 SHA512 8593848c468a6b1ac3d9ae343384aa323fb6ddc17802c9b184c178b9a41314c463b1c5f02ffd19d6e844894c7998e41d6e9b808ed70dcc235aa595607f52bc76
+EBUILD cryptominisat-5.11.11.ebuild 748 BLAKE2B 2bb52efb5041be14dbf7f20f10931016245bc34e4793b30b1c9704e7dc8a43b75b7920d9525d86c889de7725e858b25143e605023afb5c6cca1e61881992127e SHA512 72806c7f19684b99939b43494b1272fc38dde381769e46b3cc19a18d8d151f6f3f600cd10f1960fab460b48827604fbd944e1607e1002131324ce90a2112c595
EBUILD cryptominisat-5.11.4.ebuild 812 BLAKE2B 772e5bf7985032fa53ecf5e40e9874535baaac95dbecbc3a5435c2a3f2af85d8ceb83979ff20d6a18a6b05eec525365c74f477edec7cf8a2f4d0dd3e34a70957 SHA512 d05b7762282bd018411a19acef297d876f2e0e57813d7747bfb294881844ffec57695a69f025dcf951a2255d95bf94e6ec9a436b19df0a51ce28d0105c38cf0c
MISC metadata.xml 858 BLAKE2B 4543d51cedd7b5e5e8508c14dfae420360f9d76ada1b969d855ca2b17b2c967036b29a9f2769a2c78e736c1e449e2b079558cd7460a72d402e9f1ce029ba414a SHA512 e1b39d888ab6c09f8707a164c7f683831a908477b2c7f219f4c9f71161ba84c145836ca2b1665e200f15a6e2ff6ca6318bd16fc40d57ad9c64bd1a4e229fbabc
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
new file mode 100644
index 000000000000..4d4e2a5c0742
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/msoos/${PN}.git"
+else
+ SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0/${PV}"
+LICENSE="GPL-2 MIT"
+RESTRICT="test" # Tests require many git modules.
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}