summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-24 17:23:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-24 17:23:06 +0100
commit6ec91ab7ea6f7b0b84e3006f7136ad8d67bd6ef0 (patch)
treee973b210311e7c2d0c04aae34e776e6e608c70af /sci-mathematics/cryptominisat
parent6a851e4f7c23c15c4b7853e6c34b0a0b9bc68482 (diff)
gentoo auto-resync : 24:09:2023 - 17:23:06
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/Manifest2
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index b877600ed535..88a7b3f50279 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1,5 +1,7 @@
DIST cryptominisat-5.11.11.tar.gz 1012869 BLAKE2B 768ae936380c05f3129ac642fe8e7c3581824f8be8e02c7d6709fbb8ca1e43eae04ba6d16d441063ed4cbe597a64ee357fa8b45e3f740a6cf11c00f9225b6b5d SHA512 21827627a1765b760df4635f3606ba83c76bac52217120a0b4c97bcb05526fe6cf7325dff04385525f763f20a0371586dc929eb3c57023b3367a8af9ea8e947a
DIST cryptominisat-5.11.12.tar.gz 1013147 BLAKE2B f69f8dac97aaddcff89039aa43e786058befe5b86bed98059bda84d7559601ef6d39dcbf296a0c075d0ffae54054f7b3e78db371c8c66d4290b78dcd562bb977 SHA512 f6e9bb3f561e066f5fa228fcd0d8887333b251b88f7838c3ac0c130c2b7cd5ae46ff6272b4603a898efa67b3faeef22d01697b60e565d2dc6bfc890c7dc56a93
+DIST cryptominisat-5.11.14.tar.gz 1013009 BLAKE2B 83fc29694caa3a3883f617affaf9906da6f9ded11a6894e92274c47c4df202b7ef2a404f25781348752a471564a6469aacea9a79d466d01d3d703e4df7a357a8 SHA512 efcec05f515f1c83d5ecc96cb21ad956bae52563749412cd9d0279b0780c0f91b7143ebc5524dc7d45d159e921a88503248ccef6d2ef37875e78b7a163ddb3ce
EBUILD cryptominisat-5.11.11.ebuild 748 BLAKE2B 2bb52efb5041be14dbf7f20f10931016245bc34e4793b30b1c9704e7dc8a43b75b7920d9525d86c889de7725e858b25143e605023afb5c6cca1e61881992127e SHA512 72806c7f19684b99939b43494b1272fc38dde381769e46b3cc19a18d8d151f6f3f600cd10f1960fab460b48827604fbd944e1607e1002131324ce90a2112c595
EBUILD cryptominisat-5.11.12.ebuild 748 BLAKE2B 2bb52efb5041be14dbf7f20f10931016245bc34e4793b30b1c9704e7dc8a43b75b7920d9525d86c889de7725e858b25143e605023afb5c6cca1e61881992127e SHA512 72806c7f19684b99939b43494b1272fc38dde381769e46b3cc19a18d8d151f6f3f600cd10f1960fab460b48827604fbd944e1607e1002131324ce90a2112c595
+EBUILD cryptominisat-5.11.14.ebuild 752 BLAKE2B 6b1ec4218e34de0fcb98cb8e5877659a8f81feaba1d3bc9a92cfa7f7c004c3e655d45149ebbe92dca11ea180138eb15705aa8e550c5b7cb22ba3d739bf375505 SHA512 0c681051ab75b14a19b7c7405e6e0ae750b9243b0009a4608d39b88ad9ca79f91ddb8b4bbcf62530538e02588bb6df23efa5e53d80ddeb85bdfaafafbb771da0
MISC metadata.xml 858 BLAKE2B 4543d51cedd7b5e5e8508c14dfae420360f9d76ada1b969d855ca2b17b2c967036b29a9f2769a2c78e736c1e449e2b079558cd7460a72d402e9f1ce029ba414a SHA512 e1b39d888ab6c09f8707a164c7f683831a908477b2c7f219f4c9f71161ba84c145836ca2b1665e200f15a6e2ff6ca6318bd16fc40d57ad9c64bd1a4e229fbabc
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild
new file mode 100644
index 000000000000..8eb2f8619f84
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/msoos/${PN}.git"
+else
+ SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0/${PV}"
+LICENSE="GPL-2 MIT"
+RESTRICT="test" # Tests require many git modules.
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}