summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-12 05:45:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-12 05:45:47 +0000
commit26c687603afd123f35f1b8745cb38493a4e7d928 (patch)
tree233680ddc1713aa90cc78e3dd6fe7a46a51f9f61 /sci-mathematics/cryptominisat
parent7051f2e58b6bbc371b2c94cead2715bf06310adb (diff)
gentoo auto-resync : 12:01:2023 - 05:45:47
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/Manifest2
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index e9326ae1fa29..f9e3207dcd82 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1,4 +1,6 @@
AUX cryptominisat-5.8.0-setup.py.in-sysconfig.patch 678 BLAKE2B b42dd9ebed8076e8c46ddf92107bdd776d078c0869a824b87c27876c49818ca96b1455912c3af3957c507b59fadb5ecbdedbd94404a87f4672295553d40ce612 SHA512 9836faddf2d502af08a15a08611dfcd1e476d4155fe6a6a9a68b4d6ff851fa7dd485e0c08ba23920cda43f8fc72e5ec9f05fce816b7b0ead65144daa38490601
+DIST cryptominisat-5.11.4.tar.gz 1044845 BLAKE2B b6df4e61c5f37d24a61a5c782f08f223c413e19fc2b1625718f7d19d4df8f4d955a92ae447f6c98889927ddc7407b4790092086996a0a32879c7dcb614ca1024 SHA512 8593848c468a6b1ac3d9ae343384aa323fb6ddc17802c9b184c178b9a41314c463b1c5f02ffd19d6e844894c7998e41d6e9b808ed70dcc235aa595607f52bc76
DIST cryptominisat-5.8.0.tar.gz 943785 BLAKE2B 534af88a8432c7e3da63989cad8fd5e1491bd69a80b44977fa681e0356e857a505a82dc860b0d04d07987e3edae2861da67ec9dd781261e03a1120dc342b9759 SHA512 3eb954f01524b189a8de57a05f6060471a083addc4b9077c1e32b769d26393ce3d33468819ba8169deedce43fc3663b0ad8bbad95c6afe5e562e438c57b75496
+EBUILD cryptominisat-5.11.4.ebuild 759 BLAKE2B 90fd6e94487a8da7e2ee691e9634ea4e846aa9bcb7592e91360044955a1e6cb4bfbcbe572f03e7a46f9b4217b303bc34e07e848a4930e360511f6af4b59b4043 SHA512 bf223f972b8835465c9781ec04597f02db3675bf80e10c558e3d0925289d5471c5f87e9e857db152a001898bcc160bef9993faccc52464318adff68bd5c2c974
EBUILD cryptominisat-5.8.0.ebuild 980 BLAKE2B a4e47be2b7f6f9ba2fe6669afbdeeee25ac69586ce1fba042f6f940a0befeaded258f9c855e9d6c6d0dbe10cd996f712174e4fa5cae27d936fb6c0231e5859d9 SHA512 b0e65d01e24fdc3fb938185540594e1bf1dedafebf0f889a4368997d8e5c8b3d0afab8f8e19b93ba81d4af275bf0576d4149b60a3a426fe4a9574f836bc11948
MISC metadata.xml 858 BLAKE2B 4543d51cedd7b5e5e8508c14dfae420360f9d76ada1b969d855ca2b17b2c967036b29a9f2769a2c78e736c1e449e2b079558cd7460a72d402e9f1ce029ba414a SHA512 e1b39d888ab6c09f8707a164c7f683831a908477b2c7f219f4c9f71161ba84c145836ca2b1665e200f15a6e2ff6ca6318bd16fc40d57ad9c64bd1a4e229fbabc
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild
new file mode 100644
index 000000000000..a4f699cc2afd
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2 MIT"
+RESTRICT="test" # tests require many convoluted bundled (git) modules
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodir /usr/share/man
+ mv "${ED}"/usr/man "${ED}"/usr/share/man || die
+}