summaryrefslogtreecommitdiff
path: root/sci-mathematics/coq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-mathematics/coq
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/Manifest2
-rw-r--r--sci-mathematics/coq/coq-8.12.0.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 44cbfae283d9..a0aa977db6e9 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,5 +1,7 @@
+DIST coq-8.12.0.tar.gz 6774001 BLAKE2B dc1d6adf9d4bd50d46007fbf5fd43d1ea97b6b226d89ad943419d4cb7df1439950c94b5e3cc614eb789103d1ab50535909d4ba2079eafc2caa4fd91db30e747d SHA512 8a64624c578ce0ab781fb3b1f162bd8b095735ad891fdad2fb7c40849afbdc7c1360187c6b62a5ef2982566f4c6c78029240c611ae769943a5250af300eb1240
DIST coq-8.6.1.tar.gz 5588811 BLAKE2B 1016e54ef9b42a8534add55ab057454fad35b3fe103ba877689489c7d9cf43d76c1fbee123801d91035d353a882120650f94c433d9ee1daa878b8c819609c949 SHA512 814ab76a06ca15f927081428da74add4bc67290199fa011853b9c68a00cdefaf813b10fbac18a434f4504fce8f2173eb544080bf6f50d62caa41bb8724b13083
DIST coq-8.9.1.tar.gz 6001970 BLAKE2B f65498e2485c59f4f95d2afeac35750ebf85b5af6db7c269a11635f2414df483d4cb159557060c9118de25f4922176f54d2e5c6f12174599371348341cb4d80f SHA512 66344f801b955d1b6daf3ab1d704551070c95cf9032ae74f15fb33f7ec313812b3e05c0ec277a2eb448e3fdfd9721df06d36612e2fb4928b6530d70147f1d983
+EBUILD coq-8.12.0.ebuild 1823 BLAKE2B 84da9000cdaf8ae40283fca252940fec5ca491766998e644450fd506f001baa2cf686cb28e9ea6d669927f6cca4eb9fa33f65d5c097bb953e42921227b601ca6 SHA512 9c1025360c6cb55f420f75a2f9d6aec7964bbf76db4494f4e4fa948d3e4a939dcea52f69943e1bc2baabe0fed983fcd756bc502090462b81c2933db8ba1cb4a2
EBUILD coq-8.6.1-r1.ebuild 2007 BLAKE2B e11542ca13987c776b7dd4b181a4e369381d5b4bf16d61e2ba06b77d7c26e93295a18040ca757b02df492fb034f8852e9d340f52dbd22e7dde8cefaf60fe14f8 SHA512 b26850dc5f062a938a6974c1b49eb6f09645c75cdbac945262919be3d13c46e897d839ea063258868c6e6785cdeb31fc41152c2ffc0b412ca3b152e5ea89ffbc
EBUILD coq-8.9.1-r1.ebuild 1884 BLAKE2B d060bd67a71bbe9cfc8c73ec578ca19565f88b671f667305ffbf7a911f46de8040918848321cbebee6c7957d566638007b634a0909ff8603497ca2ef71607a7f SHA512 76d68162cfc431547f5c499d1ffa80c1446a95e2f96c414830a93d4d91ed65143eb0c8bf3b12ed27d3d1b4bd302e498ea1ebf783b37a8576c7c009d4681a83ef
EBUILD coq-8.9.1-r2.ebuild 1824 BLAKE2B c98446eed745fb1c111ad025ac19d9cc707917863ef32d47e1bdf0653b0d49ff2e050ab423ae864f55579c0e5bea0ac41e2c7ae51851e0ced846ff40d55d3646 SHA512 e7d7150b74cdfb9da5acc4dcf7e1355f9bc213d6a0aaaa72cad5a5db521718ef2533232bfb6176b7b09df2eda6283f82fa849dd2d56a671ee2b2f39496d5d358
diff --git a/sci-mathematics/coq/coq-8.12.0.ebuild b/sci-mathematics/coq/coq-8.12.0.ebuild
new file mode 100644
index 000000000000..f057ce34b154
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.12.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT=test
+
+RDEPEND="
+ >=dev-lang/ocaml-4.11.0:=[ocamlopt?]
+ dev-ml/camlp5:=[ocamlopt?]
+ dev-ml/num:=
+ gtk? (
+ dev-ml/lablgtk:3=[sourceview,ocamlopt?]
+ dev-ml/lablgtk-sourceview:3=[ocamlopt?]
+ )"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
+ dodoc README.md CREDITS
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}