summaryrefslogtreecommitdiff
path: root/sci-mathematics/coq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-mathematics/coq
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/Manifest1
-rw-r--r--sci-mathematics/coq/coq-8.9.1-r2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 32a349c41897..44cbfae283d9 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -2,4 +2,5 @@ DIST coq-8.6.1.tar.gz 5588811 BLAKE2B 1016e54ef9b42a8534add55ab057454fad35b3fe10
DIST coq-8.9.1.tar.gz 6001970 BLAKE2B f65498e2485c59f4f95d2afeac35750ebf85b5af6db7c269a11635f2414df483d4cb159557060c9118de25f4922176f54d2e5c6f12174599371348341cb4d80f SHA512 66344f801b955d1b6daf3ab1d704551070c95cf9032ae74f15fb33f7ec313812b3e05c0ec277a2eb448e3fdfd9721df06d36612e2fb4928b6530d70147f1d983
EBUILD coq-8.6.1-r1.ebuild 2007 BLAKE2B e11542ca13987c776b7dd4b181a4e369381d5b4bf16d61e2ba06b77d7c26e93295a18040ca757b02df492fb034f8852e9d340f52dbd22e7dde8cefaf60fe14f8 SHA512 b26850dc5f062a938a6974c1b49eb6f09645c75cdbac945262919be3d13c46e897d839ea063258868c6e6785cdeb31fc41152c2ffc0b412ca3b152e5ea89ffbc
EBUILD coq-8.9.1-r1.ebuild 1884 BLAKE2B d060bd67a71bbe9cfc8c73ec578ca19565f88b671f667305ffbf7a911f46de8040918848321cbebee6c7957d566638007b634a0909ff8603497ca2ef71607a7f SHA512 76d68162cfc431547f5c499d1ffa80c1446a95e2f96c414830a93d4d91ed65143eb0c8bf3b12ed27d3d1b4bd302e498ea1ebf783b37a8576c7c009d4681a83ef
+EBUILD coq-8.9.1-r2.ebuild 1824 BLAKE2B c98446eed745fb1c111ad025ac19d9cc707917863ef32d47e1bdf0653b0d49ff2e050ab423ae864f55579c0e5bea0ac41e2c7ae51851e0ced846ff40d55d3646 SHA512 e7d7150b74cdfb9da5acc4dcf7e1355f9bc213d6a0aaaa72cad5a5db521718ef2533232bfb6176b7b09df2eda6283f82fa849dd2d56a671ee2b2f39496d5d358
MISC metadata.xml 999 BLAKE2B 04e27cb6563eca4cfab69c0a73a12e2ea5cb3ccb6dc711400ebbfb4790c896ab8f7efff0da1f985596333a4f32cd6d8278e750ef90cb5f0d61728d8f453095fa SHA512 0c78334d0d352fbe268804040a4f7765fba09055e316fd67739d052fbb4048817e3136065939f763248a3cbe27daf5884f2953b887690a7593aed6b5dc7157a6
diff --git a/sci-mathematics/coq/coq-8.9.1-r2.ebuild b/sci-mathematics/coq/coq-8.9.1-r2.ebuild
new file mode 100644
index 000000000000..75d3af58a1fc
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.9.1-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit desktop multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT=test
+
+RDEPEND="
+ >=dev-lang/ocaml-4.0.7:=[ocamlopt?]
+ dev-ml/camlp5:=[ocamlopt?]
+ dev-ml/num:=
+ gtk? ( dev-ml/lablgtk:=[sourceview,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ -lablgtkdir ${ocaml_lib}/lablgtk2
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
+ dodoc README.md CREDITS CHANGES.md
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}