summaryrefslogtreecommitdiff
path: root/sci-mathematics/coq-serapi/coq-serapi-0.15.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-12 05:45:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-12 05:45:47 +0000
commit26c687603afd123f35f1b8745cb38493a4e7d928 (patch)
tree233680ddc1713aa90cc78e3dd6fe7a46a51f9f61 /sci-mathematics/coq-serapi/coq-serapi-0.15.0-r3.ebuild
parent7051f2e58b6bbc371b2c94cead2715bf06310adb (diff)
gentoo auto-resync : 12:01:2023 - 05:45:47
Diffstat (limited to 'sci-mathematics/coq-serapi/coq-serapi-0.15.0-r3.ebuild')
-rw-r--r--sci-mathematics/coq-serapi/coq-serapi-0.15.0-r3.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/sci-mathematics/coq-serapi/coq-serapi-0.15.0-r3.ebuild b/sci-mathematics/coq-serapi/coq-serapi-0.15.0-r3.ebuild
deleted file mode 100644
index ddda9b6a1dce..000000000000
--- a/sci-mathematics/coq-serapi/coq-serapi-0.15.0-r3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-COQV=8.15.0
-
-inherit elisp-common dune
-
-DESCRIPTION="Serialization library and protocol for interaction with the Coq proof assistant"
-HOMEPAGE="https://github.com/ejgallego/coq-serapi/"
-# The tarball in SRC_URI is comprised of <supported coq>+<package version>
-SRC_URI="https://github.com/ejgallego/${PN}/archive/${COQV}+${PV}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${COQV}-${PV}
-
-LICENSE="GPL-3+"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="emacs +ocamlopt test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=sci-mathematics/coq-${COQV}:= <sci-mathematics/coq-8.16:=
- >=dev-ml/ppx_sexp_conv-0.13.0:= <dev-ml/ppx_sexp_conv-0.15.0:=
- dev-ml/cmdliner:=
- dev-ml/ppx_deriving:=
- dev-ml/ppx_deriving_yojson:=
- dev-ml/ppx_import:=
- dev-ml/sexplib:=
- dev-ml/yojson:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- emacs? ( >=app-editors/emacs-23.1:* )
- test? ( sci-mathematics/coq-mathcomp )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-sertop.el-path.patch )
-SITEFILE="50sertop-gentoo.el"
-
-src_compile() {
- dune_src_compile
-
- use emacs && elisp-compile sertop.el
-}
-
-src_install() {
- dune_src_install
-
- rm -r "${D}"/usr/share/emacs || die
- if use emacs ; then
- elisp-install ${PN} sertop.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}