summaryrefslogtreecommitdiff
path: root/sci-mathematics/coq-mathcomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 14:40:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 14:40:32 +0100
commit27f59f8e16510831cc751de1406f71afbf464653 (patch)
tree71463a2ac26fc948615ad34e8101c808c930f76f /sci-mathematics/coq-mathcomp
parent9c572b23bc56215e9d24d375ddd293982c07dc08 (diff)
gentoo auto-resync : 24:10:2023 - 14:40:32
Diffstat (limited to 'sci-mathematics/coq-mathcomp')
-rw-r--r--sci-mathematics/coq-mathcomp/Manifest2
-rw-r--r--sci-mathematics/coq-mathcomp/coq-mathcomp-1.17.0.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-mathematics/coq-mathcomp/Manifest b/sci-mathematics/coq-mathcomp/Manifest
index d077c66292e6..cb92d93affa5 100644
--- a/sci-mathematics/coq-mathcomp/Manifest
+++ b/sci-mathematics/coq-mathcomp/Manifest
@@ -1,3 +1,5 @@
DIST coq-mathcomp-1.16.0.tar.gz 1377232 BLAKE2B f9246ff2a6e583facc31278728b0865fdfb4d9cb6422687643321712b22d7fa61e40dd95e7782ba8443f66b61f9f6a82caead767a6985c87e6fe731a04494713 SHA512 80dc82e0deea4b3e05811b9dca3cf7c0169387288a5cc5c7e95c452c7aa041a37df34d93546c6597c6717106e20dc98400c7b0bbb8d1d1915e2063cfe6fd300b
+DIST coq-mathcomp-1.17.0.tar.gz 1384329 BLAKE2B e77b509c49796af7a23a4f286a83516e40e28bc03a1f3b20ddeb54321de05bc5f3ddbe0632e7462c6619180276975727b49101253b07cc9a2ae54a6662d8e5ab SHA512 06b318e2973863b5acefdd01b39065987a93952fa5f2ce9ba68df7ff7bf701c5fc82b571f53e80eadaa293935a82e8d1f891cc555db7200a923ee986918a0c76
EBUILD coq-mathcomp-1.16.0-r1.ebuild 627 BLAKE2B 14853b4eedc1d123b7d5d16da9f16883a6c4e614d09ae3411c217e72a77f3b00719d48375c13708dbc264142aa8e50270251365a97c80d09487851a41d2b8d58 SHA512 9beef42e82af16d3e006cdd9062dafbcfdbd37260f0048413fe4632b624280d153e2cc6dbf8d5edae220f2ce778bf5d524ca9b6561857982da980791d28a0544
+EBUILD coq-mathcomp-1.17.0.ebuild 627 BLAKE2B e022b6e2552b0a307ebe83e7d3861c0f45cbe1bbd3c69bc18a3bea71680aa74922bb20624e67bca89040ec72f51f9aeb90c2175d35b6e8fb3f54015c5986dff6 SHA512 50887be2fccf1aac5a224877c4b562d94ce41a0f1c35754968728a49f62a69b5d041366d7edd266d42d1ebf03080234f3f25a35725865f560a335a35442f8fc9
MISC metadata.xml 511 BLAKE2B 3936f96cbf938fb9de97b080566d7fdde222d7dd303ccf842c76e7bd113b31c05136aea043c354bbd2ac6d4f61e2cba4e738f9f325059d36b7bae4feaed1ae89 SHA512 af2a4cfded0990d95e0a4b77ba69aebea09dee075f9eb4023b14c4788cd4118a78b3b5a4349fed11fff347061ab4bf59a4c63c8f43b22f8513054f1b3817af2f
diff --git a/sci-mathematics/coq-mathcomp/coq-mathcomp-1.17.0.ebuild b/sci-mathematics/coq-mathcomp/coq-mathcomp-1.17.0.ebuild
new file mode 100644
index 000000000000..4229fb64bef2
--- /dev/null
+++ b/sci-mathematics/coq-mathcomp/coq-mathcomp-1.17.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COQ_MIN_V=8.16.0
+
+DESCRIPTION="Mathematical Components for the Coq proof assistant"
+HOMEPAGE="https://github.com/math-comp/math-comp/"
+SRC_URI="https://github.com/math-comp/math-comp/archive/mathcomp-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/math-comp-mathcomp-${PV}/mathcomp"
+
+LICENSE="CeCILL-B"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=sci-mathematics/coq-${COQ_MIN_V}:=
+ dev-lang/ocaml:=
+"
+DEPEND="${RDEPEND}"
+
+# Do not complain about CFLAGS etc since ML projects do not use them.
+QA_FLAGS_IGNORED='.*'