summaryrefslogtreecommitdiff
path: root/sci-mathematics/cadical
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /sci-mathematics/cadical
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'sci-mathematics/cadical')
-rw-r--r--sci-mathematics/cadical/Manifest3
-rw-r--r--sci-mathematics/cadical/cadical-1.5.3.ebuild35
-rw-r--r--sci-mathematics/cadical/files/cadical-configure.patch21
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
index eef40ed8536c..1fbc26daa231 100644
--- a/sci-mathematics/cadical/Manifest
+++ b/sci-mathematics/cadical/Manifest
@@ -1,4 +1,7 @@
+AUX cadical-configure.patch 380 BLAKE2B e9fd63e663811a2a067b9bb8bb05604dc5b0fb02068a04ed1f80ad7b40e3aa8981c47ad7b80475e758e6c2e44b17b175c3a793e256185d28e0029a78473837b9 SHA512 9b82cd65257253ea423df6fb711bef0d5a8fbca48dd86fde5433b0dd377bfa9778ba3141b36560d13ceb61a4df305b818f11f3a72a483a02b3b3859299d6d830
AUX cadical-makefile.in-ar.patch 323 BLAKE2B 226618745824824d8d7ccea53a3435abed9f829ca8462994fcdf805b7e5ba18a571214a16fbb2fcaeb0c91683424402e0a3c8dd05cd8f8dbdec19ed30aa023eb SHA512 30427fb87ef6aef56b9aebc3b2e0981e79c680c73dba20d371364d1b3668b51f1cbba4b6c7467ffb979245488b8ca1f2251a6321db4991221051f0c4b8e6a4d7
DIST cadical-1.5.2.tar.gz 596334 BLAKE2B 2e6c0f0602b807cf9ee5993aa627e074291b0128d19474d5431e01992d66b111773e593c14712338e9702f64e23eae6fdd937b5b86b2b9b3e08022dbbb199fd7 SHA512 1aab87bdaec938eb219f75f13bf2fcb031f47ac1f49b586f769aeececd1c33b166341bef3bc8713e62b4612a91c405db33e6d1b48e1074a3433d80e9ecb33fe2
+DIST cadical-1.5.3.tar.gz 596378 BLAKE2B 1ac27412745b0f24668ccf2ea1ff89e02c1e68137110bf9522a63ad82b14621d898d0bf873a651a24ccef9f502982f5e2d5b9c558ed0b1c5b7432c1a1459cb58 SHA512 bec811ab6a4c392506bdc391227d108476b5b5fae280b2d7d484429fe6d84e86206a054a1044cf68046ce183ecd7af3ec58f8be3ac27224fe37930cf43f08f3b
EBUILD cadical-1.5.2-r1.ebuild 732 BLAKE2B f97142135bf5be3f3912d572235aa0de953ac4137e715b0b3732014c19527cb2a6a4fca456bdd5e48b9384038b1028fcaef8b47695ead65bff5ebdd17fc1d3ce SHA512 aed6e5bd0cda217c6b2a1c9a32dc27f0b0c5f051dcbf43a3e06e806e5a6099340a8d224027b77e6949b3ca3f053f1cd1676cf968d95c9a63636bbe18703e7f79
+EBUILD cadical-1.5.3.ebuild 787 BLAKE2B b4303e9b1636eabd5697e1dcf2111182ca297c7b7d76a64eddf03acef1dd9e3ce569cf1907282cb8511d74a54d4372f5fd67d1d8f1f2f9430fbb9ecb13d9cb70 SHA512 bb7d45d98a46b0a61ce0174a9d287c2fdd425dad7da90fd0f8c963aaf53cdd0aa8b617a9a7ae1ff817a44b39ea2e4ff951d17539dcc5958ad20cd5e24f60d929
MISC metadata.xml 613 BLAKE2B 6d7e0c1b5eae3803aa0981b195457cdcc6d2ffa2af655837e615da6ed6914ac5bec7a831ced6703ff67476561cf67139ea5519d98cdc2bd8d5781108496046e2 SHA512 b04ad6ae6e2626cea18049e3e20eb227b5580853b8ad77179ea693ed61f12d042b7ea505eb8cfafaa0121564ab0a4b6c7dcdf84f78fa2f47c465e6f61fb1a3f0
diff --git a/sci-mathematics/cadical/cadical-1.5.3.ebuild b/sci-mathematics/cadical/cadical-1.5.3.ebuild
new file mode 100644
index 000000000000..dac39982db2e
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-rel-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-configure.patch
+ "${FILESDIR}"/${PN}-makefile.in-ar.patch
+)
+
+DOCS=( BUILD.md CONTRIBUTING NEWS.md README.md VERSION )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ einstalldocs
+}
diff --git a/sci-mathematics/cadical/files/cadical-configure.patch b/sci-mathematics/cadical/files/cadical-configure.patch
new file mode 100644
index 000000000000..c6135cb08664
--- /dev/null
+++ b/sci-mathematics/cadical/files/cadical-configure.patch
@@ -0,0 +1,21 @@
+Remove forced debugging or optimization flags.
+
+--- a/configure
++++ b/configure
+@@ -261,16 +261,6 @@ case x"$CXX" in
+ *) CXXFLAGS="${CXXFLAGS}-W";;
+ esac
+
+-if [ $debug = yes ]
+-then
+- CXXFLAGS="$CXXFLAGS -g"
+-else
+- case x"$CXX" in
+- x*g++*|x*clang++*) CXXFLAGS="$CXXFLAGS -O3";;
+- *) CXXFLAGS="$CXXFLAGS -O";;
+- esac
+-fi
+-
+ if [ $m32 = yes ]
+ then
+ case x"$CXX" in