summaryrefslogtreecommitdiff
path: root/sci-mathematics/cadical
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-mathematics/cadical
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-mathematics/cadical')
-rw-r--r--sci-mathematics/cadical/Manifest4
-rw-r--r--sci-mathematics/cadical/cadical-1.5.2-r1.ebuild32
-rw-r--r--sci-mathematics/cadical/files/cadical-makefile.in-ar.patch12
-rw-r--r--sci-mathematics/cadical/metadata.xml17
4 files changed, 65 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
new file mode 100644
index 000000000000..905451ab2716
--- /dev/null
+++ b/sci-mathematics/cadical/Manifest
@@ -0,0 +1,4 @@
+AUX cadical-makefile.in-ar.patch 323 BLAKE2B 226618745824824d8d7ccea53a3435abed9f829ca8462994fcdf805b7e5ba18a571214a16fbb2fcaeb0c91683424402e0a3c8dd05cd8f8dbdec19ed30aa023eb SHA512 30427fb87ef6aef56b9aebc3b2e0981e79c680c73dba20d371364d1b3668b51f1cbba4b6c7467ffb979245488b8ca1f2251a6321db4991221051f0c4b8e6a4d7
+DIST cadical-1.5.2.tar.gz 596334 BLAKE2B 2e6c0f0602b807cf9ee5993aa627e074291b0128d19474d5431e01992d66b111773e593c14712338e9702f64e23eae6fdd937b5b86b2b9b3e08022dbbb199fd7 SHA512 1aab87bdaec938eb219f75f13bf2fcb031f47ac1f49b586f769aeececd1c33b166341bef3bc8713e62b4612a91c405db33e6d1b48e1074a3433d80e9ecb33fe2
+EBUILD cadical-1.5.2-r1.ebuild 732 BLAKE2B f97142135bf5be3f3912d572235aa0de953ac4137e715b0b3732014c19527cb2a6a4fca456bdd5e48b9384038b1028fcaef8b47695ead65bff5ebdd17fc1d3ce SHA512 aed6e5bd0cda217c6b2a1c9a32dc27f0b0c5f051dcbf43a3e06e806e5a6099340a8d224027b77e6949b3ca3f053f1cd1676cf968d95c9a63636bbe18703e7f79
+MISC metadata.xml 612 BLAKE2B 61991d650dbdae11b63c71085f145740272b8fe3b720da4d6750c6b82b7bc72e3acabf22826b0e01301d4866c05431d607f20f86a35e71b0754deb157dab34bb SHA512 c46f122e4d50c0a3db07e42453491d4285d5ef879f026ed747d173b9f0000ba26d44a097104cbe0642cac448c9b565d61132d0d9d4660dfb8a6c24900d6098b9
diff --git a/sci-mathematics/cadical/cadical-1.5.2-r1.ebuild b/sci-mathematics/cadical/cadical-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..c773ea12d5f2
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.5.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-makefile.in-ar.patch )
+
+DOCS=( BUILD.md CONTRIBUTING NEWS.md README.md VERSION )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ dobin build/{cadical,mobical}
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+
+ einstalldocs
+}
diff --git a/sci-mathematics/cadical/files/cadical-makefile.in-ar.patch b/sci-mathematics/cadical/files/cadical-makefile.in-ar.patch
new file mode 100644
index 000000000000..cb344eec60ab
--- /dev/null
+++ b/sci-mathematics/cadical/files/cadical-makefile.in-ar.patch
@@ -0,0 +1,12 @@
+index 8fd957f..cdad96e 100644
+--- a/makefile.in
++++ b/makefile.in
+@@ -47,7 +48,7 @@ mobical: mobical.o libcadical.a makefile $(LIBS)
+ $(COMPILE) -o $@ $< -L. -lcadical
+
+ libcadical.a: $(OBJ) makefile
+- ar rc $@ $(OBJ)
++ ${AR} rc $@ $(OBJ)
+
+ #--------------------------------------------------------------------------#
+
diff --git a/sci-mathematics/cadical/metadata.xml b/sci-mathematics/cadical/metadata.xml
new file mode 100644
index 000000000000..c3c09f27203e
--- /dev/null
+++ b/sci-mathematics/cadical/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ The goal of CaDiCaL is to provide a clean and efficient state-of-the-art
+ CDCL solver, which is also easy to understand and change.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/arminbiere/cadical/issues/</bugs-to>
+ <remote-id type="github">arminbiere/cadical</remote-id>
+ </upstream>
+</pkgmetadata>