summaryrefslogtreecommitdiff
path: root/sci-mathematics/cadical
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
commit32c16465e56b0122cf6e5a4625e9c7b56b107b07 (patch)
tree600c43152c825fda5f210dd7cb52b357eb6f2602 /sci-mathematics/cadical
parent607c0755d4f6476e326fb33795df7216a7bcff18 (diff)
gentoo auto-resync : 08:10:2023 - 06:02:21
Diffstat (limited to 'sci-mathematics/cadical')
-rw-r--r--sci-mathematics/cadical/Manifest2
-rw-r--r--sci-mathematics/cadical/cadical-1.8.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
index 7befc2608609..4f073a9b2753 100644
--- a/sci-mathematics/cadical/Manifest
+++ b/sci-mathematics/cadical/Manifest
@@ -1,5 +1,7 @@
AUX cadical-configure.patch 380 BLAKE2B e9fd63e663811a2a067b9bb8bb05604dc5b0fb02068a04ed1f80ad7b40e3aa8981c47ad7b80475e758e6c2e44b17b175c3a793e256185d28e0029a78473837b9 SHA512 9b82cd65257253ea423df6fb711bef0d5a8fbca48dd86fde5433b0dd377bfa9778ba3141b36560d13ceb61a4df305b818f11f3a72a483a02b3b3859299d6d830
AUX cadical-makefile.in-ar.patch 323 BLAKE2B 226618745824824d8d7ccea53a3435abed9f829ca8462994fcdf805b7e5ba18a571214a16fbb2fcaeb0c91683424402e0a3c8dd05cd8f8dbdec19ed30aa023eb SHA512 30427fb87ef6aef56b9aebc3b2e0981e79c680c73dba20d371364d1b3668b51f1cbba4b6c7467ffb979245488b8ca1f2251a6321db4991221051f0c4b8e6a4d7
DIST cadical-1.5.3.tar.gz 596378 BLAKE2B 1ac27412745b0f24668ccf2ea1ff89e02c1e68137110bf9522a63ad82b14621d898d0bf873a651a24ccef9f502982f5e2d5b9c558ed0b1c5b7432c1a1459cb58 SHA512 bec811ab6a4c392506bdc391227d108476b5b5fae280b2d7d484429fe6d84e86206a054a1044cf68046ce183ecd7af3ec58f8be3ac27224fe37930cf43f08f3b
+DIST cadical-1.8.0.tar.gz 649017 BLAKE2B 73db2dd0278869bc1b4fe5d1eb80e767a07c640bcd2b1901d86901a09ac6b8bdbe375017593c12ac80d7a860a0aead191777ce733452741395bf14b958bd1b03 SHA512 78dfd4a4a93090e3e00fa73c0dfde6edc781e8a69f257506f273cac46b942979335c2ae0ac1054bde68259b030ba235615275307ad077762c8770884914cfed7
EBUILD cadical-1.5.3-r1.ebuild 813 BLAKE2B 028ee0555334e9f2a4e3a4c90cac3d85644592c69f5d44392212c941889ad24bb7e9b1f7bbe5a67e6efd370d1f9832300da57b16543c30d17e32786925c774b8 SHA512 1dc7b61c695804ae6348ff35b4047b9ad2bb26f3a63906d661dcf87b4e0a4ff5127228c9694d46377517ec2c27d04f2173a5f9e3f8582349e1b8662ff2f1cab6
+EBUILD cadical-1.8.0.ebuild 815 BLAKE2B 4a0582001f4c55ddac5df7ffcd5fa5306e11cd79022d691090f9a7f338c7c7a632fcf71e9e367a0c97eb31de57c7d96e28c4af8f3057d14c16cd24e3b28e3c20 SHA512 38535f28bd7a19a9ad22a49c58901073e119fe7ef606ad7393798d53c5a12b7ea4427864b494363307f57c011f793e3dc22d253aef5186c54b0504ec4bef87de
MISC metadata.xml 613 BLAKE2B 6d7e0c1b5eae3803aa0981b195457cdcc6d2ffa2af655837e615da6ed6914ac5bec7a831ced6703ff67476561cf67139ea5519d98cdc2bd8d5781108496046e2 SHA512 b04ad6ae6e2626cea18049e3e20eb227b5580853b8ad77179ea693ed61f12d042b7ea505eb8cfafaa0121564ab0a4b6c7dcdf84f78fa2f47c465e6f61fb1a3f0
diff --git a/sci-mathematics/cadical/cadical-1.8.0.ebuild b/sci-mathematics/cadical/cadical-1.8.0.ebuild
new file mode 100644
index 000000000000..a71f7eebe39d
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-configure.patch
+ "${FILESDIR}"/${PN}-makefile.in-ar.patch
+)
+
+DOCS=( BUILD.md CONTRIBUTING NEWS.md README.md VERSION )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ doheader src/ccadical.h
+
+ einstalldocs
+}