summaryrefslogtreecommitdiff
path: root/sci-mathematics/btor2tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 05:43:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 05:43:34 +0000
commitad391b961414c99124b93cb86695c04bd8d57937 (patch)
tree446151aff1c09db21505a46da4107f9a5be588e0 /sci-mathematics/btor2tools
parent113cc6fe7a9adc2baf67f9ef7723db6ed2b24887 (diff)
gentoo auto-resync : 11:01:2023 - 05:43:34
Diffstat (limited to 'sci-mathematics/btor2tools')
-rw-r--r--sci-mathematics/btor2tools/Manifest5
-rw-r--r--sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518.ebuild39
-rw-r--r--sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch28
-rw-r--r--sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch19
-rw-r--r--sci-mathematics/btor2tools/metadata.xml13
5 files changed, 104 insertions, 0 deletions
diff --git a/sci-mathematics/btor2tools/Manifest b/sci-mathematics/btor2tools/Manifest
new file mode 100644
index 000000000000..a6f98fe33e62
--- /dev/null
+++ b/sci-mathematics/btor2tools/Manifest
@@ -0,0 +1,5 @@
+AUX btor2tools-1.0.0_pre20220518-cmake-also-static.patch 804 BLAKE2B bdfb9e99a98f9cd9989ba0eb10490877b24553c5db478281c8771bb922060c20412521dbab513e5742daa4878189313cae075d044b4ba4ee8f265bde15aef520 SHA512 ac03a333bd0563559b940d4b4b0f2e5da4440503e5ec84b0a28ddb4c4b5a17cf96910c025abe088f93dc82147023cfaa598eb18a6aa409e690baffe0166d10d6
+AUX btor2tools-1.0.0_pre20220518-cmake-clfags.patch 551 BLAKE2B 8cc8c427a2ec7defc4bd7f251b2a2a6484bc321b0f0d88a7099e8a69963cfbf6b69d13dbce4f54874d8138ec01ae870752a947a01c93c3cf996456c546ce012e SHA512 a6c446440405ab44b9bffb8316d170782241d77334c5837820ee0ea1e6da5ff97121b966a49af9c15e8e0e2a184ae3781166eb9c0ba07c4319dd92fed105ae2d
+DIST btor2tools-1.0.0_pre20220518.tar.gz 87420 BLAKE2B df8ddc8f286c32c580a8feaf0c7e90dff113d2b0303e3da0a378f2906cd34134ea91707cd40c95c38782990bf4d815416b3a566680f4d6668ddca46321ae530a SHA512 96e17327de311b3d16e086031038a8248431d0dda75b83ce137d6526a096b69fc062290f92ec5b58fffb56aa25437835f97a96bd15f0044d4d52263bf386d928
+EBUILD btor2tools-1.0.0_pre20220518.ebuild 783 BLAKE2B a911486c6340478d3c00421c77f8f4eca47e442cae1fd0df8c048e5ea27065c219ec58af95618eba7b837b4ee20b250746a92d0d915a66a1f01b1287feabed62 SHA512 2bb3a28dd080ffd68f8e37c92a58a12ac1f19a2864e116d4c66d46e2e793d733fe1d9fdfc2539c1c3c108f6590cb4bb0564c009d8b0b854c7f43bb1e0f644f7e
+MISC metadata.xml 437 BLAKE2B 93f1e3a98b8dd3edd95de3bd8f830427a9e05dcfc73690899ed16ec49be25bfd524d86fcaa9735d15c22515b98d13ded8a95c7a39e4970e3035c72e4cbe7d544 SHA512 39b7bd39e597f6d3086358738cb2d668f0317af3a8674eb4c032f59c64de0ceada799900bd193f244f049f51e1a91dcd9bb4474db39ac88967086206f3090a62
diff --git a/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518.ebuild b/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518.ebuild
new file mode 100644
index 000000000000..efade1283737
--- /dev/null
+++ b/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=b8456dda4780789e882f5791eb486f295ade4da4
+
+inherit cmake
+
+DESCRIPTION="Generic parser and tools for the BTOR2 format"
+HOMEPAGE="https://github.com/Boolector/btor2tools/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Boolector/${PN}.git"
+else
+ SRC_URI="https://github.com/Boolector/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-also-static.patch
+ "${FILESDIR}"/${P}-cmake-clfags.patch
+)
+
+src_install() {
+ cmake_src_install
+
+ if use examples ; then
+ insinto /usr/share/${PN}
+ dodoc -r examples
+ fi
+}
diff --git a/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch
new file mode 100644
index 000000000000..061ddac84194
--- /dev/null
+++ b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch
@@ -0,0 +1,28 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ add_library(btor2parser
++ SHARED
+ btor2parser/btor2parser.c
+ )
+ target_include_directories(btor2parser PRIVATE .)
+@@ -10,6 +11,19 @@ install(
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ )
+
++add_library(btor2parser_static
++ STATIC
++ btor2parser/btor2parser.c
++)
++target_include_directories(btor2parser_static PRIVATE .)
++set_target_properties(btor2parser_static PROPERTIES OUTPUT_NAME btor2parser)
++set_target_properties(btor2parser_static PROPERTIES PUBLIC_HEADER btor2parser/btor2parser.h)
++install(
++ TARGETS btor2parser_static
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++)
++
+ add_executable(btorsim
+ btorsim/btorsimam.cpp
+ btorsim/btorsimstate.cpp
diff --git a/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch
new file mode 100644
index 000000000000..84c6631c9219
--- /dev/null
+++ b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-clfags.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -91,16 +91,6 @@ add_check_c_cxx_flag("-Wredundant-decls")
+ add_check_c_flag("-std=gnu99")
+ add_required_cxx_flag("-std=gnu++11")
+
+-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+- add_check_c_cxx_flag("-g3")
+- add_check_c_cxx_flag("-ggdb")
+-else()
+- add_check_c_cxx_flag("-O3")
+- if(NOT CHECK)
+- add_check_c_cxx_flag("-DNDEBUG")
+- endif()
+-endif()
+-
+ if(ASAN)
+ # -fsanitize=address requires CMAKE_REQUIRED_FLAGS to be explicitely set,
+ # otherwise the -fsanitize=address check will fail while linking.
diff --git a/sci-mathematics/btor2tools/metadata.xml b/sci-mathematics/btor2tools/metadata.xml
new file mode 100644
index 000000000000..237d97fb7791
--- /dev/null
+++ b/sci-mathematics/btor2tools/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Boolector/btor2tools/issues/</bugs-to>
+ <remote-id type="github">Boolector/btor2tools</remote-id>
+ </upstream>
+</pkgmetadata>