summaryrefslogtreecommitdiff
path: root/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 17:49:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 17:49:19 +0000
commit06bb974d894b86598af155dc76a6fbd76c4fa30c (patch)
tree363e323b416b8141cedf7b17e890e743d41c4c8a /sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
parente45f0df9d7f9f5260e69235b8c7c6e00153747f0 (diff)
gentoo auto-resync : 13:01:2023 - 17:49:18
Diffstat (limited to 'sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild')
-rw-r--r--sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild b/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
new file mode 100644
index 000000000000..e967b953fb59
--- /dev/null
+++ b/sci-mathematics/btor2tools/btor2tools-1.0.0_pre20220518-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=b8456dda4780789e882f5791eb486f295ade4da4
+
+inherit cmake
+
+DESCRIPTION="Generic parser and tools for the BTOR2 format"
+HOMEPAGE="https://github.com/Boolector/btor2tools/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Boolector/${PN}.git"
+else
+ SRC_URI="https://github.com/Boolector/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}"/${P}-cmake-clfags.patch )
+
+src_install() {
+ cmake_src_install
+
+ if use examples ; then
+ insinto /usr/share/${PN}
+ dodoc -r examples
+ fi
+}