summaryrefslogtreecommitdiff
path: root/sci-mathematics/bertini
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-mathematics/bertini
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-mathematics/bertini')
-rw-r--r--sci-mathematics/bertini/Manifest2
-rw-r--r--sci-mathematics/bertini/bertini-1.4.ebuild46
2 files changed, 26 insertions, 22 deletions
diff --git a/sci-mathematics/bertini/Manifest b/sci-mathematics/bertini/Manifest
index 3931e5bfdfe4..b3a991f73105 100644
--- a/sci-mathematics/bertini/Manifest
+++ b/sci-mathematics/bertini/Manifest
@@ -1,3 +1,3 @@
DIST BertiniSource_v1.4.tar.gz 1827401 BLAKE2B 4869ef0b73a3688df504bff84dc36682700c4916dcfdca68ae3a1bf87ceda2f664c35e2b5fe4b5d0859bbab110a2fa1e474361847db897859c3d5d17c48f122f SHA512 bb53f8ed24a0f21e95b4e373be36039b69ea0ddb11ad8240bcf52ce64436a56c1f2057a5d733d017fdf68cfb3598a473e1f12b4659308890e2e2575b7d8143f6
-EBUILD bertini-1.4.ebuild 1041 BLAKE2B a3a0da2ceab1d0fef50a2dc1ca80f1e64d2ed64353d222917499b3557045d89b87dc95651c0ff880558ec39b384e0bc30fea72b9a4ff75800241e91a6b03ee85 SHA512 4757e0e9486c1878c51e0fafa101dbc71e2107ca872afbc16268b366b39c4a60c88e2d9a2e2b93c027cf06ec8e1136cd2ece12bdd913f73d669b26096269ba05
+EBUILD bertini-1.4.ebuild 1323 BLAKE2B 91903ca89a071f3f011a047b8d5a37d140f9665d74d1f17ebc3678f86d65cea5642ba266c83ca1a3b435d5d1783eb54c7afc503c3366182c81e4097eacb4c006 SHA512 cebc05cb552daa75e8959dc6d0bf5fd0890fdda00d1bb6c4d502ef2bd32bc5c12bdd7660a1b89a2dcab1839ac2fcc9b6ab5d560371815688ecd7387d94763011
MISC metadata.xml 815 BLAKE2B 67dcf99c0602a8e96628fca184d2447f44c399ba3641d7fab57273e8216c9674122fe432099aaf74d1630652770e7c92dae3fdc9d1ca4604e503e331b61dd9da SHA512 552d4d83e494fdc984fc55924b287c45430381fe7ba7f90eb5ba0db5ecb0de68ed683fd57ac76ba0aca8488ed6b3c501608fecf0b94c35238b443a0a09081242
diff --git a/sci-mathematics/bertini/bertini-1.4.ebuild b/sci-mathematics/bertini/bertini-1.4.ebuild
index 8eb1c6cae69d..2ad14ca941e0 100644
--- a/sci-mathematics/bertini/bertini-1.4.ebuild
+++ b/sci-mathematics/bertini/bertini-1.4.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
MYP="BertiniSource_v${PV}"
-
DESCRIPTION="Software for Numerical Algebraic Geometry"
HOMEPAGE="http://bertini.nd.edu"
-
SRC_URI="http://www3.nd.edu/~sommese/bertini/${MYP}.tar.gz"
+S="${WORKDIR}/${MYP}/src"
LICENSE="bertini"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples +optimization"
-DEPEND="
+
+BDEPEND="
sys-devel/bison
sys-devel/flex
"
@@ -24,34 +24,38 @@ RDEPEND="
dev-libs/gmp
dev-libs/mpfr
"
-
-S="${WORKDIR}/${MYP}/src"
+DEPEND="${RDEPEND}"
src_prepare() {
+ default
+
+ # bug #723328
+ append-cflags -fcommon
+
+ # Ensure this is before the CFLAGS sed
+ # or breakage occurs if 'gcc' is in your CFLAGS
+ sed -i -e "s/gcc/$(tc-getCC)/" Makefile || die
+
if ! use optimization; then
- sed -i -e "s/\$(OPT)/ ${CXXFLAGS} ${LDFLAGS}/" Makefile
+ sed -i -e "s/\$(OPT)/ ${CFLAGS} ${CXXFLAGS} ${LDFLAGS}/" Makefile || die
else
- sed -i -e "s/\$(OPT)/ \$(OPT) ${LDFLAGS}/" Makefile
+ # If people want the optimisation offered by upstream,
+ # let's ensure they don't accidentally override it.
+ filter-flags -O?
+ sed -i -e "s/\$(OPT)/ \$(OPT) ${CFLAGS} ${LDFLAGS}/" Makefile || die
fi
- sed -i -e "s/gcc/$(tc-getCC)/" Makefile
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- emake
}
src_install() {
dobin bertini
+
if use doc; then
dodoc "${WORKDIR}/${MYP}/BertiniUsersManual.pdf"
fi
+
if use examples; then
- insinto "/usr/share/${PN}"
- doins -r "${WORKDIR}/${MYP}/examples"
+ docinto examples
+ dodoc -r "${WORKDIR}/${MYP}/examples"
elog "Examples have been installed into /usr/share/${MYP}"
fi
}