summaryrefslogtreecommitdiff
path: root/sci-mathematics/bertini
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-06 21:22:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-06 21:22:20 +0000
commit7842f444601c620f190db9801e59c4f11e686f15 (patch)
treebd6f22298de6de933ea0b3b327ce4b26a2dc1ca5 /sci-mathematics/bertini
parent734ebb79080aab27a82cb1a8380d4fc581e25638 (diff)
gentoo auto-resync : 06:02:2023 - 21:22:20
Diffstat (limited to 'sci-mathematics/bertini')
-rw-r--r--sci-mathematics/bertini/Manifest3
-rw-r--r--sci-mathematics/bertini/bertini-1.6.ebuild65
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/bertini/Manifest b/sci-mathematics/bertini/Manifest
index cdba6fd2df4b..62327b14000b 100644
--- a/sci-mathematics/bertini/Manifest
+++ b/sci-mathematics/bertini/Manifest
@@ -1,3 +1,6 @@
DIST BertiniSource_v1.4.tar.gz 1827401 BLAKE2B 4869ef0b73a3688df504bff84dc36682700c4916dcfdca68ae3a1bf87ceda2f664c35e2b5fe4b5d0859bbab110a2fa1e474361847db897859c3d5d17c48f122f SHA512 bb53f8ed24a0f21e95b4e373be36039b69ea0ddb11ad8240bcf52ce64436a56c1f2057a5d733d017fdf68cfb3598a473e1f12b4659308890e2e2575b7d8143f6
+DIST BertiniSource_v1.6.tar.gz 4957384 BLAKE2B 395ca96c52b167eaefe672d31c79c5791d92b1375059c0e6244042f2e987d011d0c9b5d6590555654e0b23d15aec2dcdcb2c1fa23fec73fb5c0e307c960c334b SHA512 04e0964e714ede697d49aeecd4008102d653472664d22fc2f491e93d8a5cc18a9db2980d57a23a8ea88f1fab9b98aeb2d36fc112c0a0aa3510e152a8edcb1f95
+DIST BertiniUsersManual.pdf 1188567 BLAKE2B d940e95a86ec2b81d5afff3ade9fe28f5c3034e9250a844d3b8ad4de5ded1b4b98a68d2da1f61e17fd7f25ed481522805505850fc011f2a5642ca7cee4e86c8f SHA512 f206645cf20eb4da9e00b62440e612e0037fe02882167cdb48074d4532b913a940b551f4624fd00309c8f5d2a9775350430b143277b1dfe8064fd899a58408d9
EBUILD bertini-1.4.ebuild 1323 BLAKE2B 91903ca89a071f3f011a047b8d5a37d140f9665d74d1f17ebc3678f86d65cea5642ba266c83ca1a3b435d5d1783eb54c7afc503c3366182c81e4097eacb4c006 SHA512 cebc05cb552daa75e8959dc6d0bf5fd0890fdda00d1bb6c4d502ef2bd32bc5c12bdd7660a1b89a2dcab1839ac2fcc9b6ab5d560371815688ecd7387d94763011
+EBUILD bertini-1.6.ebuild 1401 BLAKE2B ed9b252c03a4670b0b30919a208c47f97ca9597685f020c36241ac43bf5546de10d78dfc78b5aea3d89e3e9401d15d3c8f8ec69df8ca2c72862b6fe944930c99 SHA512 077dbcf4287b84c8bac9d2bba6ba85a57c271cd2792c1af3cebc59435b55391bae6a9432697c1d334f84f19c2ac61a6ede416935f20eda4fde0d403269e0d690
MISC metadata.xml 824 BLAKE2B 7151b5c87b9366cf0d67f70239ecb9f19403ccb1dbe3d2ac2238d8676417acbfc9fdef79ed5030ed7004e6f6e71c7384ed68e6e11319e82ae29532aa64e4ac46 SHA512 6be583a25b2a6c52dfa8c24e48a3055c29b8f9db64879e28b968de2e62e843a40d2cab8eef58911bc6fadaeaaa3f05f32a5525f2ef30f092880281dd848142e9
diff --git a/sci-mathematics/bertini/bertini-1.6.ebuild b/sci-mathematics/bertini/bertini-1.6.ebuild
new file mode 100644
index 000000000000..5fe2bd594d0f
--- /dev/null
+++ b/sci-mathematics/bertini/bertini-1.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MYP=BertiniSource_v${PV}
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Software for Numerical Algebraic Geometry"
+HOMEPAGE="http://bertini.nd.edu"
+SRC_URI="https://bertini.nd.edu/${MYP}.tar.gz
+ doc? ( https://bertini.nd.edu/BertiniUsersManual.pdf )"
+S="${WORKDIR}"/${MYP/./}
+
+LICENSE="bertini"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +optimization"
+
+RDEPEND="
+ dev-libs/gmp
+ dev-libs/mpfr
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ default
+
+ # bug #723328
+ append-cflags -fcommon
+
+ # Ensure this is before the CFLAGS sed
+ # or breakage occurs if 'gcc' is in your CFLAGS
+ sed -i -e "s/gcc/$(tc-getCC)/" src/Makefile || die
+
+ if ! use optimization ; then
+ sed -i -e "s/\$(OPT)/ ${CFLAGS} ${CXXFLAGS} ${LDFLAGS}/" src/Makefile || die
+ else
+ # If people want the optimisation offered by upstream,
+ # let's ensure they don't accidentally override it.
+ filter-flags -O?
+ sed -i -e "s/\$(OPT)/ \$(OPT) ${CFLAGS} ${LDFLAGS}/" src/Makefile || die
+ fi
+}
+
+src_configure() {
+ econf --prefix=/usr --includedir=/usr/include/${PN}
+
+ use doc && DOCS+=( "${DISTDIR}"/BertiniUsersManual.pdf )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ find "${ED}" -name "*.la" -delete || die
+
+ einstalldocs
+}