summaryrefslogtreecommitdiff
path: root/sci-mathematics/bertini
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/bertini
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/bertini')
-rw-r--r--sci-mathematics/bertini/Manifest5
-rw-r--r--sci-mathematics/bertini/bertini-1.4.ebuild57
-rw-r--r--sci-mathematics/bertini/metadata.xml25
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-mathematics/bertini/Manifest b/sci-mathematics/bertini/Manifest
new file mode 100644
index 000000000000..d0f5551b6eba
--- /dev/null
+++ b/sci-mathematics/bertini/Manifest
@@ -0,0 +1,5 @@
+DIST BertiniSource_v1.4.tar.gz 1827401 SHA256 61ce11b2714d1540311c1a8e3192ff92bfbd8fd85c357b554d22ab6cbe67f6a1 SHA512 bb53f8ed24a0f21e95b4e373be36039b69ea0ddb11ad8240bcf52ce64436a56c1f2057a5d733d017fdf68cfb3598a473e1f12b4659308890e2e2575b7d8143f6 WHIRLPOOL f832076f0c2277c35df28d7ed94476e1ec086c5fcb4a80e52fd3cd2d5fce79ecbc66606ba1cb0f71ca0fa6180c0e82e79b5cc85eb5949de64b6c9d8e2e8b7e6a
+EBUILD bertini-1.4.ebuild 1041 SHA256 0f6a63715c85f5156f4cf9a6f68357da77025e5c66d7753cb037e0d460e9391d SHA512 4757e0e9486c1878c51e0fafa101dbc71e2107ca872afbc16268b366b39c4a60c88e2d9a2e2b93c027cf06ec8e1136cd2ece12bdd913f73d669b26096269ba05 WHIRLPOOL 97c70916758afbd1ef9d5d1d7670049ca47aa2024dda6a92b4d91980d683911476e1b65d29c1085a953650075d349188fa482047aa2b91ed65db8dcc1b8c29cd
+MISC ChangeLog 2430 SHA256 b3a340e4efe92f7b3b33e1848d4f461268db2935e6e614d3731cdcae99a397d7 SHA512 85bf37e0d3910a01b74992683e6b58d7254bc3b5e2d64948edd03a82ebb64c81519aa85ac1ab259073ca123253bee4d528f3f7ec667376c5d6f46f82d1888c51 WHIRLPOOL 34f8904c80f9954d70327c8c6f695f8bc94b5f97ce4911467ac7467039d79d21c6aea42e2b7405a545c1a21d62da6a7d1049a0123ffd9e2183655e434ae585be
+MISC ChangeLog-2015 366 SHA256 d9ecd4284c2045754e9d954c05761c581cb77b865f3cfbbf0bc689c6ebe57185 SHA512 2cf11ebe1a982e85a6bc89cc7f45046bd15a69dd41f2881a3289b33bff5ac6c717a9e053059cc9c48406beaad6fc78ba4bcd973566a131ef654100f68fafad2e WHIRLPOOL 9d3f2247dcc8875876eb0583aab29e1b78b12826598fa6564602971110397241025db0318c3ee54b2c3de2a661c006bcf67b68b48102f0abc55d596dd0fcd559
+MISC metadata.xml 815 SHA256 759050f82cb66ec0ac30293e3bb4a286d46523a2ef108116b50ca040b43cf8e2 SHA512 552d4d83e494fdc984fc55924b287c45430381fe7ba7f90eb5ba0db5ecb0de68ed683fd57ac76ba0aca8488ed6b3c501608fecf0b94c35238b443a0a09081242 WHIRLPOOL 066493a4fdb26d4c1e9123f576c7fc8e0e50eea0014eb84205f4e4444371dca69dc7e4490eb9b177f71cd0b923e8374de57215736716cc9407c6f01c661b0cb8
diff --git a/sci-mathematics/bertini/bertini-1.4.ebuild b/sci-mathematics/bertini/bertini-1.4.ebuild
new file mode 100644
index 000000000000..8eb1c6cae69d
--- /dev/null
+++ b/sci-mathematics/bertini/bertini-1.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MYP="BertiniSource_v${PV}"
+
+DESCRIPTION="Software for Numerical Algebraic Geometry"
+HOMEPAGE="http://bertini.nd.edu"
+
+SRC_URI="http://www3.nd.edu/~sommese/bertini/${MYP}.tar.gz"
+
+LICENSE="bertini"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +optimization"
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND="
+ dev-libs/gmp
+ dev-libs/mpfr
+"
+
+S="${WORKDIR}/${MYP}/src"
+
+src_prepare() {
+ if ! use optimization; then
+ sed -i -e "s/\$(OPT)/ ${CXXFLAGS} ${LDFLAGS}/" Makefile
+ else
+ sed -i -e "s/\$(OPT)/ \$(OPT) ${LDFLAGS}/" Makefile
+ fi
+ sed -i -e "s/gcc/$(tc-getCC)/" Makefile
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin bertini
+ if use doc; then
+ dodoc "${WORKDIR}/${MYP}/BertiniUsersManual.pdf"
+ fi
+ if use examples; then
+ insinto "/usr/share/${PN}"
+ doins -r "${WORKDIR}/${MYP}/examples"
+ elog "Examples have been installed into /usr/share/${MYP}"
+ fi
+}
diff --git a/sci-mathematics/bertini/metadata.xml b/sci-mathematics/bertini/metadata.xml
new file mode 100644
index 000000000000..b7d09f96e255
--- /dev/null
+++ b/sci-mathematics/bertini/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+Bertini: Software for Numerical Algebraic Geometry
+
+Facts in brief:
+
+ Purpose: The numerical solution of systems of polynomial equations
+
+ Approach: Homotopy continuation.
+
+ Authors: Daniel J. Bates, Jonathan D. Hauenstein, Andrew J. Sommese, Charles W. Wampler
+
+ Background: Bertini is a general-purpose solver, written in C, that was
+ created for research about polynomial continuation.
+</longdescription>
+<use>
+ <flag name="optimization">Accept upstream's choices for -O option.</flag>
+</use>
+</pkgmetadata>