summaryrefslogtreecommitdiff
path: root/sci-mathematics/alt-ergo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-mathematics/alt-ergo
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-mathematics/alt-ergo')
-rw-r--r--sci-mathematics/alt-ergo/Manifest4
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild48
-rw-r--r--sci-mathematics/alt-ergo/metadata.xml36
3 files changed, 72 insertions, 16 deletions
diff --git a/sci-mathematics/alt-ergo/Manifest b/sci-mathematics/alt-ergo/Manifest
index 1cacec94a01f..b99ff2cb935d 100644
--- a/sci-mathematics/alt-ergo/Manifest
+++ b/sci-mathematics/alt-ergo/Manifest
@@ -1,3 +1,5 @@
DIST alt-ergo-2.3.0.tar.gz 455577 BLAKE2B 1836782be452df5147fc3041517fd267f3ce7facd15ad460c3e1dfba2b6ea455fee79ad8264ccb12cf21622c21a54c186c9943e7bffb392daab15d046ff93863 SHA512 a2f209b62b8494bfefe84328cdc786185e0534c5e224e212b83045b078352a51d2ab02622f72c22c74c7de95c7a554cbdae2a9a8a0c41f3f26c841f8c72f6b21
+DIST alt-ergo-2.4.1.tar.gz 2883046 BLAKE2B 6930080f7735f043e33d02b7fa0990c53992848796c0a5cf6ea4d7122eb6b9e5d6ac7ce420a4a19da35fa0ce5ff431bc228f2314a6f709f27a16bc7481bbacd5 SHA512 c3eee41d3c588ca89c2a1eebe9f10914ef647743b58fb562b682172cf6b6bdeb0920ebbba8a850820c0cb53bad0260f11b82fe71f00830ea9b33f5bb5d4fd048
EBUILD alt-ergo-2.3.0.ebuild 1207 BLAKE2B 395779b3fa2c360a9162ee18b5a8266f978ac96ac09e4da308efbb3f3eabc1cff770c2404dd1e2c0531d8b74b40b82e11331b5a5a69ef92bfe589ddcd7fbfa05 SHA512 d4611afe608836003b93f7e6942da711799116cffaed63ccbbbd1b36a8d8de638a5fee103d3cc751df8cb332e54e28bcaff72142b1be2a3fa1ba4bea1349b257
-MISC metadata.xml 753 BLAKE2B d02fb64b2dfa930640c981f7c4f145422e5e4737cf82074ef2b4043e8a8bb14a9ff83301cb98cec0c94681da8b055745b87ebaf5aca7e2a8dd921c1ff4ef0f67 SHA512 c43745074c9fa0c9b47804144f005dfc8abd8367954f35e6ab67fad415aad58b87b7de088bce395737a9db03749ef385bfa6c0e10a800eecd8f93767d4f33dc4
+EBUILD alt-ergo-2.4.1-r1.ebuild 997 BLAKE2B 87c4ced0832718030a39a953531b3742baddc9b15070ba1be5dfb7ddda3a1373ebe2a24071ef399960374ca98ca74505564f6aa8a111fcce2b9270cb08e6db67 SHA512 10b356e99545e1f4f4ad29c6d1e0d86ee5eeb576c2139cf268ee5d13559eb9fe39e24be281ca100365584c4aecf15df04b07793615e6531a5031a0cd163a4b43
+MISC metadata.xml 957 BLAKE2B 2ac1b5428ee88fa81b3898a351b770b9a3b4e91ad049e7ab2b5b62e3ddcef635e2f19f801ef1c067b51c2f30f513b40a82e968a314be10e7a5ff795df24dd6d5 SHA512 bcbe312badeb5f3d6c243d620ec5744ac6bf3c23e6bc7b6327c7a1a72b42f2cc68cd4326b065a3fca3c2a9c7c1670e2a84ca1ca2e7bf423a274025010a6735f4
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..52d3124f6809
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.09.0:=[ocamlopt=]
+ >=sci-mathematics/psmt2-frontend-0.4.0:=
+
+ >=dev-ml/menhir-20181006:=
+ >=dev-ml/ocplib-simplex-0.4:=
+ dev-ml/camlzip:=
+ dev-ml/cmdliner:=
+ dev-ml/num:=
+ dev-ml/seq:=
+ dev-ml/stdlib-shims:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/dune-configurator"
+
+src_prepare() {
+ default
+
+ # Remove the GTK2 GUI frontend because GTK2 in Gentoo is deprecated
+ rm -r src/bin/gui || die
+}
+
+src_configure() {
+ sh ./configure --prefix /usr --libdir=/usr/$(get_libdir) || die
+}
+
+src_install() {
+ dune-install alt-ergo-lib alt-ergo-parsers alt-ergo
+
+ use examples && dodoc -r examples
+}
diff --git a/sci-mathematics/alt-ergo/metadata.xml b/sci-mathematics/alt-ergo/metadata.xml
index bd913dcab82d..0892f84cbfc2 100644
--- a/sci-mathematics/alt-ergo/metadata.xml
+++ b/sci-mathematics/alt-ergo/metadata.xml
@@ -1,19 +1,25 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
<pkgmetadata>
- <maintainer type="person">
- <email>tupone@gentoo.org</email>
- <name>Tupone Alfredo</name>
- </maintainer>
- <longdescription lang="en">
- Alt-Ergo is an open-source automatic solver of mathematical formulas
- designed for program verification. It is based on Satisfiability Modulo
- Theories (SMT). Solvers of this family have made impressive advances
- and became very popular during the last decade. They are now used is
- various domains such as hardware design, software verification and
- formal testing.
- </longdescription>
- <upstream>
- <remote-id type="github">OCamlPro/alt-ergo</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Alt-Ergo is an open-source automatic solver of mathematical formulas
+ designed for program verification. It is based on Satisfiability Modulo
+ Theories (SMT). Solvers of this family have made impressive advances
+ and became very popular during the last decade. They are now used is
+ various domains such as hardware design, software verification and
+ formal testing.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/OCamlPro/alt-ergo/issues/</bugs-to>
+ <remote-id type="github">OCamlPro/alt-ergo</remote-id>
+ </upstream>
</pkgmetadata>