summaryrefslogtreecommitdiff
path: root/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /sci-mathematics/alt-ergo/alt-ergo-2.4.1-r2.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'sci-mathematics/alt-ergo/alt-ergo-2.4.1-r2.ebuild')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.4.1-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r2.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r2.ebuild
new file mode 100644
index 000000000000..bc908a192c9e
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="amd64"
+IUSE="examples +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.09.0:=[ocamlopt=]
+ >=sci-mathematics/psmt2-frontend-0.4.0:=
+
+ <dev-ml/cmdliner-1.1.0:=
+ >=dev-ml/menhir-20181006:=
+ >=dev-ml/ocplib-simplex-0.4:=
+ dev-ml/camlzip:=
+ dev-ml/num:=
+ dev-ml/seq:=
+ dev-ml/stdlib-shims:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/dune-configurator"
+
+src_prepare() {
+ default
+
+ # Remove the GTK2 GUI frontend because GTK2 in Gentoo is deprecated
+ rm -r src/bin/gui || die
+}
+
+src_configure() {
+ sh ./configure --prefix /usr --libdir=/usr/$(get_libdir) || die
+}
+
+src_install() {
+ dune-install alt-ergo-lib alt-ergo-parsers alt-ergo
+
+ use examples && dodoc -r examples
+}