summaryrefslogtreecommitdiff
path: root/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
new file mode 100644
index 000000000000..69ade990ba8f
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://alt-ergo.ocamlpro.com/http/${P}/${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples gtk +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
+ dev-ml/zarith
+ gtk? ( >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )
+ dev-ml/camlzip
+ >=dev-ml/ocplib-simplex-0.4
+ >=dev-ml/menhir-20181006
+ dev-ml/dune"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES INSTALL.md README.md )
+
+src_configure() {
+ ./configure --prefix /usr --libdir=/usr/$(get_libdir)
+}
+
+src_compile() {
+ emake
+ use gtk && emake gui
+}
+
+src_install() {
+ default
+ use gtk && emake DESTDIR="${D}" install-gui
+ insinto /usr/share/doc/${PF}
+ use examples && doins -r examples
+ mv "${D}"/usr/doc/* "${D}"/usr/share/doc/${PF}/ || die
+ rmdir "${D}"/usr/doc || die
+}