summaryrefslogtreecommitdiff
path: root/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
commit0fdd4074ff3dc0c507a9867380a4f91250a0b610 (patch)
tree83d3b64438d2f29b375d895f12b82d5c484db219 /sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
parent8fbd420dce8836e6503b162092e07b6a77a89f1d (diff)
gentoo resync : 15.10.2017
Diffstat (limited to 'sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild b/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
new file mode 100644
index 000000000000..46560c627430
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="http://alt-ergo.ocamlpro.com"
+SRC_URI="https://alt-ergo.ocamlpro.com/http/${P}/${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples gtk +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
+ dev-ml/zarith
+ gtk? ( >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )
+ dev-ml/camlzip
+ dev-ml/ocplib-simplex"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES INSTALL.md README.md )
+
+src_compile() {
+ emake
+ use gtk && emake gui
+}
+
+src_install() {
+ default
+ use gtk && emake DESTDIR="${D}" install-gui
+ insinto /usr/share/doc/${PF}
+ use examples && doins -r examples
+}