summaryrefslogtreecommitdiff
path: root/sci-mathematics/acl2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
commit268f9f01921ccb921b794d43092c5f29c1e96c56 (patch)
tree07329b3a8cb5d315182a2ec2b2f4a4b36374724d /sci-mathematics/acl2
parente3a48e635527f3e2d2254e9631f7a5758df9c3fb (diff)
gentoo auto-resync : 08:01:2023 - 06:15:27
Diffstat (limited to 'sci-mathematics/acl2')
-rw-r--r--sci-mathematics/acl2/Manifest4
-rw-r--r--sci-mathematics/acl2/acl2-8.5.ebuild92
-rw-r--r--sci-mathematics/acl2/files/50acl2-gentoo.el6
-rw-r--r--sci-mathematics/acl2/metadata.xml20
4 files changed, 122 insertions, 0 deletions
diff --git a/sci-mathematics/acl2/Manifest b/sci-mathematics/acl2/Manifest
new file mode 100644
index 000000000000..14113f3e630d
--- /dev/null
+++ b/sci-mathematics/acl2/Manifest
@@ -0,0 +1,4 @@
+AUX 50acl2-gentoo.el 230 BLAKE2B 42394e3aa3c8925a09ae331c0e133ebe0eb917991301172a50630b53c80dfda75629e8bc1ae4e9f844b5ab606ffbe0ffd70778c8066f4da386f8dad10ccee7ab SHA512 8b367c76497e50284f11606e7660148b78f069fa474bfaae49de4ac9649e524da1902b61a28ea50223d53582fe76485a8c2b26ca8b698005b2dd47cadcf99828
+DIST acl2-8.5.tar.gz 222696244 BLAKE2B e5aa8360d9f94ed398d11c4e0873818f8f49ed0e072192c7d62dde99b4a7f98b4240b352818e7691ebc98f85ab3c10981c36bb1e35317e50a111c9c7f3f57b33 SHA512 5a2e004713350ae41ced830aa8620c27963eb108baa499f7e52a1c60961b220ef7a026efdfef6cea1063f731b50f3cccbe1583a9957c9cf269b0a958ec83fe48
+EBUILD acl2-8.5.ebuild 2144 BLAKE2B 5952da8e09626d4e087783cdc2311b0485d50052c4f43e8b1046ed8ad2770c38404c0246c69b397df124d0f77385882b6b819dcf6aabaea669c462dbec46af21 SHA512 fa27d6da48e6dfaa9122cc7c9429a95af08511e00dae889f45beeb7ffd071ba251d372e2f07cfe2b6984388f0a503f828d54e8e502ed880ecbf53493a6f9e6ee
+MISC metadata.xml 816 BLAKE2B 791aff8f16b043469eb568aa6d50c2dabb2ffc3686ee846e98fd8f6e48533f5e4f86d500d8065a3a91cfce767c4990aabaf437eb97e57f8deabe19a6b9248116 SHA512 42a005fb8d3831cc422fed00a18419b959d40c3ee25a437efbfb836d9cb008fe22390a1986b090261c735fc0ff18688331ef884ee892703b166807616b947e64
diff --git a/sci-mathematics/acl2/acl2-8.5.ebuild b/sci-mathematics/acl2/acl2-8.5.ebuild
new file mode 100644
index 000000000000..bea58cd4e997
--- /dev/null
+++ b/sci-mathematics/acl2/acl2-8.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Only SBCL (dev-lisp/sbcl) is tested for now, but probably
+# more CL implementations can be added as alternative dependencies.
+# With ClozureCL (dev-lisp/clozurecl) ACL2 fails to build,
+# this might need in-depth investigation...
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Industrial strength theorem prover, logic and programming language"
+HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/
+ https://github.com/acl2/acl2/"
+SRC_URI="https://github.com/acl2/acl2/archive/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs"
+REQUIRED_USE="emacs? ( doc )"
+
+RDEPEND="
+ dev-lisp/sbcl
+ emacs? ( >=app-editors/emacs-25:* )
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? ( dev-lang/perl )
+"
+
+DOCS=( books/README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ find . -type f -name "*.bak" -delete || die
+ find . -type f -name "*.orig" -delete || die
+ rm books/workshops/2003/schmaltz-al-sammane-et-al/support/acl2link || die
+
+ default
+}
+
+src_compile() {
+ emake LISP="sbcl --no-sysinit --no-userinit --disable-debugger"
+
+ use doc && emake ACL2="${S}"/saved_acl2 basic DOC
+
+ if use emacs ; then
+ local elisp_dir
+ for elisp_dir in books/emacs books/interface/emacs ; do
+ BYTECOMPFLAGS="-L ${S}/${elisp_dir}" \
+ elisp-compile "${S}"/${elisp_dir}/*.el
+ done
+ fi
+}
+
+src_install() {
+ local saved_name=saved_acl2
+
+ sed "s|${S}|/usr/share/acl2|g" -i ${saved_name} || die
+ sed "5iexport ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
+ -i ${saved_name} || die
+
+ exeinto /usr/share/acl2
+ doexe ${saved_name}
+ insinto /usr/share/acl2
+ doins ${saved_name}.core
+ doins TAGS
+ dosym -r /usr/share/acl2/${saved_name} /usr/bin/acl2
+
+ if use doc ; then
+ doins -r books
+
+ HTML_DOCS=( doc/HTML/. )
+ einstalldocs
+ fi
+ if use emacs ; then
+ elisp-install ${PN} \
+ books/emacs/*.el{,c} \
+ books/interface/emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/acl2/files/50acl2-gentoo.el b/sci-mathematics/acl2/files/50acl2-gentoo.el
new file mode 100644
index 000000000000..d61224e84506
--- /dev/null
+++ b/sci-mathematics/acl2/files/50acl2-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(defvar *acl2-sources-dir* "/usr/share/acl2/")
+(autoload 'inferior-acl2 "inf-acl2.el"
+ "Run an inferior Acl2 process" t)
+(autoload 'run-acl2 "inf-acl2.el"
+ "Run an inferior Acl2 process" t)
diff --git a/sci-mathematics/acl2/metadata.xml b/sci-mathematics/acl2/metadata.xml
new file mode 100644
index 000000000000..df9ae811037d
--- /dev/null
+++ b/sci-mathematics/acl2/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ ACL2 is a logic and programming language in which you can model computer
+ systems, together with a tool to help you prove properties of those models.
+ "ACL2" denotes "A Computational Logic for Applicative Common Lisp". ACL2 is
+ part of the Boyer-Moore family of provers, for which its authors have
+ received the 2005 ACM Software System Award.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/acl2/acl2/issues/</bugs-to>
+ <remote-id type="github">acl2/acl2</remote-id>
+ </upstream>
+</pkgmetadata>