summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 23:39:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 23:39:38 +0000
commitcc5ddec0bbae3bf2151f62ef22d19b5e85cb8f35 (patch)
tree0ecbd113fafef1c07a494eb72954a4768ea4040a /sci-libs
parent9aa795a0179b29f7489bd04584bc8d2914da467b (diff)
gentoo auto-resync : 19:02:2024 - 23:39:38
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin45090 -> 45089 bytes
-rw-r--r--sci-libs/onnx/Manifest2
-rw-r--r--sci-libs/onnx/onnx-1.15.0-r1.ebuild (renamed from sci-libs/onnx/onnx-1.15.0.ebuild)44
3 files changed, 25 insertions, 21 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 54fca18fa4bb..8c34c088e77c 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index 731c22139c3f..968a445894eb 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -3,5 +3,5 @@ AUX onnx-1.14.1-musl.patch 518 BLAKE2B 540d5c81d43a515ca6c4598057b80ad2157ba528d
DIST onnx-1.14.1.tar.gz 11570627 BLAKE2B df478219b5d557ad7e0717377996eefc02baa88a89d9681b17e00670e42fa3c8e47db0f5c5fdfab682fa7d80032559da8276c5106a91a7599d190427e2b6e4a8 SHA512 f846fffb286c4aeadc01462f220515f0a5c2ce1cbec849da7092a08c2676f8308af7315318a2866e9182f9aed719984ef95a9ddc69ffe0e62e40664395df5efd
DIST onnx-1.15.0.tar.gz 12360484 BLAKE2B 4d35b82c128a69124b9bfcb3e56b3d584b7451ae739a91039e201dd485efa3e90e34e6cf135993317622f8f524160a38556231b2b0561e93d8cd0487abf35c1b SHA512 b46a4ab70af88053318eba45251c1f71528f15e45a33042877570e8d857febd3ec66e2e811fcda2105a4f17b84c9a1c6a0aaa22756c3287321b3ea29e83127fd
EBUILD onnx-1.14.1-r2.ebuild 1287 BLAKE2B 981384a06007a6e1d0bbe602a6ab46cf856a5f6c07223599fbebfd23f2dfef4ded766367580b11e635421b0fb94ca0574fde853ee6dadb4d5f50e978a1eec1b9 SHA512 98cd76cee92bebe93192cce202fd7caf4cbb42d0afcf312acbdcb57992ccc1a7efe1f9cc3d1dc9df9cdc657b5c1ae4bfb2d6e5f86624f4bb6b5853d6a19ec952
-EBUILD onnx-1.15.0.ebuild 1202 BLAKE2B b02f87b6f3765cc308be2f150cd528fd9840a5cbeb7b786db9583d4b9282707b374c4b1c360ce5944a0c0f5ce838416114659188b38913dedceaf2bdd38ea4ec SHA512 64153c948cf18055fa4bb9196e6a384f727281d32e2827039fa60236348d4c630d7525a9bab61e1d092c795142beb811db4263bff5f6eba13af5afb69a22804b
+EBUILD onnx-1.15.0-r1.ebuild 1181 BLAKE2B fb08ccfcb7f183d1143e516a66b49e714bebd2d88abb7838d1c5b66eb1d4dd9b767f87ae6987eef2d6f2ea5781261c07f0c24cbc49ac02601c2468c47a434929 SHA512 a4ee45c2f908e05f4fda7f9d418576182f77174543c176cd290137129017b56b49d7f7061c84f561bcaf2e1d659456746c9b1b49d86f2f164dbeb812fdb00bc8
MISC metadata.xml 322 BLAKE2B a78b6feffba2cf354154448a0e0cef5e866ec51ff0158939e7a5be1f3c4cb9bb3b29ae88ae06540627946fc3e0f6e9a63ef4d8951385e840a7a87ada99e1d50a SHA512 9d81e8e43822232c8c8cf690b6bdb9939f04adeb9230f8225a5b0b10083f9555304768901c46cc5d29c41038397bbb3b12e0111c3d0443f4c0003e99b99fc50f
diff --git a/sci-libs/onnx/onnx-1.15.0.ebuild b/sci-libs/onnx/onnx-1.15.0-r1.ebuild
index 1e57c8b8213f..8e846b3e6d5f 100644
--- a/sci-libs/onnx/onnx-1.15.0.ebuild
+++ b/sci-libs/onnx/onnx-1.15.0-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_OPTIONAL=1
DISTUTILS_EXT=1
PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1 cmake
@@ -16,44 +15,49 @@ SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-IUSE="python"
RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- )
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
dev-libs/protobuf:=
"
DEPEND="${RDEPEND}"
-BDEPEND="python? (
- ${DISTUTILS_DEPS}
-)"
-
src_prepare() {
cmake_src_prepare
- use python && distutils-r1_src_prepare
+ distutils-r1_src_prepare
}
-src_configure() {
+python_configure_all() {
mycmakeargs=(
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON
-DONNX_USE_LITE_PROTO=ON
)
cmake_src_configure
- use python && distutils-r1_src_configure
}
-src_compile() {
+src_configure() {
+ distutils-r1_src_configure
+}
+
+python_compile_all() {
cmake_src_compile
- use python && CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
}
-src_install() {
+src_compile() {
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ )
+ CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
+}
+
+python_install_all() {
cmake_src_install
- use python && distutils-r1_src_install
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
}