summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 02:37:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 02:37:55 +0100
commitb5c8e7977a8950fe976559fbed28db9c0bcd3d6f (patch)
treef3685b9d72ea7daa9be01003ad1168de69152385 /sci-libs
parente26a7b5ef1fe42a66a3c91fe878da93c7cf83737 (diff)
gentoo auto-resync : 19:07:2022 - 02:37:54
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin44565 -> 44565 bytes
-rw-r--r--sci-libs/nlopt/Manifest1
-rw-r--r--sci-libs/nlopt/nlopt-2.7.1-r1.ebuild111
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 2c010dbbfd2f..4e39a3120237 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/nlopt/Manifest b/sci-libs/nlopt/Manifest
index 1b7391246775..048b954e3c04 100644
--- a/sci-libs/nlopt/Manifest
+++ b/sci-libs/nlopt/Manifest
@@ -1,5 +1,6 @@
DIST nlopt-2.6.2.tar.gz 2040229 BLAKE2B f1f4124de574600ddbef8a885bbdd3a4f57b469b2f958ce94bbc831cf9bfa8a845e438fccfe4ab219a73a5675b8d880f6d49e0e7cbe9d0966777b0d2344521d4 SHA512 61e5c01140a57c0ad2a0acd82ad50dce1b5679dc281e55cbbc332e876b19a689013100617545a42b721d8c487df37d6ccd67859171243433fe29468f259b556b
DIST nlopt-2.7.1.tar.gz 2044180 BLAKE2B 6d459f94a26ee6dd7f72c73c48992bd047150aa525bc4ad088c8516127afc5c7843f6fbb6726c2f845271b87934c13e0892a063362ab50df51f92e81979111fb SHA512 e23cb522fc696010574c14b72be85acc0f8ccf0bf208bf2b8789c57d6c5a6e6d419ee10330581518b1c1567018ae909b626ce7761d4fbd5bf112916871e420e2
EBUILD nlopt-2.6.2-r1.ebuild 2307 BLAKE2B 9c57f104122725bb2660bde7259ff187256d26cffbb4f0bd399acd2b07dcbac522ea4c83ea2196c84a274fe3c188ee61830e0e09d93505a78df1d74618505364 SHA512 858cc72c427ec512c1ef07619fc44230b1b5fe9b1ca68899341a80c13db7a9a1ac82cc8a8dd3d419a832519739ec672361ee3acdb058f31140df9195101fefd9
+EBUILD nlopt-2.7.1-r1.ebuild 2137 BLAKE2B 3222a9313e12e3aa2527edb03d116571be7f39a5deb620d9e473fe20ad1f0f6b779e07d8f4f050884747e14e63aeccd4331f4ce873a4753156f145437deb10c3 SHA512 0af89d4895a25e37c3270f0940fb82d79ecb010328688cd62ae1b8e225d77deb62e92b902bf4d7c3f088295a42be0f4012efc55df7a7379b45109fcbb0025236
EBUILD nlopt-2.7.1.ebuild 1989 BLAKE2B 9250bcd302e71a9d261930c8ec91646d5b9981a9aaec70274bc1e2c006f15e40d787c6ba7c7f02fbd31cf9c47144fb7a97017954d9ffe0ca9845a7b6914a479e SHA512 d618cf5a1f7ee9d41e6cc7e9a5756b9fa59668bade2428bbcae8a4f4e782268e095f9dbdeb95eaee0c23aa1c5508f18cdde7b869328063f1becb8c13d278651b
MISC metadata.xml 1096 BLAKE2B 2b35b6f79c882fbae26b6bc68c75e30b0e2d48f540696cbbc48f06c2686e89a1a5f582d59d2c1ee3b47d5f813f4dbc20cd1d35228c7f968e327e41bb2f1f4da9 SHA512 5776b4b8faa1a6406f1d65bcd9de9ce4087580d98b5c3272804d442905c34d64c6e7d632022425e6e13b12161c94a99906a6196c3624b5b9b4aa1eac6fe9aa1e
diff --git a/sci-libs/nlopt/nlopt-2.7.1-r1.ebuild b/sci-libs/nlopt/nlopt-2.7.1-r1.ebuild
new file mode 100644
index 000000000000..a7ca0ef31672
--- /dev/null
+++ b/sci-libs/nlopt/nlopt-2.7.1-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-r1 cmake fortran-2
+
+DESCRIPTION="Non-linear optimization library"
+HOMEPAGE="https://github.com/stevengj/nlopt"
+SRC_URI="https://github.com/stevengj/nlopt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="cxx guile octave python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ guile? ( dev-scheme/guile:* )
+ octave? ( >=sci-mathematics/octave-6 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="python? ( dev-lang/swig )"
+
+src_prepare() {
+ cmake_src_prepare
+
+ use python && python_copy_sources
+}
+
+src_configure() {
+ # MATLAB detection causes problems (as in bug 826774) if we don't
+ # explicitly disable it.
+ local mycmakeargs=(
+ -DNLOPT_CXX=$(usex cxx)
+ -DNLOPT_FORTRAN=$(usex test)
+ -DNLOPT_GUILE=$(usex guile)
+ -DNLOPT_OCTAVE=$(usex octave)
+ -DNLOPT_MATLAB=OFF
+ -DNLOPT_PYTHON=OFF
+ -DNLOPT_SWIG=$(usex python)
+ -DNLOPT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+
+ if use python; then
+ python_configure() {
+ local mycmakeargs=(
+ ${mycmakeargs[@]}
+ -DNLOPT_PYTHON=ON
+ -DINSTALL_PYTHON_DIR="$(python_get_sitedir)"
+ )
+
+ cmake_src_configure
+ }
+
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use python; then
+ python_foreach_impl run_in_build_dir cmake_src_compile
+ fi
+}
+
+src_test() {
+ do_test() {
+ local a f
+ cd "${BUILD_DIR}"/test
+ for a in {1..$(usex cxx 9 7)}; do
+ for f in {5..9}; do
+ ./testopt -a $a -o $f || die "algorithm $a function $f failed"
+ done
+ done
+ }
+
+ do_test
+
+ if use python; then
+ python_foreach_impl run_in_build_dir do_test
+ fi
+}
+
+nlopt_install() {
+ cmake_src_install
+ python_optimize
+}
+
+src_install() {
+ cmake_src_install
+
+ if use python; then
+ python_foreach_impl run_in_build_dir nlopt_install
+ fi
+
+ local r
+ for r in */README; do
+ newdoc ${r} README.$(dirname ${r})
+ done
+}