summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
commit9afce155a599e5f4518f3c7913b6424ac13be12e (patch)
tree60420eafdcf940c0e4555d9aa8e4e9017a646344 /sci-libs
parenteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (diff)
gentoo auto-resync : 06:11:2023 - 16:19:27
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin45135 -> 45137 bytes
-rw-r--r--sci-libs/scikit-image/Manifest2
-rw-r--r--sci-libs/scikit-image/scikit-image-0.22.0.ebuild61
-rw-r--r--sci-libs/scikit-learn/Manifest2
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.3.2.ebuild60
-rw-r--r--sci-libs/scikit-optimize/Manifest3
-rw-r--r--sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-numpy-1.24.patch22
-rw-r--r--sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-scikit-learn-1.2.0.patch104
-rw-r--r--sci-libs/scikit-optimize/scikit-optimize-0.9.0-r1.ebuild39
9 files changed, 293 insertions, 0 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 2cd21a0a26c4..e50d0fb1b660 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/scikit-image/Manifest b/sci-libs/scikit-image/Manifest
index e226626c7608..5fdbbdd1fb4c 100644
--- a/sci-libs/scikit-image/Manifest
+++ b/sci-libs/scikit-image/Manifest
@@ -1,3 +1,5 @@
DIST scikit-image-0.19.3.tar.gz 22232287 BLAKE2B 855584be0e69ac6e0dc7a17a68a1bca6843b471073e63d098b4933bc301eab5246d4cd2b444960de7fcd37012b66f7ba8cd6030ac485a7ab3aa1d36501aef0c7 SHA512 cda1699200e19155da13e313eb129771b7bb895913e552b959a3374267fe4f73c33d5e6e2fa2d49326903c901925797e46b9f05342a78c5332df1c266d37471a
+DIST scikit_image-0.22.0.tar.gz 22685018 BLAKE2B 7d0a65f75f5a58211e21501d6cc6a638f1d36e9a2198a3ad9ff2f230890496c41d5e6cdaed02bbaa62f26aa57fd24fc993656cbdfc2c9c9750147d0f325e56f1 SHA512 4b8c097cd5465f57b1c0879363fe3bdc0941decf2d1f8a881f13f2b7f3207c425f3a0cdcb4be0eed7b33d3ac2f3f8b1835d1cfa69cd3fa2ff5e0be11385fef48
EBUILD scikit-image-0.19.3-r1.ebuild 1709 BLAKE2B 64a320f739ce86bc09d93173c412c2f0585be15438eb43678b68d63989da62b2041dd38eabb767ac1d835dcd9cd3908949ffb588166fffe8d3c17de17893347b SHA512 64f7076edd4385ee6d41d472e77e63ea4a7c24cbdf58d82747dffbc8f5c4a241104d8cab03117ac3dbe8ddaf26d4da0655f319bee95cb82518d55b6ea7843a41
+EBUILD scikit-image-0.22.0.ebuild 1835 BLAKE2B dd12aac249e4a8a2fa4dca268f331e7651cb1ca203d10458247d0c7130a0166e0d1f0bf2157e8973523a3b8ab0779f02404e583d80d3b2dd190b58c37085ff79 SHA512 6bd8c2c7c15e4fa905036ed868cce3cacc6dd0e4ba6717024ab63f3c0b3c3d6c269626ed80211c9c668e33d63ac38acc5d16209afba817d829407f6d604f7b17
MISC metadata.xml 695 BLAKE2B 11487b964bde2ce1a39a8680bc3cc62045c4a7e2e17844de830d5f0e043660c431cd002a2a0fc19acb4c0262289ee280195475dd1f8b35f6a51ce0df369871f8 SHA512 fca83587d443373fc7219911900105676bdba5a7ced07ac00a9ab5cbe361d8ca1175b02b04fa53cdbde6f198a986b21f989baf32139cd76b7d1b2b78034d3142
diff --git a/sci-libs/scikit-image/scikit-image-0.22.0.ebuild b/sci-libs/scikit-image/scikit-image-0.22.0.ebuild
new file mode 100644
index 000000000000..cbf391a09c1a
--- /dev/null
+++ b/sci-libs/scikit-image/scikit-image-0.22.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=meson-python
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Image processing routines for SciPy"
+HOMEPAGE="
+ https://scikit-image.org/
+ https://github.com/scikit-image/scikit-image/
+ https://pypi.org/project/scikit-image/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/imageio-2.27[${PYTHON_USEDEP}]
+ >=dev-python/lazy_loader-0.3[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.8[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.0.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.8[sparse(+),${PYTHON_USEDEP}]
+ >=dev-python/tifffile-2022.8.12[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+DOCS=( CONTRIBUTORS.txt RELEASE.txt )
+
+distutils_enable_tests pytest
+# There is a programmable error in your configuration file:
+#distutils_enable_sphinx doc/source dev-python/numpydoc dev-python/myst-parser
+
+python_test() {
+ # This needs to be run in the install dir
+ cd "${WORKDIR}/${PN//-/_}-${PV}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/skimage" || die
+ distutils-r1_python_test
+}
+
+pkg_postinst() {
+ optfeature "FITS io capability" dev-python/astropy
+ optfeature "GTK" dev-python/pygtk
+ optfeature "Parallel computation" dev-python/dask
+ optfeature "io plugin providing most standard formats" dev-python/imread
+ optfeature "plotting" dev-python/matplotlib
+ optfeature "wavelet transformations" dev-python/pywavelets
+ optfeature "io plugin providing a wide variety of formats, including specialized formats using in medical imaging." dev-python/simpleitk
+}
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index f517b9e2ab1a..9dc21d588c90 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,3 +1,5 @@
DIST scikit-learn-1.1.2.gh.tar.gz 7104556 BLAKE2B e67e1deddf5a1134b57a146e8271a406cb257ffc92c9719e90f5b9d98e711b68bc67e3367660ecaad61aaec1794bb8999b4dd00b7d56e21eca8fcb2ee72cc9aa SHA512 58789c1e607d7de3339fa3b8928553ca96cef93e8da8fd13612aa78e5ebde8e6a55e3bf7845f9a45b78ed77da6a219d08d2c26318b602f937e0e3debd239293e
+DIST scikit-learn-1.3.2.gh.tar.gz 7650823 BLAKE2B 170699917f46d6d3f4b9ebc314bc1ec45687dad0a4aec5d2cee6e288b5dbe508bad6dd80406501f289a33593c6482067393e9dc28155f85a4872a34523bf4199 SHA512 a3799e9b39b755a50ba225f836904a378f7d83a08274c614d0485e4d4d4a7b0c7adba2dbb6612f2ccb4e5167f872214a2853eff69d767dc70f52369bda7a230b
EBUILD scikit-learn-1.1.2.ebuild 1629 BLAKE2B e1ee3c014014278883a44f947f01bbfaa79ff13ccdfdb846bf5de87db9ce4cf13642bcaaf131d0515a410a1cae930078557cb632e1aadd79bfce8c9e0e723dce SHA512 fa04eea3aef64d81a7bf9957aaffffb509eeb36efebbf1e7184ad91060e528710b1efce8d8b68b0f775786aab3353f95ba3e06f5825e87776ab8f75d3b03447e
+EBUILD scikit-learn-1.3.2.ebuild 1551 BLAKE2B 6ecce9433f6ec349665045d7e95993b67ec023e10753ecbc4965229dff96f76ea0a0e9327d5fcc40ce9f31923be90c6bb99f3b276a68f5a2e3412fb68c2f232a SHA512 a13767d4e714fdda6de61d459a3e8490d2f3508f60a736fe41dbe1c50362950cf64ecf05791b5258b8ed0b0f2e883b594d799a08acbb85beeb5eced5984067d5
MISC metadata.xml 614 BLAKE2B b5425c2d022592581647c9b97c0ab22bfc2afe347b2e5ea22f141245238f145322f39406c62318ba1e6af1462b2691267b39976bfde38faaf1d28b1d29c4e015 SHA512 74ac79123848bc385c29fcfdc4a1e780529dda685c1deb5eb722f5d4919ee6ac9d80798d52c4af0be0cc8dbbaea3784963dd97e2b7c1258cc2f5605b0bc8907a
diff --git a/sci-libs/scikit-learn/scikit-learn-1.3.2.ebuild b/sci-libs/scikit-learn/scikit-learn-1.3.2.ebuild
new file mode 100644
index 000000000000..4618b7e65231
--- /dev/null
+++ b/sci-libs/scikit-learn/scikit-learn-1.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Machine learning library for Python"
+HOMEPAGE="https://scikit-learn.org/stable/"
+SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+DEPEND="
+ virtual/blas:=
+ virtual/cblas:=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/joblib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.22.3[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/threadpoolctl-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+# For some reason this wants to use urllib to fetch things from the internet
+# distutils_enable_sphinx doc \
+# dev-python/matplotlib \
+# dev-python/memory-profiler \
+# dev-python/numpydoc \
+# dev-python/pandas \
+# dev-python/pillow \
+# dev-python/seaborn \
+# dev-python/sphinx-gallery \
+# dev-python/sphinx-prompt \
+# sci-libs/scikit-image
+
+python_test() {
+ # This needs to be run in the install dir
+ cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
+ distutils-r1_python_test
+}
+
+python_install_all() {
+ find "${S}" -name \*LICENSE.txt -delete || die
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}
diff --git a/sci-libs/scikit-optimize/Manifest b/sci-libs/scikit-optimize/Manifest
index 2c0a66e4db19..b8d2f5462f1d 100644
--- a/sci-libs/scikit-optimize/Manifest
+++ b/sci-libs/scikit-optimize/Manifest
@@ -1,3 +1,6 @@
+AUX scikit-optimize-0.9.0-numpy-1.24.patch 892 BLAKE2B c06e68b47aa051546ede619ef5cb910b15ae2eb4f8b3a79058759ad6d7b0f29fe357670e2b6ec46d519e5e5dd1dce934336eee2dceec11cde471ed99d569049b SHA512 0d8d037b8a27e44709b27780f49089c17273d43bb90b102e62427c8847e3cd2b0020379e072c525540a3316d6fa7af0e9566880cb9826531213dda96cdded972
+AUX scikit-optimize-0.9.0-scikit-learn-1.2.0.patch 5047 BLAKE2B eb393b5a3f82478da2d58997dc0a8521a8c3f37c3de05df76d583b9bb6f0d18a149f14b90cc885cacd458c0aeb7e8de55cd1accfe8f16f85491423005fbc8830 SHA512 b501680cf6722ec60fea590f9ea966767108411c22b0ded6f3eb15e5f29d95e57f1f8842e91815b08403fb1e27424cbb2bcfc343ff7e5641a075e1217d8fb19e
DIST scikit-optimize-0.9.0.tar.gz 275570 BLAKE2B ab481bf1cfc2b8c7cff213ae0ce2fa937de8f6269b491cf63ae115eea5c936c8a5c26b7fb339fa6cd2927c5105068635c008d6dc8b3f99b4b5d3abfed1a1c5a2 SHA512 a4c1bd589686dbbabcc5de38a4eb581c040cc2c3f83bc250ddcbe66314f03fc68b7b12d7679049da34c42445b446e1af3873f7ce90bec2a5361f0077ff3e9b74
+EBUILD scikit-optimize-0.9.0-r1.ebuild 1072 BLAKE2B 22c2666059968510416e9b3b8323829cddcc7107d94ba52e54ef5984b676f558067d103e75cc3741346c2f6e465700c061dd4eb8de0075b4f745166195a44323 SHA512 a5705395464c4c000ea9ef8a6fa917de831eb8d4339eabd7e7ef6073d737366c57e3c2a0db60051362107c3d5de89c3877aa5a36597d6a92c37d1dbf2bdc6beb
EBUILD scikit-optimize-0.9.0.ebuild 810 BLAKE2B 4547d60f4efbb1a35da5b878ee2de8ba956dbb84ddad8d23f8deb9c61b9b47221aa169b42b96d582c6aca9ffdb8027ea99d1631704cc90aa458a45e5e166b73d SHA512 8c31bc0322d7ba807a3cf09a59d33b877e043cbf8be6aa841165166a8729d25b68e507a8525b51e47c617a74316e79bb1213a7e80db96c7f160cd3dcd835ebcd
MISC metadata.xml 415 BLAKE2B 3bfa58da8f117a7b62399a17e5259dbfb0e74b9b9acd16e4515bcceaafc2928733f047f229c58bc437907cddf3b8a93c9576a9645e0c910129900072bed94aff SHA512 6343c76ca9a28f321c3fd8c94dfbb912f305ce43025ab6d666ed0aa5a496f08f258e1ab4e11c14844baa3c04c63a43c1d79bc8067a0d02a4eccf0e37c0c686f7
diff --git a/sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-numpy-1.24.patch b/sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-numpy-1.24.patch
new file mode 100644
index 000000000000..65fc26f3eed1
--- /dev/null
+++ b/sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-numpy-1.24.patch
@@ -0,0 +1,22 @@
+diff --git a/skopt/space/transformers.py b/skopt/space/transformers.py
+index 68892952..87cc3b68 100644
+--- a/skopt/space/transformers.py
++++ b/skopt/space/transformers.py
+@@ -259,7 +259,7 @@ def transform(self, X):
+ if (self.high - self.low) == 0.:
+ return X * 0.
+ if self.is_int:
+- return (np.round(X).astype(np.int) - self.low) /\
++ return (np.round(X).astype(np.int64) - self.low) /\
+ (self.high - self.low)
+ else:
+ return (X - self.low) / (self.high - self.low)
+@@ -272,7 +272,7 @@ def inverse_transform(self, X):
+ raise ValueError("All values should be greater than 0.0")
+ X_orig = X * (self.high - self.low) + self.low
+ if self.is_int:
+- return np.round(X_orig).astype(np.int)
++ return np.round(X_orig).astype(np.int64)
+ return X_orig
+
+
diff --git a/sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-scikit-learn-1.2.0.patch b/sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-scikit-learn-1.2.0.patch
new file mode 100644
index 000000000000..8cf8cff9479f
--- /dev/null
+++ b/sci-libs/scikit-optimize/files/scikit-optimize-0.9.0-scikit-learn-1.2.0.patch
@@ -0,0 +1,104 @@
+diff --git a/skopt/learning/forest.py b/skopt/learning/forest.py
+index 096770c1d..ebde568f5 100644
+--- a/skopt/learning/forest.py
++++ b/skopt/learning/forest.py
+@@ -27,7 +27,7 @@ def _return_std(X, trees, predictions, min_variance):
+ -------
+ std : array-like, shape=(n_samples,)
+ Standard deviation of `y` at `X`. If criterion
+- is set to "mse", then `std[i] ~= std(y | X[i])`.
++ is set to "squared_error", then `std[i] ~= std(y | X[i])`.
+
+ """
+ # This derives std(y | x) as described in 4.3.2 of arXiv:1211.0906
+@@ -61,9 +61,9 @@ class RandomForestRegressor(_sk_RandomForestRegressor):
+ n_estimators : integer, optional (default=10)
+ The number of trees in the forest.
+
+- criterion : string, optional (default="mse")
++ criterion : string, optional (default="squared_error")
+ The function to measure the quality of a split. Supported criteria
+- are "mse" for the mean squared error, which is equal to variance
++ are "squared_error" for the mean squared error, which is equal to variance
+ reduction as feature selection criterion, and "mae" for the mean
+ absolute error.
+
+@@ -194,7 +194,7 @@ class RandomForestRegressor(_sk_RandomForestRegressor):
+ .. [1] L. Breiman, "Random Forests", Machine Learning, 45(1), 5-32, 2001.
+
+ """
+- def __init__(self, n_estimators=10, criterion='mse', max_depth=None,
++ def __init__(self, n_estimators=10, criterion='squared_error', max_depth=None,
+ min_samples_split=2, min_samples_leaf=1,
+ min_weight_fraction_leaf=0.0, max_features='auto',
+ max_leaf_nodes=None, min_impurity_decrease=0.,
+@@ -228,20 +228,20 @@ def predict(self, X, return_std=False):
+ Returns
+ -------
+ predictions : array-like of shape = (n_samples,)
+- Predicted values for X. If criterion is set to "mse",
++ Predicted values for X. If criterion is set to "squared_error",
+ then `predictions[i] ~= mean(y | X[i])`.
+
+ std : array-like of shape=(n_samples,)
+ Standard deviation of `y` at `X`. If criterion
+- is set to "mse", then `std[i] ~= std(y | X[i])`.
++ is set to "squared_error", then `std[i] ~= std(y | X[i])`.
+
+ """
+ mean = super(RandomForestRegressor, self).predict(X)
+
+ if return_std:
+- if self.criterion != "mse":
++ if self.criterion != "squared_error":
+ raise ValueError(
+- "Expected impurity to be 'mse', got %s instead"
++ "Expected impurity to be 'squared_error', got %s instead"
+ % self.criterion)
+ std = _return_std(X, self.estimators_, mean, self.min_variance)
+ return mean, std
+@@ -257,9 +257,9 @@ class ExtraTreesRegressor(_sk_ExtraTreesRegressor):
+ n_estimators : integer, optional (default=10)
+ The number of trees in the forest.
+
+- criterion : string, optional (default="mse")
++ criterion : string, optional (default="squared_error")
+ The function to measure the quality of a split. Supported criteria
+- are "mse" for the mean squared error, which is equal to variance
++ are "squared_error" for the mean squared error, which is equal to variance
+ reduction as feature selection criterion, and "mae" for the mean
+ absolute error.
+
+@@ -390,7 +390,7 @@ class ExtraTreesRegressor(_sk_ExtraTreesRegressor):
+ .. [1] L. Breiman, "Random Forests", Machine Learning, 45(1), 5-32, 2001.
+
+ """
+- def __init__(self, n_estimators=10, criterion='mse', max_depth=None,
++ def __init__(self, n_estimators=10, criterion='squared_error', max_depth=None,
+ min_samples_split=2, min_samples_leaf=1,
+ min_weight_fraction_leaf=0.0, max_features='auto',
+ max_leaf_nodes=None, min_impurity_decrease=0.,
+@@ -425,19 +425,19 @@ def predict(self, X, return_std=False):
+ Returns
+ -------
+ predictions : array-like of shape=(n_samples,)
+- Predicted values for X. If criterion is set to "mse",
++ Predicted values for X. If criterion is set to "squared_error",
+ then `predictions[i] ~= mean(y | X[i])`.
+
+ std : array-like of shape=(n_samples,)
+ Standard deviation of `y` at `X`. If criterion
+- is set to "mse", then `std[i] ~= std(y | X[i])`.
++ is set to "squared_error", then `std[i] ~= std(y | X[i])`.
+ """
+ mean = super(ExtraTreesRegressor, self).predict(X)
+
+ if return_std:
+- if self.criterion != "mse":
++ if self.criterion != "squared_error":
+ raise ValueError(
+- "Expected impurity to be 'mse', got %s instead"
++ "Expected impurity to be 'squared_error', got %s instead"
+ % self.criterion)
+ std = _return_std(X, self.estimators_, mean, self.min_variance)
+ return mean, std
diff --git a/sci-libs/scikit-optimize/scikit-optimize-0.9.0-r1.ebuild b/sci-libs/scikit-optimize/scikit-optimize-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..694cd3ffafeb
--- /dev/null
+++ b/sci-libs/scikit-optimize/scikit-optimize-0.9.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sequential model-based optimization library"
+HOMEPAGE="https://scikit-optimize.github.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/joblib-0.11[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+ >=dev-python/scipy-0.19.1[${PYTHON_USEDEP}]
+ >=sci-libs/scikit-learn-0.20.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ # https://github.com/scikit-optimize/scikit-optimize/pull/1187
+ "${FILESDIR}/${P}-numpy-1.24.patch"
+ # https://github.com/scikit-optimize/scikit-optimize/pull/1184/files
+ "${FILESDIR}/${P}-scikit-learn-1.2.0.patch"
+)
+
+distutils_enable_tests pytest
+# No such file or directory: image/logo.png
+#distutils_enable_sphinx doc \
+# dev-python/numpydoc \
+# dev-python/sphinx-issues \
+# dev-python/sphinx-gallery