summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-06 12:28:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-06 12:28:43 +0100
commit8bf02d8edf7e8947a205e2dca77bee4c4e31739b (patch)
tree3711c04de0185e8d4835ac527c634e0d4893ad7e /sci-libs
parent5d93bae2c1576ab817f482024a6d47592829407b (diff)
gentoo auto-resync : 06:09:2024 - 12:28:42
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin42961 -> 42963 bytes
-rw-r--r--sci-libs/qd/Manifest2
-rw-r--r--sci-libs/qd/qd-2.3.24.ebuild40
3 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 4516478f3005..d26d0a007d61 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/qd/Manifest b/sci-libs/qd/Manifest
index e27de8539920..73b4c90ff7a8 100644
--- a/sci-libs/qd/Manifest
+++ b/sci-libs/qd/Manifest
@@ -1,3 +1,5 @@
DIST qd-2.3.23.tar.gz 781558 BLAKE2B bbda1ede1e93c100ca831b3eddc34ad6092007f9674c83803e5a5e140f80cc6b4b41fa71857beb9ef255d77265470537e43ef81886d6a013958a429b1c641c55 SHA512 ab311883db7708cee1c307eead5d02dac3b9809389b8d29e2fda5207decb752ca360a9aab234dd8a70228e0e004a6b6d6cdf92fd098536e96a2fa01c5b2ced2c
+DIST qd-2.3.24.tar.gz 812215 BLAKE2B f9520066d8004befc3c17dc9a79dc8f099e39c3eeb676c8909f2914fa2f7d8e4f52e7e906c928d6fecdf018cdf97ac465fa9aa3f9c57b02279d1cbb8b3952246 SHA512 7f233e9d0edcb442da160a49bc97df87acf258c3251828e2d473206022a36581295f38c685ac5f0c78b106605f12698f3d0cc0b4865be220a50b3536820ac1b7
EBUILD qd-2.3.23.ebuild 916 BLAKE2B c9220a83d46916dda3d308d480b84078f8af02515c13db7ba4303a999cb8b9aa5837ac3b19271942646a46397d600c674cdad17b729834669a056535771efe75 SHA512 8ee98f3f5bceac44362d9f148084585a1996bc019774fe2b7daad55e9ead316415652ee0ee1ff4fcfbe474f3a8b86336a9d686fdf8bc86d40824b2ddea422bc4
+EBUILD qd-2.3.24.ebuild 920 BLAKE2B 3cb78d7181b2eb2a6facb6c8d895726d216e50c18d269e0f89c7e432b85e935f1ec8d1f46d9b089c79dde6c88775905d4af289a329dd7cc0d1c31e4e9c13dcc3 SHA512 14b9964127ef897503bda6d10e193615d546f356cd9c50aa4c35ab7312914eddb39cf1000d660e632e77aa9c0d2046d3c857e586a0c3a40e46525baf4e7b4d7b
MISC metadata.xml 260 BLAKE2B 14d3d7872b9a3cb341301daf85c6b037c567163317516100d5af08e7ae02970252f210e90118d5df9e0cf6e0b3560add3a7894d379609b864e60dfdda3036423 SHA512 973385fccdcb0ccc36e00a09dc85204cf15081b8b61bc20e02d7d1311cb05af4927f01aac36ec93275158f5b990874ca03ab7d381cf6ee6f5e30bc4926d2f045
diff --git a/sci-libs/qd/qd-2.3.24.ebuild b/sci-libs/qd/qd-2.3.24.ebuild
new file mode 100644
index 000000000000..2dd5a5b3591a
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2
+
+DESCRIPTION="Quad-double and double-double float arithmetics"
+HOMEPAGE="https://www.davidhbailey.com/dhbsoftware/"
+SRC_URI="https://www.davidhbailey.com/dhbsoftware/${P}.tar.gz"
+LICENSE="LBNLBSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-ieee-add \
+ --disable-sloppy-mul \
+ --disable-sloppy-div \
+ --enable-inline \
+ $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma) \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+
+ dosym qd_real.h /usr/include/qd/qd.h
+ dosym dd_real.h /usr/include/qd/dd.h
+
+ if ! use doc; then
+ rm "${ED}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}