summaryrefslogtreecommitdiff
path: root/sci-libs/xkaapi/xkaapi-3.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/xkaapi/xkaapi-3.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/xkaapi/xkaapi-3.0.3.ebuild')
-rw-r--r--sci-libs/xkaapi/xkaapi-3.0.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/xkaapi/xkaapi-3.0.3.ebuild b/sci-libs/xkaapi/xkaapi-3.0.3.ebuild
new file mode 100644
index 000000000000..738863617afd
--- /dev/null
+++ b/sci-libs/xkaapi/xkaapi-3.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2
+
+UPSTREAM_NO=34360
+
+DESCRIPTION="Kernel for Adaptative, Asynchronous Parallel and Interactive programming"
+HOMEPAGE="http://kaapi.gforge.inria.fr"
+SRC_URI="https://gforge.inria.fr/frs/download.php/${UPSTREAM_NO}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx fortran openmp static-libs"
+
+RDEPEND="
+ sys-apps/hwloc
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's:-Werror::g' \
+ -i tests/testsuite* tests/*/*.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-mode=gentoo
+ --enable-api-quark
+ --with-ccache=no
+ $(use_enable fortran api-kaapif)
+ $(use_enable cxx api-kaapixx)
+ $(use_enable openmp libkomp)
+# $(use_with plasma "${EPREFIX}"/usr)
+ )
+ autotools-utils_src_configure
+}