summaryrefslogtreecommitdiff
path: root/sci-libs/vtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /sci-libs/vtk
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/Manifest1
-rw-r--r--sci-libs/vtk/vtk-8.1.0-r3.ebuild333
2 files changed, 334 insertions, 0 deletions
diff --git a/sci-libs/vtk/Manifest b/sci-libs/vtk/Manifest
index 90c09bb15e97..3177be830de3 100644
--- a/sci-libs/vtk/Manifest
+++ b/sci-libs/vtk/Manifest
@@ -24,5 +24,6 @@ EBUILD vtk-6.1.0-r4.ebuild 10480 BLAKE2B 72dc967f163fed46bcbe7dc0a2b4de89840c951
EBUILD vtk-7.1.0.ebuild 9296 BLAKE2B 0fd4cb6ff13fe68d9a39bd686a18477fc0f8daad711910135448aacc96e06820251921263dc9517f400454fbdbda26ad5dc9633e98557b2246fe6e8658495537 SHA512 622eabfbb2a4b2c80a6254b09779f05b9354082402f3fead1010767c660b86c0e94413026a27bd06ea8eb7a07bea14d747db3bec51d9b5bf6ccb669d660d937f
EBUILD vtk-8.1.0-r1.ebuild 9027 BLAKE2B 45d5ef5b8177e418424135b9ee70af8e4d681731584a595bb4108cdff1e8f3fe29f0293bd668fba67967dfcd4e9b7e26ae51e3dea92e72ed0bc7d4589c82597c SHA512 36a149ad672f38d48f767c4381bb04bc4054edd76776430d3157f034f4faf58ddaed43675c712e1d4787ae01f05ed8c2b64988dfb30392a43faeb6c37416d115
EBUILD vtk-8.1.0-r2.ebuild 9037 BLAKE2B 8f8f89c3d158b826591eb07fe0250c16d0ba9dca9ea11011254152ac37b15bb840a815eb1bcb7b8a7c92524eb12f44d56a5ca16d91ca47b0d2797fa6e43db214 SHA512 5e0285464d4a41370a9e6586f9fb57fa6a1bebc2785f996c9a48d4066022f05103a7f233570cb729a79052a6684c51e682229376afab359b2c56bdbe52ad0a33
+EBUILD vtk-8.1.0-r3.ebuild 9057 BLAKE2B e5329bd6ed31f37152614d1e4773ed62a0eb92e9bfdecd0695dc57ebbf5c6cce9d0e5ab27a793774acabe9a9b9c4170ec579ccdf75fcbdc02e6666eafee2b6b2 SHA512 db6b2eea35c79c1ece9a0ce00dd5e9863eb3b312fd90101da5b7d216dcff2a365445d4f91fccdf49f176dfc626652a05da396c270dd27251db74b1cf69f08238
EBUILD vtk-8.1.0.ebuild 9214 BLAKE2B 4705a1ba19eee614686234bb3297f70104fd1b050f51bfd3c16f2c01cc33f745d2fdcf70331dc060852923da8f319cbc554c9296e76d6a742215e3c31990b77d SHA512 34a8ab6760d0b3fbb25dbf9d2c4a9eb5507b7de777bcce509b8d80e92131290d31b747921a1cd0905001b4657c6eba68f6497b024f2ff70cecaa7bdacaccb11a
MISC metadata.xml 1120 BLAKE2B 17456da598e4b7dfddec75a323def586e3b099ddfaa2e5883410afdd9143d317a6db53ead747b097cf8631f738d6a0b38a1e27ea37b445ba667a403053223e02 SHA512 d0d9ccd1922afe496e24d38fee05793fdf3983f798bef817a00c77bb632f2cabe3d2be554d0e979c223fd4005f3186b9ef78d394050539bd21cba5c2b6e56143
diff --git a/sci-libs/vtk/vtk-8.1.0-r3.ebuild b/sci-libs/vtk/vtk-8.1.0-r3.ebuild
new file mode 100644
index 000000000000..bfe60457d8c5
--- /dev/null
+++ b/sci-libs/vtk/vtk-8.1.0-r3.ebuild
@@ -0,0 +1,333 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+WEBAPP_OPTIONAL=yes
+WEBAPP_MANUAL_SLOT=yes
+
+inherit flag-o-matic java-pkg-opt-2 python-single-r1 qmake-utils versionator toolchain-funcs cmake-utils virtualx webapp
+
+# Short package version
+SPV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="The Visualization Toolkit"
+HOMEPAGE="https://www.vtk.org/"
+SRC_URI="
+ https://www.vtk.org/files/release/${SPV}/VTK-${PV}.tar.gz
+ doc? ( https://www.vtk.org/files/release/${SPV}/vtkDocHtml-${PV}.tar.gz )
+ examples? (
+ https://www.vtk.org/files/release/${SPV}/VTKData-${PV}.tar.gz
+ https://www.vtk.org/files/release/${SPV}/VTKLargeData-${PV}.tar.gz
+ )"
+
+LICENSE="BSD LGPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="
+ all-modules aqua boost doc examples imaging ffmpeg gdal java json kaapi mpi
+ mysql odbc offscreen postgres python qt5 rendering tbb theora tk tcl
+ video_cards_nvidia views web R +X xdmf2"
+
+REQUIRED_USE="
+ all-modules? ( python xdmf2 boost )
+ java? ( qt5 )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tcl? ( rendering )
+ examples? ( python )
+ tk? ( tcl )
+ web? ( python )
+ ^^ ( X aqua offscreen )"
+
+RDEPEND="
+ app-arch/lz4
+ dev-libs/expat
+ dev-libs/jsoncpp:=
+ dev-libs/libxml2:2
+ >=media-libs/freetype-2.5.4
+ >=media-libs/libharu-2.3.0-r2
+ media-libs/libpng:0=
+ media-libs/libtheora
+ media-libs/mesa
+ media-libs/tiff:0
+ sci-libs/exodusii
+ sci-libs/hdf5:=
+ sci-libs/netcdf:0=
+ sci-libs/netcdf-cxx:3
+ sys-libs/zlib
+ virtual/jpeg:0
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ boost? ( dev-libs/boost:=[mpi?] )
+ examples? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ )
+ ffmpeg? ( virtual/ffmpeg )
+ gdal? ( sci-libs/gdal )
+ java? ( >=virtual/jdk-1.7:* )
+ kaapi? ( <sci-libs/xkaapi-3 )
+ mpi? (
+ virtual/mpi[cxx,romio]
+ python? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
+ )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ offscreen? ( media-libs/mesa[osmesa] )
+ postgres? ( dev-db/postgresql:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/sip[${PYTHON_USEDEP}]
+ )
+ qt5? (
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtx11extras:5
+ python? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
+ )
+ R? ( dev-lang/R )
+ tbb? ( dev-cpp/tbb )
+ tcl? ( dev-lang/tcl:0= )
+ tk? ( dev-lang/tk:0= )
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers[tools,static-libs] )
+ web? (
+ ${WEBAPP_DEPEND}
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/constantly[${PYTHON_USEDEP}]
+ dev-python/hyperlink[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/txaio[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ )
+ xdmf2? ( sci-libs/xdmf2 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}"/VTK-${PV}
+
+RESTRICT="test"
+
+pkg_setup() {
+ use java && java-pkg-opt-2_pkg_setup
+ use python && python-single-r1_pkg_setup
+ use web && webapp_pkg_setup
+}
+
+src_prepare() {
+ local x
+ # missing: VPIC freerange libproj4 mrmpi sqlite utf8 verdict xmdf2 xmdf3
+ for x in constantly expat freetype hdf5 hyperlink incremental jpeg jsoncpp libharu libxml2 lz4 netcdf oggtheora png tiff Twisted txaio zlib ZopeInterface; do
+ ebegin "Dropping bundled ${x}"
+ rm -r ThirdParty/${x}/vtk${x} || die
+ eend $?
+ done
+ rm -r \
+ ThirdParty/AutobahnPython/vtkAutobahn \
+ || die
+
+ if use doc; then
+ einfo "Removing .md5 files from documents."
+ rm -f "${WORKDIR}"/html/*.md5 || die "Failed to remove superfluous hashes"
+ sed -e "s|\${VTK_BINARY_DIR}/Utilities/Doxygen/doc|${WORKDIR}|" \
+ -i Utilities/Doxygen/CMakeLists.txt || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # general configuration
+ local mycmakeargs=(
+ -Wno-dev
+ -DVTK_DIR="${S}"
+ -DVTK_INSTALL_LIBRARY_DIR=$(get_libdir)
+ -DVTK_INSTALL_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DVTK_DATA_ROOT="${EPREFIX}/usr/share/${PN}/data"
+ -DVTK_CUSTOM_LIBRARY_SUFFIX=""
+ -DBUILD_SHARED_LIBS=ON
+ -DVTK_USE_SYSTEM_AUTOBAHN=ON
+ -DVTK_USE_SYSTEM_EXPAT=ON
+ -DVTK_USE_SYSTEM_FREETYPE=ON
+ -DVTK_USE_SYSTEM_FreeType=ON
+ # Use bundled gl2ps (bundled version is a patched version of 1.3.9. Post 1.3.9 versions should be compatible)
+ -DVTK_USE_SYSTEM_GL2PS=OFF
+ -DVTK_USE_SYSTEM_HDF5=ON
+ -DVTK_USE_SYSTEM_JPEG=ON
+ -DVTK_USE_SYSTEM_LIBPROJ4=OFF
+ -DVTK_USE_SYSTEM_LIBXML2=ON
+ -DVTK_USE_SYSTEM_LibXml2=ON
+ -DVTK_USE_SYSTEM_NETCDF=ON
+ -DVTK_USE_SYSTEM_OGGTHEORA=ON
+ -DVTK_USE_SYSTEM_PNG=ON
+ -DVTK_USE_SYSTEM_TIFF=ON
+ -DVTK_USE_SYSTEM_TWISTED=ON
+ -DVTK_USE_SYSTEM_XDMF2=OFF
+ -DVTK_USE_SYSTEM_XDMF3=OFF
+ -DVTK_USE_SYSTEM_ZLIB=ON
+ -DVTK_USE_SYSTEM_ZOPE=ON
+ -DVTK_USE_SYSTEM_LIBRARIES=ON
+ # Use bundled diy2 (no gentoo package / upstream does not provide a Finddiy2.cmake or diy2Config.cmake / diy2-config.cmake)
+ -DVTK_USE_SYSTEM_DIY2=OFF
+ -DVTK_USE_GL2PS=ON
+ -DVTK_USE_LARGE_DATA=ON
+ -DVTK_USE_PARALLEL=ON
+ -DVTK_EXTRA_COMPILER_WARNINGS=ON
+ -DVTK_Group_StandAlone=ON
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_VTK_BUILD_ALL_MODULES_FOR_TESTS=off
+ -DVTK_BUILD_ALL_MODULES=$(usex all-modules)
+ -DUSE_DOCUMENTATION_HTML_HELP=$(usex doc)
+ -DVTK_Group_Imaging=$(usex imaging)
+ -DVTK_Group_MPI=$(usex mpi)
+ -DVTK_Group_Rendering=$(usex rendering)
+ -DVTK_Group_Tk=$(usex tk)
+ -DVTK_Group_Views=$(usex views)
+ -DVTK_Group_Web=$(usex web)
+ -DVTK_WWW_DIR="${ED%/}/${MY_HTDOCSDIR}"
+ -DVTK_WRAP_JAVA=$(usex java)
+ -DVTK_WRAP_PYTHON=$(usex python)
+ -DVTK_WRAP_PYTHON_SIP=$(usex python)
+ -DVTK_WRAP_TCL=$(usex tcl)
+ -DVTK_USE_BOOST=$(usex boost)
+ -DUSE_VTK_USE_BOOST=$(usex boost)
+ -DModule_vtkInfovisBoost=$(usex boost)
+ -DModule_vtkInfovisBoostGraphAlgorithms=$(usex boost)
+ -DVTK_USE_ODBC=$(usex odbc)
+ -DModule_vtkIOODBC=$(usex odbc)
+ -DVTK_USE_OFFSCREEN=$(usex offscreen)
+ -DVTK_OPENGL_HAS_OSMESA=$(usex offscreen)
+ -DVTK_USE_OGGTHEORA_ENCODER=$(usex theora)
+ -DVTK_USE_NVCONTROL=$(usex video_cards_nvidia)
+ -DModule_vtkFiltersStatisticsGnuR=$(usex R)
+ -DVTK_USE_X=$(usex X)
+ # IO
+ -DVTK_USE_FFMPEG_ENCODER=$(usex ffmpeg)
+ -DModule_vtkIOGDAL=$(usex gdal)
+ -DModule_vtkIOGeoJSON=$(usex json)
+ -DModule_vtkIOXdmf2=$(usex xdmf2)
+ -DBUILD_TESTING=$(usex examples)
+ # Apple stuff, does it really work?
+ -DVTK_USE_COCOA=$(usex aqua)
+ )
+
+ if use java; then
+ local javacargs=$(java-pkg_javac-args)
+ mycmakeargs+=( -DJAVAC_OPTIONS=${javacargs// /;} )
+ fi
+
+ if use kaapi; then
+ mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="Kaapi" )
+ elif use tbb; then
+ mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="TBB" )
+ else
+ mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="Sequential" )
+ fi
+
+ if use python; then
+ mycmakeargs+=(
+ -DVTK_INSTALL_PYTHON_MODULE_DIR="$(python_get_sitedir)"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ -DSIP_PYQT_DIR="${EPREFIX}/usr/share/sip"
+ -DSIP_INCLUDE_DIR="$(python_get_includedir)"
+ -DVTK_PYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DVTK_PYTHON_LIBRARY="$(python_get_library_path)"
+ -DVTK_PYTHON_SETUP_ARGS:STRING="--prefix=${EPREFIX} --root=${D}"
+ -DVTK_USE_SYSTEM_SIX=ON
+ )
+ fi
+
+ if use qt5; then
+ mycmakeargs+=(
+ -DVTK_USE_QVTK=ON
+ -DVTK_USE_QVTK_OPENGL=ON
+ -DVTK_USE_QVTK_QTOPENGL=ON
+ -DQT_WRAP_CPP=ON
+ -DQT_WRAP_UI=ON
+ -DVTK_INSTALL_QT_DIR="$(qt5_get_libdir)/qt5/plugins/designer"
+ -DDESIRED_QT_VERSION=5
+ -DVTK_QT_VERSION=5
+ -DQT_MOC_EXECUTABLE="$(qt5_get_bindir)/moc"
+ -DQT_UIC_EXECUTABLE="$(qt5_get_bindir)/uic"
+ -DQT_INCLUDE_DIR="${EPREFIX}/usr/include/qt5"
+ -DQT_QMAKE_EXECUTABLE="$(qt5_get_bindir)/qmake"
+ -DVTK_Group_Qt:BOOL=ON
+ )
+ fi
+
+ if use R; then
+ mycmakeargs+=(
+ -DR_LIBRARY_BLAS=/usr/$(get_libdir)/R/lib/libR.so
+ -DR_LIBRARY_LAPACK=/usr/$(get_libdir)/R/lib/libR.so
+ )
+ fi
+
+ append-cppflags -D__STDC_CONSTANT_MACROS -D_UNICODE
+
+ use java && export JAVA_HOME="${EPREFIX}/etc/java-config-2/current-system-vm"
+
+ if use mpi; then
+ export CC=mpicc
+ export CXX=mpicxx
+ export FC=mpif90
+ export F90=mpif90
+ export F77=mpif77
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use web && webapp_src_preinst
+
+ cmake-utils_src_install
+
+ use java && java-pkg_regjar "${ED%/}"/usr/$(get_libdir)/${PN}.jar
+
+ # Stop web page images from being compressed
+ use doc && docompress -x /usr/share/doc/${PF}/doxygen
+
+ if use tcl; then
+ # install Tcl docs
+ docinto vtk_tcl
+ dodoc Wrapping/Tcl/README
+ docinto .
+ fi
+
+ # install examples
+ if use examples; then
+ einfo "Installing examples"
+ mv -v {E,e}xamples || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ # environment
+ cat >> "${T}"/40${PN} <<- EOF || die
+ VTK_DATA_ROOT=${EPREFIX}/usr/share/${PN}/data
+ VTK_DIR=${EPREFIX}/usr/$(get_libdir)/${PN}-${SPV}
+ VTKHOME=${EPREFIX}/usr
+ EOF
+ doenvd "${T}"/40${PN}
+
+ use web && webapp_src_install
+}
+
+# webapp.eclass exports these but we want it optional #534036
+pkg_postinst() {
+ use web && webapp_pkg_postinst
+}
+
+pkg_prerm() {
+ use web && webapp_pkg_prerm
+}