summaryrefslogtreecommitdiff
path: root/sci-libs/vtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /sci-libs/vtk
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/Manifest2
-rw-r--r--sci-libs/vtk/vtk-9.0.1.ebuild25
2 files changed, 24 insertions, 3 deletions
diff --git a/sci-libs/vtk/Manifest b/sci-libs/vtk/Manifest
index 61c5072a121d..cbb6f6edd974 100644
--- a/sci-libs/vtk/Manifest
+++ b/sci-libs/vtk/Manifest
@@ -17,5 +17,5 @@ DIST VTKLargeData-9.0.1.tar.gz 247522733 BLAKE2B a1d603f7560cf2cd7d1f355fd30fa5b
DIST vtkDocHtml-8.2.0.tar.gz 132516675 BLAKE2B 8651a3793f3326dee36c5ae8a280b00943067f973115697f34770eefd42b5534a7d7e439e7745b32c5fa83daf5a5292b854792d18951af236d0aa77c3aa2b564 SHA512 45e198bde82948d1d8e47a8bdb64a2792c2bfdfc0d939ffe40ded79092d7ac5f497008c00c805baa09d27eabb419cdf0787eee1caf2ac44c5e8759ecf709a317
DIST vtkDocHtml-9.0.1.tar.gz 138707547 BLAKE2B 1493d21a41b5f8fd43c3503cb4f98905c6d8d0c39e3245a97141bb1baa59ef0054b52595b48fe2b1c1579b02da0dd1f660e5ef7fefd3c7a9cfdbed42f923a234 SHA512 9997fb73ab46d28f107f5a7ef31a86f6948cd3ff88184fd4f1b0cc14dff1b8b6395e420ae2b2a42e772b90b84d8e077cc4543b8b8c9495481c3f8271949f11e4
EBUILD vtk-8.2.0-r4.ebuild 10333 BLAKE2B 834bac0a4f2a2ebb770a67b62dab0240c45588ddebf5939e4e0557441750c8a83cb76ecee02a3841673e2749ffd628ea8e611f9327c214c01a95eeb5dd23fd75 SHA512 26c1bf583d835717950cd0f5842eb358ed31728484c906b9122e5cb72b72f0255f73f6a52974d098eebe2af6af9a72aa4b369148cf47d1ca994ebd6dfcd3f68a
-EBUILD vtk-9.0.1.ebuild 13679 BLAKE2B 4b46f2a93590a6f7403e9ca4d491d632e2ca9bbc0ba0f45c5a4c541cb2bf351e69f9b498edfc46ecfd84e2c1eaef5673c035ee050b584844e3e665fbca2e031d SHA512 4515771d506b19696467eeb0146dffeacca46df9310ca3c1176c80f050dee05b189c109b12e508822478b820e1a247eb0ae16542ac23ed86d3330c6224875acb
+EBUILD vtk-9.0.1.ebuild 14476 BLAKE2B 2e67bbb40a0b63df76193c8d3883b35180e84c6a97b65ac551017a6e32340a67433d2f34db1f912996d5c6a138816d7efb5f3fe39e2c892c421c4395e650df0b SHA512 bfa4a2d152b81e52cf0bec0fb41b35985df7e8ff0a11385b3907bd93a8745a3e5726819f84edc5b63d0a30afdcd5d065dd70afed077de64234904602ed7bbd90
MISC metadata.xml 1404 BLAKE2B d55945785c3e374227585ec5adb6cf9ad652c111cf4de2572179ea7f88df21b281bd02f841f9acdea72e034e4504cfe204833c44a265690ef4966bcf574bc0d0 SHA512 1d15b7c59d735c84915288dec1166ab9e48cfbe42d050bb4cc74e6c878a54c1e31da0e7edca5ffcbcb7d50de77d849b3df6ff68e07495e1c549217f87b0708c1
diff --git a/sci-libs/vtk/vtk-9.0.1.ebuild b/sci-libs/vtk/vtk-9.0.1.ebuild
index 6e0717f814c3..a38e3f1c3270 100644
--- a/sci-libs/vtk/vtk-9.0.1.ebuild
+++ b/sci-libs/vtk/vtk-9.0.1.ebuild
@@ -41,7 +41,7 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="
all-modules? ( boost ffmpeg gdal imaging mysql odbc postgres qt5 rendering theora views )
- cuda? ( X )
+ cuda? ( X video_cards_nvidia )
java? ( rendering )
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( X rendering )
@@ -294,7 +294,28 @@ src_configure() {
fi
if use cuda; then
- mycmakeargs+=( -DVTKm_CUDA_Architecture="native" )
+ local cuda_arch=
+ case ${VTK_CUDA_ARCH:-native} in
+ # we ignore fermi arch, because current nvidia-cuda-toolkit-11*
+ # no longer supports it
+ kepler|maxwell|pascal|volta|turing|ampere|all)
+ cuda_arch=${VTK_CUDA_ARCH}
+ ;;
+ native)
+ ewarn "If auto detection fails for you, please try and export the"
+ ewarn "VTK_CUDA_ARCH environment variable to one of the common arch"
+ ewarn "names: kepler, maxwell, pascal, volta, turing, ampere or all."
+ cuda_arch=native
+ ;;
+ *)
+ eerror "Please properly set the VTK_CUDA_ARCH environment variable to"
+ eerror "one of: kepler, maxwell, pascal, volta, turing, ampere, all"
+ die "Invalid CUDA architecture given: '${VTK_CUDA_ARCH}'!"
+ ;;
+ esac
+ ewarn "Using CUDA architecture '${cuda_arch}'"
+
+ mycmakeargs+=( -DVTKm_CUDA_Architecture=${cuda_arch} )
fi
if use ffmpeg; then