summaryrefslogtreecommitdiff
path: root/sci-libs/votca-tools/votca-tools-2021.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /sci-libs/votca-tools/votca-tools-2021.2.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'sci-libs/votca-tools/votca-tools-2021.2.ebuild')
-rw-r--r--sci-libs/votca-tools/votca-tools-2021.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/votca-tools/votca-tools-2021.2.ebuild b/sci-libs/votca-tools/votca-tools-2021.2.ebuild
new file mode 100644
index 000000000000..184243331d2d
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-2021.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+ S="${WORKDIR}/${P#votca-}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="https://www.votca.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-cpp/eigen-3.3
+ dev-libs/boost:=
+ dev-libs/expat
+ sci-libs/fftw:3.0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+DOCS=( NOTICE README.rst CHANGELOG.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_RC_FILES=OFF
+ -DENABLE_TESTING=$(usex test)
+ -DCMAKE_DISABLE_FIND_PACKAGE_MKL=ON
+ )
+ cmake_src_configure
+}