summaryrefslogtreecommitdiff
path: root/sci-libs/tnt/tnt-3.0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/tnt/tnt-3.0.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/tnt/tnt-3.0.12.ebuild')
-rw-r--r--sci-libs/tnt/tnt-3.0.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/tnt/tnt-3.0.12.ebuild b/sci-libs/tnt/tnt-3.0.12.ebuild
new file mode 100644
index 000000000000..2a622ddfa0c2
--- /dev/null
+++ b/sci-libs/tnt/tnt-3.0.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit versionator
+
+MYP="${PN}_$(replace_all_version_separators '_')"
+
+DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
+HOMEPAGE="http://math.nist.gov/tnt/"
+SRC_URI="http://math.nist.gov/tnt/${MYP}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto /usr/include
+ doins *.h
+}