summaryrefslogtreecommitdiff
path: root/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild')
-rw-r--r--sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild b/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
new file mode 100644
index 000000000000..23422f9cc125
--- /dev/null
+++ b/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+CommitId=bb1473a4b38b18268e8693044afdb8635bc8351b
+
+DESCRIPTION="provides a tensor-aware channel"
+HOMEPAGE="https://github.com/pytorch/tensorpipe/"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT=test
+
+RDEPEND="
+ dev-libs/libuv
+"
+DEPEND="${RDEPEND}
+ dev-libs/libnop
+"
+BDEPEND=""
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )