summaryrefslogtreecommitdiff
path: root/sci-libs/tensorflow-estimator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /sci-libs/tensorflow-estimator
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'sci-libs/tensorflow-estimator')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index 0ace811524d4..48fc8141992a 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -5,4 +5,5 @@ DIST tensorflow-estimator-2.1.tar.gz 622792 BLAKE2B d1c8abb22d90c789ebfadaf78ca9
DIST tensorflow-estimator-2.2.0.tar.gz 627362 BLAKE2B 125792fc2167b8af837a99b08a9a26943bc5c1fda8ab3690b01c0d49a6dd39142ff4a063867dfe1bee3b99fb018981d0e4ee45d194caac2cd96a829ad22db0ad SHA512 aaf743835e2c606439fcccb56742997e930ba0e72c01d51633ce86824bbfaacd64607dc1fd7fb9604cc444feb65ebae60c2266be084e1b49ef2a1a9ca5a3d60d
EBUILD tensorflow-estimator-2.1.ebuild 1853 BLAKE2B 13a0aa24ad860e69af5c8e180d939bd074c909bfcef47d5e9d16074cf010927f51bb64e6a48a7db00a5a817db70f4aa7071a32e89439b6864cc406a3cc13c59e SHA512 295825f9278094596f880fe69898791b00b68f71b4e7b6fd2efdb7357d2090ace62eb0d45b7b649f222544c789d8375bba73776a5428b587ba01367024af6615
EBUILD tensorflow-estimator-2.2.0-r1.ebuild 1978 BLAKE2B 790ff6c1a2facc9e5b652b346a9ad24b445494f156a90465d3fa278e49376122da03f182fd4264f2e1f17488f326353e58810122996fbd33b4deabb7ed1986b1 SHA512 419fdbe02e00fdabe285f122be8ac574181366fc5f48fcf56616a37c69867cf6b530ea7dae8f5cfd8c6114a1ccb945699e4e4674ea7a14ad4d6bc14619c6693c
+EBUILD tensorflow-estimator-2.2.0-r2.ebuild 1978 BLAKE2B 31f981c1afd0f9d9392480840e7af5cf77d8723c13aab512316f3a5b5817b18f9cc58153c33fe66ac6845c155b8c9564116dcc42996c04fd43e0475e0f9c074f SHA512 6e115396a5257a4be94741c2eae714389a4b75359cd7168021901745fa854063374f2fc3f6a3d4f2d54cb1dd98437fd0d5a8b143fa01a3043035180da92f9afc
MISC metadata.xml 580 BLAKE2B fb81098968d0fdf34a3f28dabee76df16be5393cb9ea79ee4fa670af985ef3f70bb83f14be84a0cc0e564e6626007c2977851f8299460b483f88325be155f4cc SHA512 6aef6523502a3bcf0b2ca59cf7480b92032b53020cccfa715203e5a48c960ecc92c94fa75f98a234da2d51662d43e0c1a85a1537f3ab67287cdb8183476a0efa
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r2.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..6000b5742991
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+ https://github.com/bazelbuild/rules_cc/archive/0d5f3f2768c6ca2faca0079a997a97ce22997a0c.zip -> bazelbuild-rules_cc-0d5f3f2768c6ca2faca0079a997a97ce22997a0c.zip
+ https://github.com/bazelbuild/rules_cc/archive/8bd6cd75d03c01bb82561a96d9c1f9f7157b13d0.zip -> bazelbuild-rules_cc-8bd6cd75d03c01bb82561a96d9c1f9f7157b13d0.zip
+ https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+ ${bazel_external_uris}"
+
+RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-java/java-config"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+ python_copy_sources
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+
+ do_compile() {
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src-${EPYTHON/./_}"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+ }
+
+ python_foreach_impl run_in_build_dir do_compile
+}
+
+src_install() {
+ do_install() {
+ cd "${T}/src-${EPYTHON/./_}" || die
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl do_install
+
+ cd "${S}" || die
+ einstalldocs
+}