summaryrefslogtreecommitdiff
path: root/sci-libs/tensorflow-estimator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /sci-libs/tensorflow-estimator
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'sci-libs/tensorflow-estimator')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest2
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index 1ca67369b4f8..f23f90ab480f 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -1,4 +1,6 @@
AUX 0001-pip_package-modularize-build-script-to-allow-distros.patch 4250 BLAKE2B 79702d82e629e2159cbe33efe8dd91536d904536f4bbf3d4ad02186916a09786cde6ce29a63acaafe3169dbd7904448461f2b557f33218651351fd87d42ed613 SHA512 42bb57433f61b3a9b1a93c897202bacdf44a8277ea0e64257ac3b60c9b964a6441345c9b222fb26afb1d66a53323fe38c29811adfd6354032cb5d3f85dde0816
+DIST tensorflow-estimator-1.13.0.tar.gz 530871 BLAKE2B 4f208ed20e10fa68e06d21c9865cd07623e14362bdcff456bc9b412431c8f12f289c8a8f8ad89cb1f0ec98b1432844632d7e1097ea29d40bf6f67b90b4968f93 SHA512 e4be92b805776d2be5f391f737f1043b994f42721173c4d4a7dbf3fac9b00121cb072091a474bf71c7dcd952fc8b330cf9254c7a5ad9d096ba1cdc12ba12078b
DIST tensorflow-estimator-1.13.0_rc0.tar.gz 531012 BLAKE2B 1398fdec5b81a7bab7ccfb2d37b8094c4ef4b96562e2c6b8b4e565cad3c234245b5d8dfb30a79b73302fc0764b1d3503d4ee2d4363a9d2e635b36fb8e2b726b4 SHA512 c8ad78d0df294c7471f1577880905be08edcc038878e9d197b975f33f91192e9c413d13fa70e8fa1ff760ad6bf6141f199322bf2076568690e75fa38bd5a4cf4
+EBUILD tensorflow-estimator-1.13.0.ebuild 1333 BLAKE2B 0087323052bd5de42be018b255f21d50c499a18aba79a8540e6490cd1a9173be9a08b257cfd2da2b0378c274331b9a51f9048891688f0115a300a997279e1c55 SHA512 7c10982a4f1f1a7943c2497f3831f5825836a8589bc74c52665e0862d386a73e71039c474ee1f78f4505b9c5af4bd72ef34f73bc5b58c758f04beef19be691c8
EBUILD tensorflow-estimator-1.13.0_rc0.ebuild 1329 BLAKE2B ed4451574acbc5067715148a5a365017d3b4b42a99aece10be94d6b3d1683f3d0cc758ff6dc89c7c4b1d9ac1974969b9ab3f320d6434014f16ef1d405d137dc1 SHA512 5db769ca08138e3fe4a696708049b96eb442c2e2484b737f821eff5da89575d671a57c156fc583819f345d53e4a800503df3517355d76cd4440af2ac6410ae61
MISC metadata.xml 580 BLAKE2B fb81098968d0fdf34a3f28dabee76df16be5393cb9ea79ee4fa670af985ef3f70bb83f14be84a0cc0e564e6626007c2977851f8299460b483f88325be155f4cc SHA512 6aef6523502a3bcf0b2ca59cf7480b92032b53020cccfa715203e5a48c960ecc92c94fa75f98a234da2d51662d43e0c1a85a1537f3ab67287cdb8183476a0efa
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild
new file mode 100644
index 000000000000..a5aede9bca28
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Jason Zaman
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6,3_7} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-java/java-config"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/0001-pip_package-modularize-build-script-to-allow-distros.patch"
+)
+DOCS=( CONTRIBUTING.md README.md )
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+}
+
+src_install() {
+ do_install() {
+ cd "${T}/src" || die
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl do_install
+
+ cd "${S}" || die
+ einstalldocs
+}