summaryrefslogtreecommitdiff
path: root/sci-libs/sundials
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /sci-libs/sundials
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'sci-libs/sundials')
-rw-r--r--sci-libs/sundials/Manifest2
-rw-r--r--sci-libs/sundials/sundials-3.0.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/sci-libs/sundials/Manifest b/sci-libs/sundials/Manifest
index 4697948ec082..b7366dfa54e2 100644
--- a/sci-libs/sundials/Manifest
+++ b/sci-libs/sundials/Manifest
@@ -1,4 +1,6 @@
AUX sundials-2.7.0-underlinking-libdir.patch 19659 BLAKE2B 9dab5796e7f64528df06a435433719bbd34f6f9868ab6d88ec59e32777c4513c995bebe3f4e32b91cfb000328c6ae307a1c29cd34acd21cd9485668c3783b991 SHA512 95bc36d359b672b725391d75540304fac6b2610960f67a636cf5656e30904a2ed309a75175f4d20b9199d70d45fa817e53e86433ff18dfcf28ef76840b9d0dba
DIST sundials-2.7.0.tar.gz 12258093 BLAKE2B 331fcf255f2bb8bcc798818b05db114feda7aacb6585177a836f17a9b58477f504099b4a33c7d71cab6e70eeb6fe47a76d101c08aa6219ee6fbac630524d5928 SHA512 c86c167538065a4109b36ae7c8f60f3d92184133cfa661b5acfccee052c38f40be865412a1746bb57907b61602c212c0f15e1e30ef29e8a49db6d46a75a28e69
+DIST sundials-3.0.0.tar.gz 12996039 BLAKE2B 0557190f6f7550bd4d7d3df10f727c6f235ff4917f2cfd35ca77785037edc43236a82383664f6fe1579bb5b07a148875b82b22f5a9e4f5f2a0607838e8a3b286 SHA512 3c86c7f27e64c2e6732546b0b1e87ea092502e361cae09b3b7eb29795c978edf494e17be13b78541dc91cc0709d928006bd0fc62ea968f2b621efa51856cdd60
EBUILD sundials-2.7.0.ebuild 2063 BLAKE2B 1ca9f283e24c399dadadf6f00835a4e2d25da64b3d660fa2f69daa632b6873bacdd73c329451036379523c3f76a6272c25833db312390e488b5330c862dbd174 SHA512 cd92701c6c400fa5c75610c6d35117b182be293821ce7bd0d15fb8c4807ca5359bd5413e36c2cc12af85321a331a90a2d514b1d31409ed70d9203728b61a995f
+EBUILD sundials-3.0.0.ebuild 2251 BLAKE2B 0550d1728013a3ad574668c1902fe3b416f8ed1842057cf7ea44bafe599e1c056db45dcdde822edb71b6094135d4d7b168ae70f575bf0cb2c41efc09eb449197 SHA512 ad1382f72bd6893788dca8706d1316a23be35f62b33bf0492675d089b506a15191550081999810dfaeff90ecaa84f8d823bae55f2de94d8446a0a1ad1e1a5381
MISC metadata.xml 1063 BLAKE2B 9fcc89ceb3553bf23a0f1074eaca3a76707ddcd7cdbce253c6710e2db8422fff558a0e761fe93eb00bf385bd6f30fcb53decc5323c425c609f419be92855799a SHA512 d81c64ac7241460ebc7bcd61f1b398ef55a1e9b5a5a9bb0ede400bfe06889d2db781c43853bf33069510f2461140ab8b7a47a4553cdafca64c1ed7bd0f16d742
diff --git a/sci-libs/sundials/sundials-3.0.0.ebuild b/sci-libs/sundials/sundials-3.0.0.ebuild
new file mode 100644
index 000000000000..35e90af469e9
--- /dev/null
+++ b/sci-libs/sundials/sundials-3.0.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit cmake-utils toolchain-funcs fortran-2 versionator
+
+DESCRIPTION="Suite of nonlinear solvers"
+HOMEPAGE="http://computation.llnl.gov/projects/sundials"
+SRC_URI="http://computation.llnl.gov/projects/sundials/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(get_major_version)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx doc examples fortran hypre lapack mpi openmp sparse static-libs superlumt threads"
+REQUIRED_USE="hypre? ( mpi )"
+
+RDEPEND="
+ lapack? ( virtual/lapack )
+ mpi? ( virtual/mpi sci-libs/hypre:= )
+ sparse? ( sci-libs/klu:= )
+ superlumt? ( sci-libs/superlu_mt:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( )
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS="$(usex static-libs)"
+ -DCXX_ENABLE="$(usex cxx)"
+ -DFCMIX_ENABLE="$(usex fortran)"
+ -DF90_ENABLE="$(usex fortran)"
+ -DHYPRE_ENABLE="$(usex hypre)"
+ -DHYPRE_INCLUDE_DIR="${EPREFIX}/usr/include/hypre"
+ -DHYPRE_LIBRARY="HYPRE"
+ -DKLU_ENABLE="$(usex sparse)"
+ -DKLU_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libklu.so"
+ -DLAPACK_ENABLE="$(usex lapack)"
+ -DMPI_ENABLE="$(usex mpi)"
+ -DOPENMP_ENABLE="$(usex openmp)"
+ -DPTHREAD_ENABLE="$(usex threads)"
+ -DSUPERLUMT_ENABLE="$(usex superlumt)"
+ -DSUPERLUMT_INCLUDE_DIR="${EPREFIX}/usr/include/superlu_mt"
+ -DSUPERLUMT_LIBRARY="superlu_mt"
+ -DEXAMPLES_ENABLE="$(usex examples)"
+ -DEXAMPLES_INSTALL=ON
+ -DEXAMPLES_INSTALL_PATH="/usr/share/doc/${PF}/examples"
+ -DUSE_GENERIC_MATH=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc doc/*/*.pdf
+ cd src
+ for r in */README; do
+ newdoc ${r} README-${r%/*}
+ done
+
+ # Use a sledgehammer, patching the buildsystem is too annoyoing (the
+ # CMake build systems consists of 2000 "lib" DESTINATIONS...)
+ if [[ lib != $(get_libdir) ]]; then
+ mv "${ED%/}"/usr/lib "${ED%/}"/usr/$(get_libdir) || die
+ fi
+}