summaryrefslogtreecommitdiff
path: root/sci-libs/sundials/sundials-5.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-libs/sundials/sundials-5.2.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-libs/sundials/sundials-5.2.0.ebuild')
-rw-r--r--sci-libs/sundials/sundials-5.2.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-libs/sundials/sundials-5.2.0.ebuild b/sci-libs/sundials/sundials-5.2.0.ebuild
index aa14eeb5320d..3d60a524cc2c 100644
--- a/sci-libs/sundials/sundials-5.2.0.ebuild
+++ b/sci-libs/sundials/sundials-5.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ FORTRAN_NEEDED=fortran
FORTRAN_STANDARD="77 90"
# if FFLAGS and FCFLAGS are set then should be equal
-inherit cmake fortran-2 toolchain-funcs
+inherit cmake fortran-2 toolchain-funcs flag-o-matic
DESCRIPTION="Suite of nonlinear solvers"
HOMEPAGE="https://computation.llnl.gov/projects/sundials"
@@ -38,6 +38,13 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # bug #707240
+ append-cflags -fcommon
+
+ cmake_src_prepare
+}
+
src_configure() {
mycmakeargs+=(
-DBUILD_SHARED_LIBS=ON