summaryrefslogtreecommitdiff
path: root/sci-libs/stellarsolver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-libs/stellarsolver
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-libs/stellarsolver')
-rw-r--r--sci-libs/stellarsolver/Manifest3
-rw-r--r--sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch88
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.2.ebuild30
3 files changed, 121 insertions, 0 deletions
diff --git a/sci-libs/stellarsolver/Manifest b/sci-libs/stellarsolver/Manifest
index a5303081c5e3..427333217ed6 100644
--- a/sci-libs/stellarsolver/Manifest
+++ b/sci-libs/stellarsolver/Manifest
@@ -1,3 +1,6 @@
+AUX stellarsolver-2.2-fix-implicit-vasprintf-decl.patch 3269 BLAKE2B b20b91d09de085aa6473b9bce472054fc4aba1516d782694e4351beda79b763347ec8012312b1384fbf1894747071dc20b4a25ca7bb2894382281fba528bc30e SHA512 026fc39584b73d2b90a26a1ad9028f94a6e63095f793da8f3fd185d48a7d055369d8e257f4032271d9a4729a499ccb051c8df1e2c559ff77f21f2ec1767518de
DIST stellarsolver-1.9.tar.gz 9117560 BLAKE2B dd458399bd53a6e9de50293ebe15538275fb494d8ef63699eb1234aaee5234fdbb81fe23a28cc1d264490ea8849569293342125461d9e638111c9acb9756fbdf SHA512 a618e551ec28bd8439a495ca6f2a69b857852f0129c8e7d692315bd124b7c7a5130763775264b3f6a7394b3d0480d4f95c1605fb02e311ab6c38b4c60bc6b9e3
+DIST stellarsolver-2.2.tar.gz 10971732 BLAKE2B 019b822d9a84401dfe2d01053da14c3f0eafb8a8b67e60c4f664ad64c0ffefe72f9dc086edef6dac5950f7fd99e655a641ecf781609b8b54e50cf3c0f8a516b5 SHA512 0b200437130ea8131ade9219e1055ea4265925168cbfb5a7bdcf3836e267a1b670df43f20d4657ef64dea2c1ef2314cfc0bcb8503eb4ead3f0cc3fae3267f7bc
EBUILD stellarsolver-1.9.ebuild 604 BLAKE2B c0fbc8549a28b289eba9965f3c968c0517861d2f4868342112cf7168eb1a971da50d060f54e5e64323eae041e71ba63b49e0e709ae305d13710c07d08390fa80 SHA512 53064dad8130d864372c5c73fc5c9995090313c3e9b08ba3cd87c4efd4c0539fc06c24ba54b1d1c5a593e5dd9a2c75297d30f9f8242075538d519371ea24a37c
+EBUILD stellarsolver-2.2.ebuild 728 BLAKE2B 104b43d93096e224b4ffd9985f3ca512fbbb78ae4f95b16ddda1bd4710280eab7cf04f38f9c1feaf9e32563b79476d8ac3785bad07121a0e82d0f9c92bef2b80 SHA512 201fe7ede6524be9f8860bae7c06753665a113a69d6e6834031911315aeae7ec2a2e6eb7fdce71069ec1adca1d2c8048765c6908f82444f705296a4e722e2bd3
MISC metadata.xml 464 BLAKE2B 4d73483b37f92bd6a6a112d27c17ce7c8c0165cb3400f10c3a5ed5a65bcaa6e2e0d892d305834fc813655258173552cdef75431d9798491d0b124de1dbb6f035 SHA512 3cc978f381b4435b05712e69733336ec7e89963d4b236059c21b4bf7f08b899e617243ef5df0e27c2ef21e59197b97fcf414c1964b86b215d0c355c4f88cac77
diff --git a/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch b/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch
new file mode 100644
index 000000000000..b2625fe4429e
--- /dev/null
+++ b/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch
@@ -0,0 +1,88 @@
+From acb58bd78388adec25eb6e09ce6434546de008b8 Mon Sep 17 00:00:00 2001
+From: Robert Lancaster <rlancaste@gmail.com>
+Date: Wed, 16 Mar 2022 18:15:21 -0400
+Subject: [PATCH] Trying to eliminate vasprintf implicit declaration warning on
+ Linux
+
+---
+ stellarsolver/astrometry/util/bl.c | 4 +++-
+ stellarsolver/astrometry/util/errors.c | 4 +++-
+ stellarsolver/astrometry/util/fitsioutils.c | 3 +++
+ stellarsolver/astrometry/util/ioutils.c | 4 +++-
+ stellarsolver/astrometry/util/log.c | 4 +++-
+ 5 files changed, 15 insertions(+), 4 deletions(-)
+
+diff --git a/stellarsolver/astrometry/util/bl.c b/stellarsolver/astrometry/util/bl.c
+index 1a0fee9..e84d74a 100644
+--- a/stellarsolver/astrometry/util/bl.c
++++ b/stellarsolver/astrometry/util/bl.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+diff --git a/stellarsolver/astrometry/util/errors.c b/stellarsolver/astrometry/util/errors.c
+index 94f5f9c..b7c4e9f 100644
+--- a/stellarsolver/astrometry/util/errors.c
++++ b/stellarsolver/astrometry/util/errors.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
+diff --git a/stellarsolver/astrometry/util/fitsioutils.c b/stellarsolver/astrometry/util/fitsioutils.c
+index 7451c36..f2b20bc 100644
+--- a/stellarsolver/astrometry/util/fitsioutils.c
++++ b/stellarsolver/astrometry/util/fitsioutils.c
+@@ -2,6 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdint.h>
+diff --git a/stellarsolver/astrometry/util/ioutils.c b/stellarsolver/astrometry/util/ioutils.c
+index ee17011..c490fb8 100644
+--- a/stellarsolver/astrometry/util/ioutils.c
++++ b/stellarsolver/astrometry/util/ioutils.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
+diff --git a/stellarsolver/astrometry/util/log.c b/stellarsolver/astrometry/util/log.c
+index 256d5a1..1a2b8db 100644
+--- a/stellarsolver/astrometry/util/log.c
++++ b/stellarsolver/astrometry/util/log.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
diff --git a/sci-libs/stellarsolver/stellarsolver-2.2.ebuild b/sci-libs/stellarsolver/stellarsolver-2.2.ebuild
new file mode 100644
index 000000000000..3fd2a5f94878
--- /dev/null
+++ b/sci-libs/stellarsolver/stellarsolver-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Cross-platform Sextractor and Astrometry.net-Based internal astrometric solver"
+HOMEPAGE="https://github.com/rlancaste/stellarsolver"
+SRC_URI="https://github.com/rlancaste/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ sci-libs/cfitsio:=
+ sci-libs/gsl:=
+ sci-astronomy/wcslib:=
+"
+DEPEND="${RDEPEND}"
+
+# https://github.com/rlancaste/stellarsolver/issues/108
+PATCHES=( "${FILESDIR}/${P}-fix-implicit-vasprintf-decl.patch" )