summaryrefslogtreecommitdiff
path: root/sci-libs/spqr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
commit345c02ca33341652116ddec6705530223af2de85 (patch)
treebcb9923530ba0703557f280b0a2bd1343bae857c /sci-libs/spqr
parentf300354de9fe5d997850456a9e1f400193e6544f (diff)
gentoo auto-resync : 27:08:2024 - 12:00:02
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/Manifest3
-rw-r--r--sci-libs/spqr/spqr-2.0.9-r3.ebuild9
-rw-r--r--sci-libs/spqr/spqr-2.0.9-r4.ebuild47
3 files changed, 57 insertions, 2 deletions
diff --git a/sci-libs/spqr/Manifest b/sci-libs/spqr/Manifest
index d264b9a707ab..10faa8e5886a 100644
--- a/sci-libs/spqr/Manifest
+++ b/sci-libs/spqr/Manifest
@@ -1,5 +1,6 @@
DIST SuiteSparse-7.0.0.gh.tar.gz 64884962 BLAKE2B 06c6cf54ffae188f5179e0cd45523700448d8999b44d6b1aeb3dfb99ccf34a570f6aff600988a144c68a4a2d8f41e32f7145e09349aed3bd889501ea031c8340 SHA512 50b1cd7bab6e4c063984162ed803fd13b69df7f67efe8ce7af15eace6b0ccd1669b6e57daa59511fd9531a847433cda49c1f52bfff234031af0d79e7fbd6423e
DIST spqr-2.0.9.tar.bz2 2161068 BLAKE2B a662983d2543a65ce36a367749db5585308acb56b016f69a35c46a84e9c12a678f57a3cfd459cc2e887fff2819b00f99981efaadb73831f1b4c54cbef5e1c367 SHA512 54b203e0d68b266473b8a2b7b3b3a55476df54a3ebd5748b70faa7bad1d0a5a7387197f0674ba5f9a5d45887daa736117f8d6ffbbc2eb02482b3374a3babf721
-EBUILD spqr-2.0.9-r3.ebuild 1114 BLAKE2B babdca5f656859ecd31db115926d7cca559d14694fc18cb4e6a29f2946ef28872b522452f971d433576ca0791791413840ca4488e49dc0f2d696edccae122d8f SHA512 5d5e22824f64627f4467e31232383879f369fb7fc6aa4234dacf9714da22db63e232c6d1cc57860b0a7f8ed90ac18f56e74af7ee457b820f513bee0469006067
+EBUILD spqr-2.0.9-r3.ebuild 1172 BLAKE2B 71f308f5398a3898b08dc0440c753c2ba146b65743ffc8d0339c8d49ebd00681f59372702e745ff4ea791914fda12d7fc60afbde905be90fa52f84f0e72a14e1 SHA512 8eee397172d1ad7ee8068d520dba6fbbc7e8c8818e66c48eaf3a852110ef56f701b64a99866d6b3e534760d7328d70cc9963501424e99431b774368c08e9214d
+EBUILD spqr-2.0.9-r4.ebuild 1155 BLAKE2B e043385ede90f19e4e239105dd9bf5461059ac9d01ae8285eb2b7d765d8f45e85743a989e101e855b5a774c53b4efc770e2ac9d530dddb6b13610bbffb4f1f9c SHA512 fafcdb5fb360a23d609f476740f0306279f9c8db88f913d3f52e84fb7c4979cad2d265d26b20089e48ec8a2fb824c7766a4685ca4cf5263eeeca1fef9a463208
EBUILD spqr-3.0.3.ebuild 5123 BLAKE2B 1fbc782524b85b8432b621935e5f9a1ff4fd79fdf020804a358bdcb36a3a7609884244f8d1c86988cddf3b026c481602386ebc80282c674f4723cd070fce28ad SHA512 f8d1cfb5e56cdd0f7fead65b967f8585097f926261972b742b379327131910ead7cf5e6faf498a8c5f2dd7e5c5760ba668fcacb409f62a4a8b867212537c3998
MISC metadata.xml 946 BLAKE2B d4051a416ebcfe046be31a02b3fca1d9b2e694d19b9f5c978ed927ce4dd4475f30025f011de24e93f1dedd5fcf3a779702d8467bdcc6a10324dc4ff9262eda97 SHA512 bb5d99a561952a29d16710c6730312f32a7d8ca8eb57a8a2479ee32a5612414e9ff00c0427c5a2962b7b3cf4b9a8b57caaace65e34f20b9fcc87714b493db157
diff --git a/sci-libs/spqr/spqr-2.0.9-r3.ebuild b/sci-libs/spqr/spqr-2.0.9-r3.ebuild
index b63bdbe966ea..a7499f3bf790 100644
--- a/sci-libs/spqr/spqr-2.0.9-r3.ebuild
+++ b/sci-libs/spqr/spqr-2.0.9-r3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
@@ -25,6 +27,11 @@ DEPEND="
tbb? ( <dev-cpp/tbb-2021:= )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf \
--disable-static \
diff --git a/sci-libs/spqr/spqr-2.0.9-r4.ebuild b/sci-libs/spqr/spqr-2.0.9-r4.ebuild
new file mode 100644
index 000000000000..92082b0cee2e
--- /dev/null
+++ b/sci-libs/spqr/spqr-2.0.9-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc partition tbb"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+# We require the cholmod supernodal module that is enabled with
+# USE=lapack, and cholmod has to have partition support if spqr is going
+# to have it (the ./configure script for spqr checks this). Note that
+# spqr links to metis directly, too.
+DEPEND="
+ virtual/lapack
+ =sci-libs/cholmod-3*[lapack,partition?]
+ partition? ( >=sci-libs/metis-5.1.0 )
+ tbb? ( <dev-cpp/tbb-2021:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_with doc) \
+ $(use_with partition) \
+ $(use_with tbb)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}