summaryrefslogtreecommitdiff
path: root/sci-libs/spqr/spqr-1.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/spqr/spqr-1.2.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/spqr/spqr-1.2.3-r1.ebuild')
-rw-r--r--sci-libs/spqr/spqr-1.2.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/spqr/spqr-1.2.3-r1.ebuild b/sci-libs/spqr/spqr-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..9f722944c3d0
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.2.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+MY_PN=SPQR
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc metis static-libs tbb"
+RDEPEND="sci-libs/cholmod[supernodal(+)]
+ tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-1.7.0-r1[metis] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README.txt Doc/ChangeLog )
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
+S="${WORKDIR}/${MY_PN}"
+
+src_configure() {
+ myeconfargs+=(
+ $(use_with metis)
+ $(use_with tbb)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && doins Doc/*.pdf
+}