summaryrefslogtreecommitdiff
path: root/sci-libs/scikits_learn/scikits_learn-0.19.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-libs/scikits_learn/scikits_learn-0.19.0-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-libs/scikits_learn/scikits_learn-0.19.0-r1.ebuild')
-rw-r--r--sci-libs/scikits_learn/scikits_learn-0.19.0-r1.ebuild107
1 files changed, 0 insertions, 107 deletions
diff --git a/sci-libs/scikits_learn/scikits_learn-0.19.0-r1.ebuild b/sci-libs/scikits_learn/scikits_learn-0.19.0-r1.ebuild
deleted file mode 100644
index 87abf6b9c1e3..000000000000
--- a/sci-libs/scikits_learn/scikits_learn-0.19.0-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 flag-o-matic
-
-MYPN="${PN/scikits_/scikit-}"
-MYP="${MYPN}-${PV}"
-
-DESCRIPTION="Python modules for machine learning and data mining"
-HOMEPAGE="https://scikit-learn.org"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-# tried to unbundle virtual/python-funcsigs, funcsigs, odict
-# but it is a large mess to maintain
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- sci-libs/scikits[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- virtual/blas:=
- virtual/cblas:=
-"
-
-DEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- virtual/blas:=
- virtual/cblas:=
-"
-
-S="${WORKDIR}/${MYP}"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.18.1-system-cblas.patch )
-
-python_prepare_all() {
- # bug #397605
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
-
- # scikits-learn now uses the horrible numpy.distutils automagic
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
-
- # remove bundled cblas
- rm -r sklearn/src || die
-
- # commented out, since it is a mess to maintain
- # use system joblib
- #rm -r sklearn/externals/joblib || die
- #sed -i -e '/joblib/d' sklearn/externals/setup.py || die
- #for f in sklearn/{*/,}*.py; do
- # sed -r -e '/^from/s/(sklearn|\.|)\.externals\.joblib/joblib/' \
- # -e 's/from (sklearn|\.|)\.externals import/import/' -i $f || die
- #done
-
- # use system funcsigs and odict
- #rm sklearn/externals/funcsigs.py || die
- #rm sklearn/externals/odict.py || die
- #for f in sklearn/{utils/fixes.py,gaussian_process/{tests/test_,}kernels.py}; do
- # sed -r -e 's/from (sklearn|\.|)\.externals\.funcsigs/from funcsigs/' -i $f || die
- #done
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- # doc builds and runs tests
- use doc && return
- distutils_install_for_testing ${SCIPY_FCONFIG}
- esetup.py install \
- --root="${T}/test-${EPYTHON}" \
- --no-compile ${SCIPY_FCONFIG}
- pushd "${T}/test-${EPYTHON}/$(python_get_sitedir)" || die > /dev/null
- JOBLIB_MULTIPROCESSING=2 SKLEARN_SKIP_NETWORK_TESTS=1 nosetests -v sklearn --exe || die
- popd > /dev/null
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
-}