summaryrefslogtreecommitdiff
path: root/sci-libs/scikits_learn/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-libs/scikits_learn/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-libs/scikits_learn/files')
-rw-r--r--sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch28
-rw-r--r--sci-libs/scikits_learn/files/scikits_learn-0.17.1-system-cblas.patch30
-rw-r--r--sci-libs/scikits_learn/files/scikits_learn-0.20.2-fix-cdfast.patch42
3 files changed, 42 insertions, 58 deletions
diff --git a/sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch b/sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch
deleted file mode 100644
index 96c6cc2dbde5..000000000000
--- a/sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- sklearn/setup.py.orig 2013-08-08 13:54:08.310879167 -0700
-+++ sklearn/setup.py 2013-08-08 13:52:59.808456423 -0700
-@@ -68,14 +68,6 @@
- libraries=libraries,
- )
-
-- # some libs needs cblas, fortran-compiled BLAS will not be sufficient
-- blas_info = get_info('blas_opt', 0)
-- if (not blas_info) or (
-- ('NO_ATLAS_INFO', 1) in blas_info.get('define_macros', [])):
-- config.add_library('cblas',
-- sources=[join('src', 'cblas', '*.c')])
-- warnings.warn(BlasNotFoundError.__doc__)
--
- # the following packages depend on cblas, so they have to be build
- # after the above.
- config.add_subpackage('linear_model')
---- sklearn/_build_utils.py.orig 2013-08-08 14:01:35.994589269 -0700
-+++ sklearn/_build_utils.py 2013-08-08 12:19:41.875967870 -0700
-@@ -23,7 +23,7 @@
- return False
-
- blas_info = get_info('blas_opt', 0)
-- if (not blas_info) or atlas_not_found(blas_info):
-+ if (not blas_info):
- cblas_libs = ['cblas']
- blas_info.pop('libraries', None)
- else:
diff --git a/sci-libs/scikits_learn/files/scikits_learn-0.17.1-system-cblas.patch b/sci-libs/scikits_learn/files/scikits_learn-0.17.1-system-cblas.patch
deleted file mode 100644
index 42657a7adacc..000000000000
--- a/sci-libs/scikits_learn/files/scikits_learn-0.17.1-system-cblas.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Nur scikit-learn-0.17.1.orig/sklearn/_build_utils.py scikit-learn-0.17.1/sklearn/_build_utils.py
---- scikit-learn-0.17.1.orig/sklearn/_build_utils.py 2016-03-09 00:27:54.756813784 +0000
-+++ scikit-learn-0.17.1/sklearn/_build_utils.py 2016-03-09 00:30:09.605118512 +0000
-@@ -23,7 +23,7 @@
- return False
-
- blas_info = get_info('blas_opt', 0)
-- if (not blas_info) or atlas_not_found(blas_info):
-+ if (not blas_info):
- cblas_libs = ['cblas']
- blas_info.pop('libraries', None)
- else:
-diff -Nur scikit-learn-0.17.1.orig/sklearn/setup.py scikit-learn-0.17.1/sklearn/setup.py
---- scikit-learn-0.17.1.orig/sklearn/setup.py 2016-03-09 00:27:54.806813156 +0000
-+++ scikit-learn-0.17.1/sklearn/setup.py 2016-03-09 00:29:28.215638848 +0000
-@@ -58,14 +58,6 @@
- libraries=libraries,
- )
-
-- # some libs needs cblas, fortran-compiled BLAS will not be sufficient
-- blas_info = get_info('blas_opt', 0)
-- if (not blas_info) or (
-- ('NO_ATLAS_INFO', 1) in blas_info.get('define_macros', [])):
-- config.add_library('cblas',
-- sources=[join('src', 'cblas', '*.c')])
-- warnings.warn(BlasNotFoundError.__doc__)
--
- # the following packages depend on cblas, so they have to be build
- # after the above.
- config.add_subpackage('linear_model')
diff --git a/sci-libs/scikits_learn/files/scikits_learn-0.20.2-fix-cdfast.patch b/sci-libs/scikits_learn/files/scikits_learn-0.20.2-fix-cdfast.patch
new file mode 100644
index 000000000000..1d1de4a3e0e5
--- /dev/null
+++ b/sci-libs/scikits_learn/files/scikits_learn-0.20.2-fix-cdfast.patch
@@ -0,0 +1,42 @@
+--- scikit-learn-0.20.3.orig/sklearn/linear_model/cd_fast.c 2019-08-09 03:05:05.351926119 +0500
++++ scikit-learn-0.20.3/sklearn/linear_model/cd_fast.c 2019-08-09 03:05:35.022926006 +0500
+@@ -4889,7 +4889,7 @@
+
+ static PyObject *__pyx_pf_7sklearn_12linear_model_7cd_fast_8enet_coordinate_descent(CYTHON_UNUSED PyObject *__pyx_self, __Pyx_memviewslice __pyx_v_w, float __pyx_v_alpha, float __pyx_v_beta, __Pyx_memviewslice __pyx_v_X, __Pyx_memviewslice __pyx_v_y, int __pyx_v_max_iter, float __pyx_v_tol, PyObject *__pyx_v_rng, int __pyx_v_random, int __pyx_v_positive) {
+ PyObject *__pyx_v_dtype = NULL;
+- void (*__pyx_v_gemv)(enum CBLAS_ORDER, enum CBLAS_TRANSPOSE, int, int, float, float *, int, float *, int, float, float *, int);
++ void (*__pyx_v_gemv)(CBLAS_ORDER, CBLAS_TRANSPOSE, int, int, float, float *, int, float *, int, float, float *, int);
+ float (*__pyx_v_dot)(int, float *, int, float *, int);
+ void (*__pyx_v_axpy)(int, float, float *, int, float *, int);
+ float (*__pyx_v_asum)(int, float *, int);
+@@ -6279,7 +6279,7 @@
+
+ static PyObject *__pyx_pf_7sklearn_12linear_model_7cd_fast_10enet_coordinate_descent(CYTHON_UNUSED PyObject *__pyx_self, __Pyx_memviewslice __pyx_v_w, double __pyx_v_alpha, double __pyx_v_beta, __Pyx_memviewslice __pyx_v_X, __Pyx_memviewslice __pyx_v_y, int __pyx_v_max_iter, double __pyx_v_tol, PyObject *__pyx_v_rng, int __pyx_v_random, int __pyx_v_positive) {
+ PyObject *__pyx_v_dtype = NULL;
+- void (*__pyx_v_gemv)(enum CBLAS_ORDER, enum CBLAS_TRANSPOSE, int, int, double, double *, int, double *, int, double, double *, int);
++ void (*__pyx_v_gemv)(CBLAS_ORDER, CBLAS_TRANSPOSE, int, int, double, double *, int, double *, int, double, double *, int);
+ double (*__pyx_v_dot)(int, double *, int, double *, int);
+ void (*__pyx_v_axpy)(int, double, double *, int, double *, int);
+ double (*__pyx_v_asum)(int, double *, int);
+@@ -16246,8 +16246,8 @@
+ CYTHON_UNUSED float (*__pyx_v_asum)(int, float *, int);
+ void (*__pyx_v_copy)(int, float *, int, float *, int);
+ void (*__pyx_v_scal)(int, float, float *, int);
+- void (*__pyx_v_ger)(enum CBLAS_ORDER, int, int, float, float *, int, float *, int, float *, int);
+- void (*__pyx_v_gemv)(enum CBLAS_ORDER, enum CBLAS_TRANSPOSE, int, int, float, float *, int, float *, int, float, float *, int);
++ void (*__pyx_v_ger)(CBLAS_ORDER, int, int, float, float *, int, float *, int, float *, int);
++ void (*__pyx_v_gemv)(CBLAS_ORDER, CBLAS_TRANSPOSE, int, int, float, float *, int, float *, int, float, float *, int);
+ unsigned int __pyx_v_n_samples;
+ unsigned int __pyx_v_n_features;
+ unsigned int __pyx_v_n_tasks;
+@@ -17965,8 +17965,8 @@
+ CYTHON_UNUSED double (*__pyx_v_asum)(int, double *, int);
+ void (*__pyx_v_copy)(int, double *, int, double *, int);
+ void (*__pyx_v_scal)(int, double, double *, int);
+- void (*__pyx_v_ger)(enum CBLAS_ORDER, int, int, double, double *, int, double *, int, double *, int);
+- void (*__pyx_v_gemv)(enum CBLAS_ORDER, enum CBLAS_TRANSPOSE, int, int, double, double *, int, double *, int, double, double *, int);
++ void (*__pyx_v_ger)(CBLAS_ORDER, int, int, double, double *, int, double *, int, double *, int);
++ void (*__pyx_v_gemv)(CBLAS_ORDER, CBLAS_TRANSPOSE, int, int, double, double *, int, double *, int, double, double *, int);
+ unsigned int __pyx_v_n_samples;
+ unsigned int __pyx_v_n_features;
+ unsigned int __pyx_v_n_tasks;