summaryrefslogtreecommitdiff
path: root/sci-libs/scikit-learn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/scikit-learn
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/scikit-learn')
-rw-r--r--sci-libs/scikit-learn/Manifest2
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.1.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index 267dfb3dead3..8a976a10f119 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,6 +1,8 @@
AUX scikit-learn-0.24.2-no-O3.patch 2346 BLAKE2B b4186a3e6a242ac964f4970adf227d2c6512141faf89828df60626aef73ab3d3de9fdeaf5fd31e230d196293b45feb11ff599a31b882ef86e1e563ff9209d7e6 SHA512 a6f2b74c424a000675ad838d95c71e459ca392f600875839cc5a740249a5db08e3d7968f87ae587398259d8dbf5ece91fe114f7c59581a32a03f3e9d183f81e8
DIST scikit-learn-0.24.2.tar.gz 7589697 BLAKE2B a5a32db690e76d6ecfcb12d57a7f84ebcc7e67ecb73258c1d923f9b98a9d87c46aac96918ef7c3d8741f5dbeb46f169c73a7744fb7b92e6ab5cf42101a6bc2f1 SHA512 2159baf63414b9594918b40e1b72af2ab47349335ad4e3afd9756921f786737ed41d6deb333881e8c5c6e1f7ce9cfa10691b966dc2476c48c051621f9049d2ee
DIST scikit-learn-1.0.2.tar.gz 6783296 BLAKE2B c5894b83c616117ac69e99d3eafe6b7218e085bfae099b41d09ecafc5cf116d4ef6849e69de2c1d833be1eb1e2479c1d200147ec1fcf73798c4e341dcaaa4d79 SHA512 1921a722ce887e04db94586a8100f435ca26038c32f1841ed8c7d5f17b5c7a3dbf5e036f5b0fca0f9907c32f80db5b082cb04141d14d22719ad78f3cfef51415
+DIST scikit-learn-1.1.1.gh.tar.gz 6896597 BLAKE2B c08bde0c531d221c40eb385ecdaa34e655442704142fe0e59b206ab17fb19ecf76866aad7dcf06f7eff3932be375ccbbdf43e150285b4f829bfb36604c963672 SHA512 366df2f0eea4d7ebf8e02829cd140c90299ee4a572e07e4e153032ffa650a990dd5ffc7d33bf8a23a4c76fdd97e296c801bc1471c79075f5631b1a341eb297ac
EBUILD scikit-learn-0.24.2.ebuild 1813 BLAKE2B 179cc80ad5984f5179f156ef4114fe1a009d2d6258c758f030e832f191c477b1c1b22758cbbdb51ac95d7ebdc52341f9bba6fde02482dbdccf92c19e82fbf774 SHA512 0877f97ab8bae1392b183fdf26bc7f5036c1b7ddf8c58fab8acf19e6756592aa3c05128e9c34416d11cb2202e7c886b44b5d3929a2bf120d078a52965762dbef
EBUILD scikit-learn-1.0.2.ebuild 1340 BLAKE2B 1984373b7d7f56884a502dd015ab1803f51e124baa76895a7a3e9f162836dc98f01df8497834857250a0bcd7cedcb9eb76b243ca4d4fdd9195f42f0f57926dbf SHA512 1d731915b21f348458a2443bd577cef7761f1aa644a8c7dbbd5f78762e19280f8bdcb2a041ab8adabc809042ca0889b9e266fcb95d466d2ccc2a34d8d0d68c6a
+EBUILD scikit-learn-1.1.1.ebuild 1529 BLAKE2B 3b307b4ef2f84580e777a08c6051672f05a04ce734cace26a1914154be548dea65de135440283d42c838dead454d97d539c30ddc338c989f33138f2e0675e72e SHA512 04d231193cd26225cee1b0a76fff119b29bbd7db7a5f085eead7c2d308b75f0410936451d058d04f6cb2b783f024daeb30496f6616d36c1d02c75ebaf71aea3e
MISC metadata.xml 614 BLAKE2B b5425c2d022592581647c9b97c0ab22bfc2afe347b2e5ea22f141245238f145322f39406c62318ba1e6af1462b2691267b39976bfde38faaf1d28b1d29c4e015 SHA512 74ac79123848bc385c29fcfdc4a1e780529dda685c1deb5eb722f5d4919ee6ac9d80798d52c4af0be0cc8dbbaea3784963dd97e2b7c1258cc2f5605b0bc8907a
diff --git a/sci-libs/scikit-learn/scikit-learn-1.1.1.ebuild b/sci-libs/scikit-learn/scikit-learn-1.1.1.ebuild
new file mode 100644
index 000000000000..5877d6d117d6
--- /dev/null
+++ b/sci-libs/scikit-learn/scikit-learn-1.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Machine learning library for Python"
+HOMEPAGE="https://scikit-learn.org/stable/"
+SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+# Fatal Python error: Segmentation fault
+RESTRICT="test"
+
+DEPEND="
+ virtual/blas:=
+ virtual/cblas:=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+# For some reason this wants to use urllib to fetch things from the internet
+# distutils_enable_sphinx doc \
+# dev-python/matplotlib \
+# dev-python/memory_profiler \
+# dev-python/numpydoc \
+# dev-python/pandas \
+# dev-python/pillow \
+# dev-python/seaborn \
+# dev-python/sphinx-gallery \
+# dev-python/sphinx-prompt \
+# sci-libs/scikit-image
+
+python_test() {
+ # This needs to be run in the install dir
+ cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
+ distutils-r1_python_test
+}
+
+python_install_all() {
+ find "${S}" -name \*LICENSE.txt -delete || die
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}